View Issue Details

IDProjectCategoryView StatusLast Update
0011604mantisbtchange logpublic2017-01-31 04:02
Reporterotilia.borretaAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.0 
Target Version2.1.0Fixed in Version2.1.0 
Summary0011604: Versions marked as obsolete appear on change log page
Description

As far as I understood, obsolete versions shouldn't appear on the change-log page. I quick-fixed it here by commenting out the line 143 in changelog_page.php:

version_cache_array_rows( $t_project_ids );

The problem actually is in core/version_api.php, function version_get_all_rows(). Once a project version is in the cache, the parameters $p_released, $p_obsolete and $p_inherit are not considered anymore, thus all versions are returned.

Tagspatch

Relationships

related to 0017145 feedback Need to show obsolete versions in Change Log. 

Activities

nimmich

nimmich

2010-03-17 19:18

reporter   ~0024783

This seems to be related to 0010873. At least the quick fix is the same, and again it's core/version_api.php:version_get_all_rows() where the real fix should be done.

Lapinkiller

Lapinkiller

2011-05-27 09:15

reporter   ~0028858

"obsolete versions shouldn't appear on the change-log page"

I'm not agree.. i think that obsolete versions have to appear on changelog page.

Else why having Roadmap AND Changelog... ;)

cbradney

cbradney

2012-06-12 16:42

reporter   ~0032087

It would be nice to either have another tag to say yes to showing on the change log page, or have multiple pages generated, .. or set a date limit or version count limit. The changelog page can appear empty if your php memory is too low and the version data is too great (bugs.scribus.net changelog)

Dentxinho

Dentxinho

2012-07-13 13:23

reporter   ~0032324

Better to add some pagination.
But i guess this is not an issue.

vboctor

vboctor

2014-03-28 02:52

manager   ~0039773

I'll have to double check the code, but I believe our intention for this feature was to hide the version from the change log since it is so old. There could be other uses of this flag, but I believe this was the only / main one. If there is a desire to still keep it in the change log, then don't mark it as obsolete. I don't believe we need another flag.

artiflo

artiflo

2015-05-11 12:12

reporter   ~0050732

I update my old mantis to 1.2.19 and I discover this feature drawback. :/

Why you do that ?

I am agree with Lapinkiller, I think that obsolete versions have to appear on changelog page.

Please return on the first idea and show in changelog all version.

ric

ric

2016-04-26 09:09

reporter   ~0053025

I've just installed version 1.2.19 and I'd like to see all the versions in the changelog.

I've modified line 157 of

FROM
$t_version_rows = version_get_all_rows( $t_project_id, / released / null, / obsolete / false);

TO
$t_version_rows = version_get_all_rows( $t_project_id, / released / null, / obsolete / true );

ric

ric

2016-04-26 09:10

reporter   ~0053026

I'm sorry I missed the filename:

I've modified line 157 of changelog_page.php

ric

ric

2016-04-27 08:31

reporter   ~0053031

Hi Guys it works setting the parameters as follow:
$t_version_rows = version_get_all_rows( $t_project_id, / released / null, / obsolete / null );

because with this
$t_version_rows = version_get_all_rows( $t_project_id, / released / null, / obsolete / true);
the non obsolete versions are hidden

vboctor

vboctor

2017-01-01 16:00

manager   ~0054888

PR: https://github.com/mantisbt/mantisbt/pull/983

dregad

dregad

2017-01-02 06:56

developer   ~0054891

While the fix restores the changelog page functionality as it was intended, I believe we should consider the fact that some people want to display obsolete versions too.

To allow that, the Changelog page should offer some basic filtering ability.

vboctor

vboctor

2017-01-03 23:23

manager   ~0054909

I will leave it for one of the motivated users to open a new bug report and provide a good explanation of why we would need to include obsolete versions in changelog and why wouldn't we achieve that by unmarking them as obsolete. Is it a requirement to remove the version from version drop downs but have it appear in the changelog?

If there is a compelling reason, then we can consider options like a "Include in Changelog flag" for each version, or a configuration option that decides whether "obsolete" should show up in changelog or not.

atrol

atrol

2017-01-04 02:29

developer   ~0054910

I will leave it for one of the motivated users to open a new bug report
See 0017145 especially 0017145:0050788

Lapinkiller

Lapinkiller

2017-01-05 08:43

reporter   ~0054941

Why can't you make it as an option in Mantis ?

dregad

dregad

2017-01-05 09:28

developer   ~0054942

@Lapinkiller and other interested in seeing Obsolete versions in Changelog, please continue the discussion in 0017145

Why can't you make it as an option in Mantis ?

This is more or less what I'm suggesting (see 0011604:0054891, 0017145:0054913)

Related Changesets

MantisBT: master 92cdfde8

2017-01-03 23:20:54

vboctor


Committer: GitHub Details Diff
Don’t show obsolete versions in Changelog (0000983)

Fixes 0011604
mod - changelog_page.php Diff File
mod - core/version_api.php Diff File

Issue History

Date Modified Username Field Change
2010-03-03 10:24 otilia.borreta New Issue
2010-03-04 03:49 dhx Status new => confirmed
2010-03-04 03:49 dhx Target Version => 1.2.2
2010-03-17 19:18 nimmich Note Added: 0024783
2010-04-21 09:14 jreese Target Version 1.2.1 => 1.2.2
2010-07-29 10:41 jreese Target Version 1.2.2 => 1.2.3
2010-09-14 10:55 jreese Target Version 1.2.3 => 1.2.4
2010-12-14 21:05 jreese Target Version 1.2.4 => 1.2.5
2011-04-05 12:25 jreese Target Version 1.2.5 => 1.2.6
2011-05-27 09:15 Lapinkiller Note Added: 0028858
2011-07-26 09:53 jreese Target Version 1.2.6 => 1.2.7
2011-08-22 10:49 jreese Target Version 1.2.7 => 1.2.8
2011-09-06 10:33 jreese Target Version 1.2.8 => 1.2.9
2012-03-04 09:23 atrol Target Version 1.2.9 => 1.2.10
2012-04-02 02:33 atrol Target Version 1.2.10 => 1.2.11
2012-06-06 23:54 jreese Target Version 1.2.11 => 1.2.12
2012-06-12 16:42 cbradney Note Added: 0032087
2012-07-13 13:23 Dentxinho Note Added: 0032324
2012-11-10 19:04 dregad Target Version 1.2.12 => 1.2.13
2013-01-22 09:48 dregad Target Version 1.2.13 => 1.2.14
2013-01-29 09:28 dregad Target Version 1.2.14 => 1.2.15
2013-04-12 09:57 dregad Target Version 1.2.15 => 1.2.16
2014-01-23 17:52 atrol Target Version 1.2.16 =>
2014-03-28 02:52 vboctor Note Added: 0039773
2014-04-01 14:40 atrol Relationship added related to 0017145
2015-05-11 12:12 artiflo Note Added: 0050732
2016-04-26 09:09 ric Note Added: 0053025
2016-04-26 09:10 ric Note Added: 0053026
2016-04-27 08:31 ric Note Added: 0053031
2016-12-30 18:16 vboctor Tag Attached: patch
2016-12-30 18:17 vboctor Assigned To => vboctor
2016-12-30 18:17 vboctor Status confirmed => assigned
2016-12-30 18:17 vboctor Target Version => 2.0.1
2017-01-01 16:00 vboctor Note Added: 0054888
2017-01-02 06:56 dregad Note Added: 0054891
2017-01-03 23:20 vboctor Changeset attached => MantisBT master 92cdfde8
2017-01-03 23:20 vboctor Status assigned => resolved
2017-01-03 23:20 vboctor Resolution open => fixed
2017-01-03 23:20 vboctor Fixed in Version => 2.1.0
2017-01-03 23:23 vboctor Note Added: 0054909
2017-01-04 02:29 atrol Note Added: 0054910
2017-01-05 08:43 Lapinkiller Note Added: 0054941
2017-01-05 09:28 dregad Note Added: 0054942
2017-01-11 07:08 atrol Target Version 2.0.1 => 2.1.0
2017-01-31 04:02 vboctor Status resolved => closed