View Issue Details

IDProjectCategoryView StatusLast Update
0017005mantisbtbugtrackerpublic2017-09-03 05:31
ReporterBascyAssigned Toatrol 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version1.2.16 
Target VersionFixed in Version 
Summary0017005: Allow changing the Priority only above certain permission level
Description

As most reporters have the tendency to set the priority of every issue they report to High (it is after all a big problem to him!) I suggest that setting and changing the priority of a bug should be allowed only from a certain permission level, like it is for i.e. the Handler.

Additional Information

A separate config setting "update_bugg_priority_threshold" could be added, or the already existing "update_bug_assign_threshold" could be used for this.

Modifications consist further of changing line 149 of bug_report_page.php into:

$tpl_show_priority = in_array( 'priority', $t_fields ) && access_has_project_level( config_get( 'update_bug_assign_threshold' ) ); 
TagsNo tags attached.

Relationships

duplicate of 0023208 new Threshold for setting fields such as priority 

Activities

atrol

atrol

2017-08-10 15:42

developer   ~0057424

Resolving this one as duplicate as the request is covered by the more generic request 0023208.

Issue History

Date Modified Username Field Change
2014-02-20 03:29 Bascy New Issue
2017-08-10 15:42 atrol Assigned To => atrol
2017-08-10 15:42 atrol Status new => resolved
2017-08-10 15:42 atrol Resolution open => duplicate
2017-08-10 15:42 atrol Note Added: 0057424
2017-08-10 15:42 atrol Relationship added duplicate of 0023208
2017-09-03 05:31 atrol Status resolved => closed