View Issue Details

IDProjectCategoryView StatusLast Update
0020565mantisbtdb mssqlpublic2017-04-19 17:28
ReporterclevertiQAAssigned Tocproensa 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows Server OS Version2012
Product Version1.3.0-rc.1 
Target VersionFixed in Version 
Summary0020565: Installation crashes when using SQL Server 2012
Description

When performing a clean installation of Mantis 1.3.0-rc1 on a windows server 2012 machine with IIS and SQL Server 2012, the process fails.

This bug is similar to bug https://www.mantisbt.org/bugs/view.php?id=9315

Steps To Reproduce

Install Mantis 1.3.0 rc1 with SQL Server

TagsNo tags attached.

Relationships

related to 0009315 closeddregad admin/install.php fails because of wrong ALTER TABLE 
related to 0022063 closeddregad Installation on MSSQL fails at step 209 

Activities

clevertiQA

clevertiQA

2016-02-03 12:35

reporter  

Mantis_130_installation.png (Attachment missing)
AlexeiK

AlexeiK

2016-02-09 07:16

reporter   ~0052491

i can present method to setup mantisbt 1.2 on MSSQL 2008
there is a small hit:
when we installing mantisBT we must use $g_db_type = 'odbc_mssql'
when we using mantisBT we must switch to $g_db_type ='mssqlnative'
the same thing with $g_hostname = 'Driver={SQL Server};SERVER=(local)\old;DATABASE=mantis;UID=mantisdb;PWD=123;'; (for ODBC)
$g_hostname ='(local)\old';(for MSSQL)

and dont forget you cant install ver 1.3 on MS SQL 2000.

AlexeiK

AlexeiK

2016-02-09 07:18

reporter   ~0052492

wihtout patches 1.3.0. rc1
at https://www.mantisbt.org/forums/viewtopic.php?f=4&t=21339&start=30#p58621
you cant install this on MS SQL >=2005.

Because ADOdb provider is broken.

AlexeiK

AlexeiK

2016-02-09 07:24

reporter   ~0052493

ADOdb included with 1.3.0 rc1 has no support for MS SQL.
its simple absent.
and on picture we see executing not modified T-SQL for MS SQL .
this SQL must be sliced to three SQL statements.
read this for details.
https://www.mantisbt.org/forums/viewtopic.php?f=4&t=21339&start=15#p58602

AlexeiK

AlexeiK

2016-02-09 07:27

reporter   ~0052494

but 1.2.0 ADOdb provider has full support for MS SQL.
the diff is 1.3.0 has resetted php files for MS SQL code.

AlexeiK

AlexeiK

2016-02-09 07:28

reporter   ~0052495

there is some commit about this
https://github.com/mantisbt/mantisbt/commit/19dbfb0e290a30fcfe1ec29566e611d36c1c7aa9

this commit adds this resetted code for MS SQL.

clevertiQA

clevertiQA

2016-02-10 06:59

reporter   ~0052505

Following the suggestion on the first note, I tried to do a clean installation using 1.2.19 with SQL Server 2012 but without success.

I set my configuration in config_inc.php as:
$g_hostname = 'Driver={SQL Server Native Client 11.0};SERVER=localhost;DATABASE=bugtracker1219;UID=mantis;PWD=mantis;';
$g_db_type = 'odbc_mssql';

The installation crashes on:
BAD
ALTER TABLE mantis_user_pref_table ALTER COLUMN redirect_delay INT DEFAULT 0 NOT NULL
[Microsoft][SQL Server Native Client 11.0][SQL Server]Incorrect syntax near the keyword 'DEFAULT'.

AlexeiK

AlexeiK

2016-02-10 13:38

reporter   ~0052509

not Driver={SQL Server Native Client 11.0}
must be $g_db_type ='odbc_mssql'

AlexeiK

AlexeiK

2016-02-10 13:38

reporter   ~0052510

and Driver={SQL Server}

cproensa

cproensa

2017-04-04 05:59

developer   ~0056366

Fixed by 0022063

Issue History

Date Modified Username Field Change
2016-02-03 12:35 clevertiQA New Issue
2016-02-03 12:35 clevertiQA File Added: Mantis_130_installation.png
2016-02-03 17:40 atrol Category installation => db mssql
2016-02-03 17:41 atrol Relationship added related to 0009315
2016-02-09 07:16 AlexeiK Note Added: 0052491
2016-02-09 07:18 AlexeiK Note Added: 0052492
2016-02-09 07:24 AlexeiK Note Added: 0052493
2016-02-09 07:27 AlexeiK Note Added: 0052494
2016-02-09 07:28 AlexeiK Note Added: 0052495
2016-02-10 06:59 clevertiQA Note Added: 0052505
2016-02-10 13:38 AlexeiK Note Added: 0052509
2016-02-10 13:38 AlexeiK Note Added: 0052510
2017-04-04 05:58 cproensa Relationship added related to 0022063
2017-04-04 05:59 cproensa Assigned To => cproensa
2017-04-04 05:59 cproensa Status new => resolved
2017-04-04 05:59 cproensa Resolution open => fixed
2017-04-04 05:59 cproensa Note Added: 0056366
2017-04-19 17:28 atrol Status resolved => closed