View Issue Details

IDProjectCategoryView StatusLast Update
0021592mantisbtfilterspublic2017-01-14 17:42
Reportervboctor 
Assigned Tocproensa 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.3.0 
Target Version2.1.xFixed in Version2.1.x 
Summary0021592: Unknown column 'mantis_bug_table.tags'
Description

A couple of users reported this issue

Message : APPLICATION ERROR 0000401
Database query failed. Error received from database was #1054: Unknown column mantis_bug_table.tags in order clause for the query: SELECT DISTINCT mantis_bug_table.* FROM mantis_bug_table JOIN mantis_project_table ON mantis_project_table.id = mantis_bug_table.project_id WHERE mantis_project_table.enabled = ? AND ( mantis_bug_table.project_id = 2 ) AND ( ( mantis_bug_table.handler_id=2 ) AND ( mantis_bug_table.status in (?, ?, ?, ?, ?, ?) ) ) ORDER BY mantis_bug_table.sticky DESC, mantis_bug_table.tags DESC, mantis_bug_table.priority DESC, mantis_bug_table.last_updated DESC, mantis_bug_table.date_submitted DESC.
Please use the Back button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

Steps To Reproduce
  • In My Account / Manage Columns, add tags to View Issues Columns
  • Open View Issues page
  • Click on Sort by, Select tags, apply filter
Tagsmantishub

Relationships

related to 0021595 new When a filter generates a bad query, reset the filter 
child of 0021935 resolvedcproensa Filter api refactoring, manage stored filters 

Activities

dregad

dregad

2016-08-09 04:25

developer   ~0053763

Looks like a query generated by filter api

dregad

dregad

2016-08-09 04:31

developer   ~0053764

Added repro steps. Also changed the product and target version, as this bug also exists in 1.3.

Since its not possible to sort by tags by clicking on the column header. I dont think the field should be available in the selection list either.

cproensa

cproensa

2016-08-09 06:57

developer   ~0053765

i have a lot of clean up for filter api, which includes many bug fixes in PR https://github.com/mantisbt/mantisbt/pull/783

this could be included, but need to refresh again that branch and agree on what to implement

dregad

dregad

2016-08-09 09:25

developer   ~0053771

Ill have a look at your PR.

cproensa

cproensa

2016-10-17 07:20

developer   ~0054246

This also happens for other columns:
example: notes, overdue

plugin columns, which are not sortable, are selectable, however it doesnt fail.
(sortable plugin columns work ok)

cproensa

cproensa

2016-10-17 16:49

developer   ~0054253

Ive included the fix in PR https://github.com/mantisbt/mantisbt/pull/862

Issue History

Date Modified Username Field Change
2016-08-09 01:12 vboctor New Issue
2016-08-09 01:12 vboctor Tag Attached: mantishub
2016-08-09 01:13 vboctor Target Version => 2.0.0-beta.2
2016-08-09 04:25 dregad Note Added: 0053763
2016-08-09 04:31 dregad Status new => confirmed
2016-08-09 04:31 dregad Product Version 2.0.0-beta.1 => 1.3.0
2016-08-09 04:31 dregad Target Version 2.0.0-beta.2 => 1.3.1
2016-08-09 04:31 dregad Description Updated View Revisions
2016-08-09 04:31 dregad Steps to Reproduce Updated View Revisions
2016-08-09 04:31 dregad Note Added: 0053764
2016-08-09 06:57 cproensa Note Added: 0053765
2016-08-09 09:25 dregad Note Added: 0053771
2016-08-09 12:15 vboctor Relationship added related to 0021595
2016-08-28 10:37 atrol Target Version 1.3.1 => 1.3.2
2016-10-02 19:36 atrol Target Version 1.3.2 => 1.3.3
2016-10-17 07:20 cproensa Note Added: 0054246
2016-10-17 16:49 cproensa Assigned To => cproensa
2016-10-17 16:49 cproensa Status confirmed => assigned
2016-10-17 16:49 cproensa Note Added: 0054253
2016-10-30 23:23 vboctor Target Version 1.3.3 => 1.3.4
2016-11-20 16:00 cproensa Relationship added child of 0021935
2016-11-27 08:22 dregad Target Version 1.3.4 => 1.3.5
2016-12-30 16:24 atrol Target Version 1.3.5 => 1.3.x
2017-01-14 17:41 cproensa Status assigned => resolved
2017-01-14 17:41 cproensa Resolution open => fixed
2017-01-14 17:41 cproensa Fixed in Version => 2.1.x
2017-01-14 17:42 cproensa Target Version 1.3.x => 2.1.x