View Issue Details

IDProjectCategoryView StatusLast Update
0021927mantisbtadministrationpublic2017-01-12 12:15
ReportervboctorAssigned Tojoel 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version2.0.0-rc.1 
Target Version2.0.0Fixed in Version2.0.0 
Summary0021927: System utilities page for moving attachments should support move all attachments
Description

At the moment, the page supports moving attachments for one project at a time. This can be painful when there are a lot of projects.

TagsNo tags attached.

Activities

vboctor

vboctor

2016-11-17 23:06

manager   ~0054537

A couple of things I don't understand in current design:

  • Why do we support per project export? I would expect admin to export all and use either DATABASE attachments or disk attachments.
  • If there is a reason to export a project or a set of projects, then why use a radio button and not checkboxes to enable selecting multiple projects.

I would be happy with just adding Move All, but was wondering about the rational behind the original design.

atrol

atrol

2016-11-18 02:18

developer   ~0054539

but was wondering about the rational behind the original design

Maybe a partial workaround if max_execution_time can't be set to unlimited due to various reasons (no access to php.ini in hosted environment, running PHP in safe mode)

joel

joel

2016-11-29 08:40

developer   ~0054631

PR: https://github.com/mantisbt/mantisbt/pull/964

Related Changesets

MantisBT: master 900469d8

2016-11-29 08:22:53

Joel C. Llano


Committer: vboctor Details Diff
Allow moving attachments for multiple projects

- replaced radio button with checkbox
- minor layout adjustments
- refactor logic in action page to make sure multiple project selection works

Fixes 0021927
mod - admin/move_attachments.php Diff File
mod - admin/move_attachments_page.php Diff File

MantisBT: master 0824a881

2016-11-29 23:01:32

Joel C. Llano


Committer: vboctor Details Diff
Improve efficiency of processing

- show message if there is no project selected
- keep old message to cover the case only if projects is selected (optimized)
- fixed coding standards

Fixes 0021927
mod - admin/move_attachments.php Diff File

Issue History

Date Modified Username Field Change
2016-11-17 22:39 vboctor New Issue
2016-11-17 23:06 vboctor Note Added: 0054537
2016-11-18 02:18 atrol Note Added: 0054539
2016-11-29 08:40 joel Note Added: 0054631
2016-12-28 22:55 vboctor Changeset attached => MantisBT master 900469d8
2016-12-28 22:55 vboctor Changeset attached => MantisBT master 0824a881
2016-12-28 22:55 vboctor Assigned To => vboctor
2016-12-28 22:55 vboctor Status new => resolved
2016-12-28 22:55 vboctor Resolution open => fixed
2016-12-28 22:55 vboctor Fixed in Version => 2.0.0
2016-12-28 22:56 vboctor Assigned To vboctor => user36846
2016-12-28 22:56 vboctor Reproducibility have not tried => N/A
2016-12-28 22:56 vboctor Target Version => 2.0.0
2016-12-30 15:54 vboctor Status resolved => closed
2017-01-12 12:15 vboctor Assigned To user36846 => joel