View Issue Details

IDProjectCategoryView StatusLast Update
0022113mantisbtlocalizationpublic2017-01-31 04:02
ReporterNikerabbit 
Assigned Todregad 
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target Version2.1.0Fixed in Version2.1.0 
Summary0022113: translatewiki.net integration updates
Description

One question and one request.

translatewiki.net is currently using branch master-1.3.x. When would it be appropriate to switch to master-2.0.x?

Also, we have created a dedicated account for pushing translation updates. https://github.com/translatewiki
Could you add that with same access which Nikerabbit and Siebrand have currently?

TagsNo tags attached.

Relationships

Activities

atrol

atrol

2017-01-05 03:36

developer   ~0054930

When would it be appropriate to switch to master-2.0.x

I think ASAP as

  • we need some translations for new strings that have not been part of 1.3.x , e.g. see 0022009
  • some strings which are no longer used should be removed in translations to avoid warnings when running admin/check/test_langs.php
atrol

atrol

2017-01-05 03:41

developer   ~0054931

Could you add that with same access which Nikerabbit and Siebrand have currently?

You could send a "Request to join" to
https://github.com/orgs/mantisbt/teams/translatewiki-net

Siebrand is the "Team maintainer" for it and could accept the request.

In case of problems, @dregad might assist.

dregad

dregad

2017-01-05 04:08

developer   ~0054932

@Nikerabbit I was actually going to write to you guys yesterday to ask you about switching, but I got sidetracked and forgot about it :-) As altrol said, you can make the switch to master-2.0.x at your earliest convenience.

For discussion: wouldn't it be better to switch to master instead of master_2.0.x (we can still backport the commits if necessary).

re: access for translatewiki, I just sent an invitation to the translatewiki.net team, which you'll need to accept before you can push with this account. Let me know if your personal accounts should remain in in the team or if you want them removed.

atrol

atrol

2017-01-05 04:28

developer   ~0054933

wouldn't it be better to switch to master instead of master_2.0.x (we can still backport the commits if necessary).

  • translations of new messages introduced in 2.1.x will be quite complete when releasing 2.1.0
  • backports to master-2.0.x will not be that easy if messages are removed in master
  • translators will not be able to update messages in 2.0.x if they are removed in master

Delaying removal of messages to the next minor release could be an option to overcome the cons.

The best solution would be if translatewiki could offer branches.

Nikerabbit

Nikerabbit

2017-01-05 04:40

developer   ~0054934

Thanks for fast response!

My account's rights can be removed, but please wait until the translatewiki account is set up and confirmed to work. I hope Siebrand can confirm what he wants to be done with his account.

I don't remember the history why we are using a stable branch, but I would support using the master branch. That's what most other projects do.

There is some support in our side for handling multiple branches intelligently, but it has not been used in a while and it will need some work to make it work.

dregad

dregad

2017-01-05 05:46

developer   ~0054938

  • backports to master-2.0.x will not be that easy if messages are removed in master

I don't think that's something which happens very frequently, so we can probably live with that.

  • translators will not be able to update messages in 2.0.x if they are removed in master

Not likely to be a problem, considering that removed messages would probably have been present in the code for quite some time. (i.e. I don't think we'd often be removing in 2.1 a string that was added in 2.0)

Delaying removal of messages to the next minor release could be an option to overcome the cons.

I'm not sure I'm following you here. If I understand you correctly, doing that would only delay the problem, wouldn't it ?

Anyway, in line with the ongoing discussion triggered by @vboctor about release management, focusing on monthly feature releases and reserving patch releases for bug fixes, means that we'll have less focus on the latter.

There is some support in our side for handling multiple branches intelligently, but it has not been used in a while and it will need some work to make it work.

I'm not sure that's really worth the effort and likely added complexity on the translators' side.

vboctor

vboctor

2017-01-05 22:26

manager   ~0054951

We should have translatewiki work off the master branch and not master-2.0.x. With the monthly releases, that would work best.

atrol

atrol

2017-01-06 02:38

developer   ~0054953

Delaying removal of messages to the next minor release could be an option to overcome the cons.
If I understand you correctly, doing that would only delay the problem, wouldn't it ?

It would allow easy back ports at least for the first round of corrections.

All in all, we should go for master.

dregad

dregad

2017-01-06 05:49

developer   ~0054957

Following the general agreement on switching to 'master' branch @Nikerabbit @siebrand kindly push one last round of translations to master-1.3.x branch, then make the switch to master.

Thanks for your support.

Nikerabbit

Nikerabbit

2017-01-07 05:13

developer   ~0054973

Uh oh, I already switched to the master branch. It doesn't make sense to export to 1.3.x now after the switch.

dregad

dregad

2017-01-11 06:33

developer   ~0055049

I already switched to the master branch.

That's unfortunate.

It doesnt make sense to export to 1.3.x now after the switch.

I agree it doesn't. We'll live without it.

@Nikerabbit Can you please push the updated translations to master ASAP ?

Nikerabbit

Nikerabbit

2017-01-11 13:47

developer   ~0055058

Last edited: 2017-01-11 14:54

View 2 revisions

There is a problem with master branch I only noticed now:

remote: error: GH006: Protected branch update failed for refs/heads/master.

remote: error: At least one approved review is required

Unless that can be worked around, it seems we need to go back to another branch.

dregad

dregad

2017-01-11 18:34

developer   ~0055063

This is Github's pull request approval mechanism which prevents direct pushed to master branch.

I'll ask Github support if there's something that can be done about it about it (e.g make an exception allowing push by specific user). If not, or until a solution is available, I see the following options:

  1. disable branch protection / PR approval
  2. push to master-2.0.x
  3. implement a mechanism whereby translation updates are submitted as pull requests, which can be merged manually.
vboctor

vboctor

2017-01-12 02:09

manager   ~0055071

@dregad Did you mean push to master rather than master-2.0.x?

dregad

dregad

2017-01-12 03:38

developer   ~0055072

Did you mean push to master rather than master-2.0.x?

No, 2.0.x is really what I meant, as a workaround since pushing to master is blocked by Github's branch protection (PR review process).

That being said, I may have found a solution... @Nikerabbit would you please try again to push the changes to master ?

vboctor

vboctor

2017-01-12 12:12

manager   ~0055086

@dregad glad you (hopefully) found a solution. Let's only commit localizations to master, even if we need to remove the protection policy.

Nikerabbit

Nikerabbit

2017-01-15 21:33

developer   ~0055141

Some delay, as I'm traveling. The error has changed but is still there:

remote: error: GH006: Protected branch update failed for refs/heads/master.
remote: error: You're not authorized to push to this branch. Visit https://help.github.com/articles/about-protected-branches/ for more information.
To git@github.com:mantisbt/mantisbt.git
! [remote rejected] master -> master (protected branch hook declined)

dregad

dregad

2017-01-23 04:54

developer   ~0055260

@Nikerabbit, could you please try again ?

Nikerabbit

Nikerabbit

2017-01-23 07:27

developer   ~0055265

Still

remote: error: GH006: Protected branch update failed for refs/heads/master.
remote: error: At least one approved review is required
To git@github.com:mantisbt/mantisbt.git
! [remote rejected] master -> master (protected branch hook declined)
error: failed to push some refs to 'git@github.com:mantisbt/mantisbt.git'

dregad

dregad

2017-01-23 11:31

developer   ~0055271

Sorry about that >:(

After additional testing, I've come to the conclusion that unless Github introduces a whitelist to bypass the branch protection, there is simply no way to enable pushing to the master branch, while maintaining required pull request reviews.

@vboctor, possible workarounds are

  1. Setup translatewiki account as Admin for mantisbt repository, so they are not affected by the requirement checks. On top of rights they already have, that would allow them to add users to the repository.
  2. Disable Require pull request reviews before merging setting for master branch. That's the easiest, but we lose the mandatory review, which I think is useful.
  3. Setup a dedicated "translatewiki" branch without protection, that TW team can push to without constraints. This adds overhead, as the branch has to be kept in sync with master (i.e. merge before pushing updated translations, and cherry-pick or merge back into master after that)
  4. Have the translations process go through pull requests as any other change. That would require extra work on TW team to automate (e.g. calling Github API to open a PR), which may not be acceptable for them.

1 is easiest if the elevated privilege is acceptable, 2 is equally easy but I hate to lose the mandatory review. 3 & 4 require extra work on our side or theirs. @Nikerabbit @siebrand your thoughts on the above options would be appreciated.

In the meanwhile, I have disabled protection (i.e. option 2) so we can have updated translations for 2.1 release (@Nikerabbit, please try once more).

vboctor

vboctor

2017-01-24 02:41

manager   ~0055277

@dregad I would go with option 2 for now.

siebrand

siebrand

2017-01-26 05:50

developer   ~0055333

@dregad: Can you please also grant @translatewiki the same access @nikerabbit and I have in https://github.com/orgs/mantisbt-plugins?

Related Changesets

MantisBT: master abbb122c

2017-01-23 11:50:36

translatewiki.net

Details Diff
Localisation updates from https://translatewiki.net.
mod - lang/strings_afrikaans.txt Diff File
mod - lang/strings_amharic.txt Diff File
mod - lang/strings_arabic.txt Diff File
mod - lang/strings_arabicegyptianspoken.txt Diff File
mod - lang/strings_asturian.txt Diff File
mod - lang/strings_basque.txt Diff File
mod - lang/strings_belarusian_tarask.txt Diff File
mod - lang/strings_breton.txt Diff File
mod - lang/strings_bulgarian.txt Diff File
mod - lang/strings_catalan.txt Diff File
mod - lang/strings_chinese_simplified.txt Diff File
mod - lang/strings_chinese_traditional.txt Diff File
mod - lang/strings_czech.txt Diff File
mod - lang/strings_danish.txt Diff File
mod - lang/strings_dutch.txt Diff File
mod - lang/strings_estonian.txt Diff File
mod - lang/strings_finnish.txt Diff File
mod - lang/strings_french.txt Diff File
mod - lang/strings_galician.txt Diff File
mod - lang/strings_german.txt Diff File
mod - lang/strings_greek.txt Diff File
mod - lang/strings_hebrew.txt Diff File
mod - lang/strings_hungarian.txt Diff File
mod - lang/strings_icelandic.txt Diff File
mod - lang/strings_interlingua.txt Diff File
mod - lang/strings_italian.txt Diff File
mod - lang/strings_japanese.txt Diff File
mod - lang/strings_korean.txt Diff File
mod - lang/strings_latvian.txt Diff File
mod - lang/strings_lithuanian.txt Diff File
mod - lang/strings_macedonian.txt Diff File
mod - lang/strings_norwegian_bokmal.txt Diff File
mod - lang/strings_occitan.txt Diff File
mod - lang/strings_polish.txt Diff File
mod - lang/strings_portuguese_brazil.txt Diff File
mod - lang/strings_portuguese_standard.txt Diff File
mod - lang/strings_qqq.txt Diff File
mod - lang/strings_ripoarisch.txt Diff File
mod - lang/strings_romanian.txt Diff File
mod - lang/strings_russian.txt Diff File
mod - lang/strings_serbian.txt Diff File
mod - lang/strings_serbian_latin.txt Diff File
mod - lang/strings_slovak.txt Diff File
mod - lang/strings_spanish.txt Diff File
mod - lang/strings_swedish.txt Diff File
mod - lang/strings_swissgerman.txt Diff File
mod - lang/strings_tagalog.txt Diff File
mod - lang/strings_turkish.txt Diff File
mod - lang/strings_ukrainian.txt Diff File
mod - lang/strings_urdu.txt Diff File
mod - lang/strings_vietnamese.txt Diff File
mod - plugins/MantisCoreFormatting/lang/strings_belarusian_tarask.txt Diff File
mod - plugins/MantisCoreFormatting/lang/strings_chinese_simplified.txt Diff File
mod - plugins/MantisCoreFormatting/lang/strings_chinese_traditional.txt Diff File
mod - plugins/MantisCoreFormatting/lang/strings_czech.txt Diff File
mod - plugins/MantisCoreFormatting/lang/strings_french.txt Diff File
mod - plugins/MantisCoreFormatting/lang/strings_german.txt Diff File
mod - plugins/MantisCoreFormatting/lang/strings_macedonian.txt Diff File
mod - plugins/MantisCoreFormatting/lang/strings_polish.txt Diff File
mod - plugins/MantisCoreFormatting/lang/strings_portuguese_brazil.txt Diff File
mod - plugins/MantisGraph/lang/strings_arabic.txt Diff File
mod - plugins/MantisGraph/lang/strings_arabicegyptianspoken.txt Diff File
mod - plugins/MantisGraph/lang/strings_asturian.txt Diff File
mod - plugins/MantisGraph/lang/strings_belarusian_tarask.txt Diff File
mod - plugins/MantisGraph/lang/strings_breton.txt Diff File
mod - plugins/MantisGraph/lang/strings_bulgarian.txt Diff File
mod - plugins/MantisGraph/lang/strings_catalan.txt Diff File
mod - plugins/MantisGraph/lang/strings_chinese_simplified.txt Diff File
mod - plugins/MantisGraph/lang/strings_chinese_traditional.txt Diff File
mod - plugins/MantisGraph/lang/strings_czech.txt Diff File
mod - plugins/MantisGraph/lang/strings_danish.txt Diff File
mod - plugins/MantisGraph/lang/strings_diq.txt Diff File
mod - plugins/MantisGraph/lang/strings_dutch.txt Diff File
mod - plugins/MantisGraph/lang/strings_estonian.txt Diff File
mod - plugins/MantisGraph/lang/strings_finnish.txt Diff File
mod - plugins/MantisGraph/lang/strings_french.txt Diff File
mod - plugins/MantisGraph/lang/strings_galician.txt Diff File
mod - plugins/MantisGraph/lang/strings_german.txt Diff File
mod - plugins/MantisGraph/lang/strings_hebrew.txt Diff File
mod - plugins/MantisGraph/lang/strings_hungarian.txt Diff File
mod - plugins/MantisGraph/lang/strings_interlingua.txt Diff File
mod - plugins/MantisGraph/lang/strings_italian.txt Diff File
mod - plugins/MantisGraph/lang/strings_japanese.txt Diff File
mod - plugins/MantisGraph/lang/strings_korean.txt Diff File
mod - plugins/MantisGraph/lang/strings_lb.txt Diff File
mod - plugins/MantisGraph/lang/strings_lithuanian.txt Diff File
mod - plugins/MantisGraph/lang/strings_macedonian.txt Diff File
mod - plugins/MantisGraph/lang/strings_norwegian_bokmal.txt Diff File
mod - plugins/MantisGraph/lang/strings_occitan.txt Diff File
mod - plugins/MantisGraph/lang/strings_pms.txt Diff File
mod - plugins/MantisGraph/lang/strings_polish.txt Diff File
mod - plugins/MantisGraph/lang/strings_portuguese_brazil.txt Diff File
mod - plugins/MantisGraph/lang/strings_portuguese_standard.txt Diff File
mod - plugins/MantisGraph/lang/strings_qqq.txt Diff File
mod - plugins/MantisGraph/lang/strings_ripoarisch.txt Diff File
mod - plugins/MantisGraph/lang/strings_romanian.txt Diff File
mod - plugins/MantisGraph/lang/strings_russian.txt Diff File
mod - plugins/MantisGraph/lang/strings_serbian.txt Diff File
mod - plugins/MantisGraph/lang/strings_serbian_latin.txt Diff File
mod - plugins/MantisGraph/lang/strings_slovak.txt Diff File
mod - plugins/MantisGraph/lang/strings_spanish.txt Diff File
mod - plugins/MantisGraph/lang/strings_swedish.txt Diff File
mod - plugins/MantisGraph/lang/strings_swissgerman.txt Diff File
mod - plugins/MantisGraph/lang/strings_tagalog.txt Diff File
mod - plugins/MantisGraph/lang/strings_turkish.txt Diff File
mod - plugins/MantisGraph/lang/strings_ukrainian.txt Diff File
mod - plugins/MantisGraph/lang/strings_vietnamese.txt Diff File
mod - plugins/MantisGraph/lang/strings_zh-cn.txt Diff File
mod - plugins/XmlImportExport/lang/strings_polish.txt Diff File

Issue History

Date Modified Username Field Change
2017-01-05 03:22 Nikerabbit New Issue
2017-01-05 03:36 atrol Note Added: 0054930
2017-01-05 03:41 atrol Note Added: 0054931
2017-01-05 04:08 dregad Assigned To => dregad
2017-01-05 04:08 dregad Status new => assigned
2017-01-05 04:08 dregad Note Added: 0054932
2017-01-05 04:10 dregad Target Version => 2.0.1
2017-01-05 04:28 atrol Note Added: 0054933
2017-01-05 04:40 Nikerabbit Note Added: 0054934
2017-01-05 05:46 dregad Note Added: 0054938
2017-01-05 22:26 vboctor Note Added: 0054951
2017-01-06 02:38 atrol Note Added: 0054953
2017-01-06 05:49 dregad Note Added: 0054957
2017-01-07 05:13 Nikerabbit Note Added: 0054973
2017-01-11 06:33 dregad Note Added: 0055049
2017-01-11 13:47 Nikerabbit Note Added: 0055058
2017-01-11 14:54 Nikerabbit Note Edited: 0055058 View Revisions
2017-01-11 18:34 dregad Note Added: 0055063
2017-01-12 02:09 vboctor Note Added: 0055071
2017-01-12 03:38 dregad Note Added: 0055072
2017-01-12 12:12 vboctor Note Added: 0055086
2017-01-15 21:33 Nikerabbit Note Added: 0055141
2017-01-23 04:54 dregad Note Added: 0055260
2017-01-23 07:27 Nikerabbit Note Added: 0055265
2017-01-23 11:31 dregad Note Added: 0055271
2017-01-24 02:41 vboctor Note Added: 0055277
2017-01-24 03:17 dregad Changeset attached => MantisBT master abbb122c
2017-01-24 03:21 dregad Status assigned => resolved
2017-01-24 03:21 dregad Resolution open => fixed
2017-01-24 03:21 dregad Fixed in Version => 2.1.0
2017-01-24 03:32 atrol Target Version 2.0.1 => 2.1.0
2017-01-26 05:50 siebrand Note Added: 0055333
2017-01-31 04:02 vboctor Status resolved => closed