View Issue Details

IDProjectCategoryView StatusLast Update
0022150mantisbtupgradepublic2017-01-22 17:07
ReporterduongnvmAssigned Todregad 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0022150: After the upgradation of Mantis 1.2.18 to Mantis 2.0.0, the error appears at logon "APPLICATION ERROR # 1404. LDAP Extension Not
Description

I use version 1.2.18 is used, authentication via LDAP successfully.
Update to version 2.0.0, the error appears at logon "APPLICATION ERROR # 1404. LDAP Extension Not Loaded."
(Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.)
Note, if the authentication database, the success of the software.
Please, anybody can help me to the LDAP authentication.

TagsNo tags attached.

Activities

duongnvm

duongnvm

2017-01-10 04:20

reporter   ~0055009

LDAP connection parameters as attachments.



LDAP.png (7,595 bytes)
LDAP.png (7,595 bytes)
duongnvm

duongnvm

2017-01-10 04:30

reporter   ~0055010

Operating System: Windows 7
AppServ Version 8.5.0 for Windows:
Apache Web Server Version 2.4.20
PHP Script Language Version 5.6.26 & 7.0.11
MySQL Database Version 5.7.15

dregad

dregad

2017-01-10 04:52

developer   ~0055012

This is not a MantisBT issue, but a problem caused by your system's configuration.
Make sure the LDAP extension is installed http://php.net/manual/en/ldap.installation.php.

duongnvm

duongnvm

2017-01-10 21:41

reporter   ~0055040

Of course has enabled library php_ldap.dll then (just uncommented in php.ini extension = php_ldap.dll at C:\AppServ\php5), but still fails.



LDAP_2.png (26,424 bytes)
LDAP_2.png (26,424 bytes)
dregad

dregad

2017-01-11 02:59

developer   ~0055044

As evidenced by the code [1] this error message is only triggered when the extension is not loaded.
Again, please check your system configuration.

[1] https://github.com/mantisbt/mantisbt/blob/release-2.0.0/core/ldap_api.php#L56

duongnvm

duongnvm

2017-01-11 03:29

reporter   ~0055045

Thank you for dregad!

Issue History

Date Modified Username Field Change
2017-01-10 04:11 duongnvm New Issue
2017-01-10 04:20 duongnvm File Added: LDAP.png
2017-01-10 04:20 duongnvm Note Added: 0055009
2017-01-10 04:30 duongnvm Note Added: 0055010
2017-01-10 04:52 dregad Assigned To => dregad
2017-01-10 04:52 dregad Status new => resolved
2017-01-10 04:52 dregad Resolution open => no change required
2017-01-10 04:52 dregad Note Added: 0055012
2017-01-10 21:41 duongnvm File Added: LDAP_2.png
2017-01-10 21:41 duongnvm Note Added: 0055040
2017-01-10 21:51 duongnvm Status resolved => feedback
2017-01-10 21:51 duongnvm Resolution no change required => reopened
2017-01-11 02:59 dregad Status feedback => resolved
2017-01-11 02:59 dregad Resolution reopened => no change required
2017-01-11 02:59 dregad Note Added: 0055044
2017-01-11 03:29 duongnvm Note Added: 0055045
2017-01-22 17:07 atrol Status resolved => closed