View Issue Details

IDProjectCategoryView StatusLast Update
0022153Plugin - EmailReporting[All Projects] Generalpublic2017-01-11 19:41
Reporterbenjo 
Assigned ToSL-Gundam 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSDebian GNU/LinuxOS Version7
Product Version0.9.3 
Target VersionFixed in Version 
Summary0022153: signature.asc stopps parsing?
Description

Hello,

last week I upgraded to the new Mantis version and therefore also to the new EmailReporting version. Since then my E-Mails were not processed anymore.
After some digging (and a lot of running processes, see some of these in Additional Information [1]) I found out, that E-Mails with signature.asc as attachments wont be processed.
And therefore also no other E-Mails (if there is one with a signature.asc among others without in the E-Mail folder). This was working before in 0.9.2.
For me this is a blocking behavior, since I have to check regularly for these kinds of E-Mails so other will appear in the bug tracker ...

Thanks in advance!

Best, benjo

Steps To Reproduce
  • Install Mantis 2.0.0
  • Install EmailReporting Plugin 0.9.3 (and set up an E-Mail account)
  • Write E-Mail with signature.asc in attachment (i.e. PGP/GPG-signed) to this E-Mail address
Additional Information

[1]
www-data 21600 5.1 0.6 220012 65420 ? R 12:25 2:46 /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php
www-data 21699 0.0 0.0 4144 616 ? Ss 12:30 0:00 /bin/sh -c /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php >/dev/null
www-data 21700 4.9 0.6 216172 61432 ? R 12:30 2:26 /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php
www-data 21790 0.0 0.0 4144 612 ? Ss 12:35 0:00 /bin/sh -c /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php >/dev/null
www-data 21791 4.8 0.6 214636 59876 ? R 12:35 2:08 /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php
www-data 21913 0.0 0.0 4144 612 ? Ss 12:39 0:00 /bin/sh -c /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php >/dev/null
www-data 21914 4.6 0.5 212332 57608 ? R 12:39 1:50 /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php
www-data 22023 0.0 0.0 4144 612 ? Ss 12:44 0:00 /bin/sh -c /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php >/dev/null
www-data 22024 4.5 0.5 211308 56644 ? R 12:44 1:34 /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php
www-data 22104 0.0 0.0 4144 608 ? Ss 12:49 0:00 /bin/sh -c /usr/bin/php /var/www/bugs/plugins/EmailReporting/scripts/bug_report_mail.php >/dev/null

TagsNo tags attached.

Relationships

Activities

SL-Gundam

SL-Gundam

2017-01-10 11:45

manager   ~0055028

Please activate debug mode and provide a raw dump file of the email that causes this

benjo

benjo

2017-01-10 12:51

reporter   ~0055029

I activated the debug mode and got the attached file.
Otherwise there is no output.



email.txt (2,938 bytes)
Return-Path: <y.haupenthal@familie-redlich.de>
X-Footer: ZmFtaWxpZS1yZWRsaWNoLmRl
Received: from [172.17.30.170] ([192.168.123.201])
	(authenticated user y.haupenthal@familie-redlich.de)
	by mail.familie-redlich.de
	(using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128 bits))
	for mantis@familie-redlich.de;
	Tue, 10 Jan 2017 14:01:25 +0100
From: Yannic Haupenthal <y.haupenthal@familie-redlich.de>
Subject: test
To: mantis@familie-redlich.de
Message-ID: <871d5de4-2d14-802f-9e77-9b9c3011441f@familie-redlich.de>
Date: Tue, 10 Jan 2017 14:01:23 +0100
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101
 Thunderbird/45.6.0
MIME-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha256;
 protocol="application/pgp-signature";
 boundary="3NK43uhA7wFpddEu2TIFVvFVHJDMtEmMb"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--3NK43uhA7wFpddEu2TIFVvFVHJDMtEmMb
Content-Type: multipart/mixed; boundary="s5To27Vhf95qGq1NDc0apMqlruEHmAnNK";
 protected-headers="v1"
From: Yannic Haupenthal <y.haupenthal@familie-redlich.de>
To: mantis@familie-redlich.de
Message-ID: <871d5de4-2d14-802f-9e77-9b9c3011441f@familie-redlich.de>
Subject: test

--s5To27Vhf95qGq1NDc0apMqlruEHmAnNK
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable


Vielen Dank & viele Gruesse,
	Yannic Haupenthal

--=20
IT Systemadministration

familie redlich :digital
Online. Content. Clicks.
www.familie-redlich.de

E-Mail: y.haupenthal@familie-redlich.de
PGP-Key: 0x870F43A9B3BF0FBC

Telefon: +49 30 398203-460
Telefax: +49 30 818777-125

familie redlich digital GmbH
Gustav-Meyer-Allee 25 | Geb=C3=A4ude 13/5
13355 Berlin

Gesch=C3=A4ftsf=C3=BChrer: Andre Redlich, Claudio Gallio, Sascha B=C3=B6t=
tcher
Amtsgericht Charlottenburg HRB 81964B




--s5To27Vhf95qGq1NDc0apMqlruEHmAnNK--

--3NK43uhA7wFpddEu2TIFVvFVHJDMtEmMb
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQJUBAEBCAA+FiEElKqWdOWHKlcJIxvwhw9DqbO/D7wFAlh02yMgHHkuaGF1cGVu
dGhhbEBmYW1pbGllLXJlZGxpY2guZGUACgkQhw9DqbO/D7wb5hAArW66hdMluXGD
1MBnncDAid+bPqj0pTZQqQbx7R+2NC06W/m0vVt4h+X64tWc6iUHZejS/FGEABt1
faFjQ1pBbasDV6x2Q5dIrLI2OJRjoAiUY3BYBmB+dBRaH/3d8sTjsyyHaNm6uX1O
awG2NkMIi5jrPxg0uQIMvNAnKKql3YPNvOSWp2Cj9BCoCXyWm3E7aBckLKrozzjS
Ey+PgqX09HlNlSVETWUhue+KyvXP8/FSOl/MkeAITN07B3Lzw+18y0E5wkvIW+2c
9x2yicosETJU3oxxnH7RRg+D6mAyoIVH+8Gtkiwf7sGfRL2SypXmFERHEQcDPEEi
bzAFJ6jYOUxkdbx1hvMAJQwn27RmAQmPVMqsqdqKnNPpJgrC72Ipet8HL6ztxKGt
iuNIC9Z1Z/wtP63+/uElS6ocFD67dXXKuRzP26vaQQvBzLGs23Y8Oh2y4tlxQeOo
CJvchUgIGm1Q1QoqYaLuP2+xhsANGNrQaTnT66Jqaih3exCQCNzHq0g4nUcpRUxR
5A/3c1UU5O6BezT599kyM5iu+IDkKRNy2GnNXwDI7xBOjM/cyhWDi9mpMXtX5YEz
QXAOavfk2mt1N3i49OqHzslQ4nyNdA7TgatklRhujps4Ikmaprv7iC3xQxgIP7Hu
y7J8TtSxfCklgKa9ltAw5VyYfO2TMfQ=
=MDkj
-----END PGP SIGNATURE-----

--3NK43uhA7wFpddEu2TIFVvFVHJDMtEmMb--
email.txt (2,938 bytes)
SL-Gundam

SL-Gundam

2017-01-10 16:12

manager   ~0055037

Last edited: 2017-01-10 16:53

View 2 revisions

Signed emails seem to be handled a little bit differently by mail_mimedecode.
This is fun. Never had a signed email to process in EmailReporting before

What should EmailReporting do with the signature.asc?
mail_mimedecode does not see it as a normal attachment so if you need it as an attachment we would need to handle it differently.
If you only want the email, we will ignore signature.asc as, in my opinion, it seems pretty useless for an issue in MantisBT

SL-Gundam

SL-Gundam

2017-01-10 18:04

manager   ~0055039

The necessary changes have been made to support signed emails
https://github.com/mantisbt-plugins/EmailReporting/commit/a60b2ce55b3ba869c595a4f805a0b3942dfd40f7

This issue will stay open until we have an answer on what to do with signature.asc (0022153:0055037)

benjo

benjo

2017-01-11 04:48

reporter   ~0055048

Awesome, thanks for getting around it so fast :)
I would agree with you, that its useless in an issue, so the best way in my opinion is to just ignore signature.asc.
Thanks a lot! :)
When can we expect the release of 0.10.0 or should I just patch manually?

SL-Gundam

SL-Gundam

2017-01-11 11:35

reporter   ~0055055

I suggest downloading the 0.10.0-DEV version (https://github.com/mantisbt-plugins/EmailReporting - Click on Clone or download and then on Download ZIP) and overwrite the existing files

SL-Gundam

SL-Gundam

2017-01-11 19:41

reporter   ~0055067

I did some more work on the code in question since attachments of the type email had issues if they were also signed

This has now also been fixed
https://github.com/mantisbt-plugins/EmailReporting/commit/6fbcef5aec0b1a31751a2df62fa6ef103aa75c9e
https://github.com/mantisbt-plugins/EmailReporting/commit/34283c50b691f4a1138801ded957693f83872987

Issue History

Date Modified Username Field Change
2017-01-10 08:16 benjo New Issue
2017-01-10 11:45 SL-Gundam Assigned To => SL-Gundam
2017-01-10 11:45 SL-Gundam Status new => assigned
2017-01-10 11:45 SL-Gundam Status assigned => feedback
2017-01-10 11:45 SL-Gundam Note Added: 0055028
2017-01-10 12:51 benjo File Added: email.txt
2017-01-10 12:51 benjo Note Added: 0055029
2017-01-10 12:51 benjo Status feedback => assigned
2017-01-10 16:12 SL-Gundam Status assigned => feedback
2017-01-10 16:12 SL-Gundam Note Added: 0055037
2017-01-10 16:53 SL-Gundam Note Edited: 0055037 View Revisions
2017-01-10 18:04 SL-Gundam Note Added: 0055039
2017-01-11 04:48 benjo Note Added: 0055048
2017-01-11 04:48 benjo Status feedback => assigned
2017-01-11 11:35 SL-Gundam Status assigned => resolved
2017-01-11 11:35 SL-Gundam Resolution open => fixed
2017-01-11 11:35 SL-Gundam Note Added: 0055055
2017-01-11 19:41 SL-Gundam Note Added: 0055067