View Issue Details

IDProjectCategoryView StatusLast Update
0022167mantisbtmarkdownpublic2017-04-30 14:53
ReporterdregadAssigned Tojoel 
PrioritynormalSeverityminorReproducibilityalways
Status confirmedResolutionfixed 
Product Version2.1.0 
Target Version2.5.0Fixed in Version 
Summary0022167: Markdown: poor handling of legacy multi-level quoted text
Description

When rendering quoted text with multiple levels of indentation, the markdown is not dealing well with multiple levels of indentation without newlines between levels

> > some text
>  more text

Renders as:

some text
more text

This is normal based on the current CommonMark spec due to the so-called "Laziness rule", but it is a problem when rendering legacy text in Mantis.

Ideally, I would expect the above to render like this:

some text

more text

TagsNo tags attached.

Relationships

related to 0022172 closedjoel Markdown not displaying single line breaks 
child of 0022180 new Markdown issues following implementation in 0017920 

Activities

cproensa

cproensa

2017-01-11 19:07

developer   ~0055066

I think it's related to 0022172
as line breaks are not treated as block separators, the second line follows the previous indentation.

vboctor

vboctor

2017-01-12 02:03

manager   ~0055070

This matches the specs and GitHub has similar behavior. Hence, I would say this is not an issue. As discussed, there will be cases where old text will need to be updated to look right with Markdown.

Let's always test on GitHub as a reference implementation + Markdown specs before reporting behavior as incorrect.

dregad

dregad

2017-02-27 10:49

developer   ~0055799

Last edited: 2017-02-27 10:50

View 2 revisions

@joel why are you marking this as fixed ? the behavior is unchanged since I reported the issue, so definitely NOT fixed.

If the decision is to not address this, then please use the appropriate closure code of won't fix (and remove the target version)

joel

joel

2017-02-27 11:45

developer   ~0055803

Reopening the issue, let's see if we could add a custom fix logic in the extension class.

joel

joel

2017-02-27 18:01

developer   ~0055811

Last edited: 2017-02-27 19:05

View 2 revisions

This is a bug in upstream again, no need to fix on our side. For this, I will open a ticket on the issue in github. https://github.com/erusev/parsedown/issues/478

joel

joel

2017-03-14 01:52

developer   ~0056069

This is not an issue as per spec here http://spec.commonmark.org/0.27/#example-212

Issue History

Date Modified Username Field Change
2017-01-11 07:30 dregad New Issue
2017-01-11 19:06 cproensa Relationship added related to 0022172
2017-01-11 19:07 cproensa Note Added: 0055066
2017-01-12 01:59 vboctor Category ui => markdown
2017-01-12 02:03 vboctor Note Added: 0055070
2017-01-12 07:16 dregad Relationship added child of 0022180
2017-01-23 03:01 joel Assigned To => joel
2017-01-23 03:01 joel Status new => assigned
2017-01-31 04:03 vboctor Target Version 2.1.0 => 2.2.0
2017-02-26 21:19 vboctor Target Version 2.2.0 => 2.3.0
2017-02-27 10:06 joel Status assigned => closed
2017-02-27 10:06 joel Resolution open => fixed
2017-02-27 10:49 dregad Note Added: 0055799
2017-02-27 10:50 dregad Note Edited: 0055799 View Revisions
2017-02-27 11:45 joel Status closed => assigned
2017-02-27 11:45 joel Note Added: 0055803
2017-02-27 18:01 joel Status assigned => confirmed
2017-02-27 18:01 joel Note Added: 0055811
2017-02-27 19:05 joel Note Edited: 0055811 View Revisions
2017-03-14 01:52 joel Note Added: 0056069
2017-04-01 00:20 vboctor Target Version 2.3.0 => 2.4.0
2017-04-30 14:53 vboctoradmin Target Version 2.4.0 => 2.5.0