View Issue Details

IDProjectCategoryView StatusLast Update
0022247mantisbtprintingpublic2017-06-20 17:11
ReporterlexlogosAssigned Toatrol 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionwon't fix 
Product Version2.0.0 
Target VersionFixed in Version 
Summary0022247: Printing bug page
Description

Is there any chance to be reintroduced in the current version of Mantis BT 2.0.0 the possibility to print as in previous versions the option print_bug_page?
Thank You
Claudiu

TagsNo tags attached.

Relationships

related to 0022467 new Print Option 

Activities

atrol

atrol

2017-01-27 02:06

developer   ~0055362

What are you missing in current implementation of printing?

lexlogos

lexlogos

2017-01-27 03:50

reporter   ~0055365

In earlier versions of MantisBT I had the opportunity to choose and change in print_bug_page printing architecture what i want to print and what I don't . I often use print bug page for printing the details on the paper and in this version of MantisBT I cannot make any changes. Thank you.

atrol

atrol

2017-01-27 04:14

developer   ~0055367

@vboctor you removed the old printing functionality.
I am not sure if we should reintroduce it, or at least reintroduce the former option to configure displayed fields (bug_print_page_fields)

atrol

atrol

2017-01-27 04:19

developer   ~0055368

@lexlogos as a workaround you could use the printing capabilities of the "View Issues" page.

lexlogos

lexlogos

2017-01-27 04:27

reporter   ~0055372

Question: It might be possible for the future to have approximately the same capabilities of printing bug page?
Thanks for quick response and support.
Claudiu, lexlogos

vboctor

vboctor

2017-01-27 04:28

manager   ~0055373

The reason for removing the print page is to remove code redundancy and complexity. Technically speaking we could re-introduce the ability to customize printable fields, but I don't know if it is worth the complexity.

@lexlogos can you provide an example of how you want to use such configuration?

lexlogos

lexlogos

2017-01-27 04:38

reporter   ~0055374

This is the format that we use now. We like the previous version of print_bug_page because we can customise and for me it looks like in attachment.



0049771_ Mircea Muresan - COMANDÄ‚_ORDER.pdf (113,671 bytes)
lexlogos

lexlogos

2017-02-02 07:32

reporter   ~0055451

@vboctor Do I managed to make myself understood on the issue registered?
Thank you.

lexlogos

lexlogos

2017-05-13 03:22

reporter   ~0056843

@atrol Hi guys, i wonder if in future version of mantis will you reintroduce the feature regarding print bug page. It helps alot for our team.
Thank you.

atrol

atrol

2017-05-16 14:20

developer   ~0056869

i wonder if in future version of mantis will you reintroduce the feature regarding print bug page

There is no plan for it at the moment.

@vboctor might comment if there is a way to get an output similar to what you provided at 0022247:0055374 using the new printing approach.

lexlogos

lexlogos

2017-05-21 05:05

reporter   ~0056923

Thank you Atrol

lexlogos

lexlogos

2017-05-23 03:43

reporter   ~0056943

@vboctor if there is a previous version of mantis which looks like actual one and has capabilities for printing like i want, than it suits for me.

lexlogos

lexlogos

2017-06-07 14:11

reporter   ~0057038

@atrol, if there is a previous version of mantis which looks like actual one and has capabilities for printing like i want, than it suits for me. Thank you.

dregad

dregad

2017-06-08 05:24

developer   ~0057041

You are welcome to use MantisBT version 1.3, but be aware that there won't be any further evolution to that (only security and critical bug fixes)

lexlogos

lexlogos

2017-06-08 06:09

reporter   ~0057042

@dregad, thank you.

Issue History

Date Modified Username Field Change
2017-01-25 05:20 lexlogos New Issue
2017-01-27 02:06 atrol Status new => feedback
2017-01-27 02:06 atrol Note Added: 0055362
2017-01-27 03:50 lexlogos Note Added: 0055365
2017-01-27 03:50 lexlogos Status feedback => new
2017-01-27 04:14 atrol Note Added: 0055367
2017-01-27 04:19 atrol Note Added: 0055368
2017-01-27 04:27 lexlogos Note Added: 0055372
2017-01-27 04:28 vboctor Note Added: 0055373
2017-01-27 04:38 lexlogos File Added: 0049771_ Mircea Muresan - COMANDÄ‚_ORDER.pdf
2017-01-27 04:38 lexlogos Note Added: 0055374
2017-02-02 07:32 lexlogos Note Added: 0055451
2017-03-05 10:32 atrol Relationship added related to 0022467
2017-05-13 03:22 lexlogos Note Added: 0056843
2017-05-16 14:20 atrol Note Added: 0056869
2017-05-21 05:05 lexlogos Note Added: 0056923
2017-05-23 03:43 lexlogos Note Added: 0056943
2017-06-07 14:11 lexlogos Note Added: 0057038
2017-06-08 05:24 dregad Assigned To => atrol
2017-06-08 05:24 dregad Status new => resolved
2017-06-08 05:24 dregad Resolution open => won't fix
2017-06-08 05:24 dregad Note Added: 0057041
2017-06-08 06:09 lexlogos Note Added: 0057042
2017-06-20 17:11 atrol Status resolved => closed