View Issue Details

IDProjectCategoryView StatusLast Update
0022262mantisbtattachmentspublic2017-02-07 17:26
ReporterajtruckleAssigned Toatrol 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version2.0.0 
Target VersionFixed in Version 
Summary0022262: Including more than two attachments to a note
Description

Is it going to be possible to have more than two attachments on a note? I find if I attach 3 screen shots that only two are embedded as links and the other becomes a standalone note.

TagsNo tags attached.

Relationships

duplicate of 0021733 new Attachments should be linkable to notes in db 

Activities

GunSmoker

GunSmoker

2017-01-26 19:06

reporter   ~0055354

Isn't it already implemented? For example, 3 attaches: http://www.mantisbt.org/bugs/view.php?id=22263#c55347

atrol

atrol

2017-01-27 01:59

developer   ~0055361

Attachments are not linked to notes, see 0021733.
They are shown inline with notes, based on the time they were created.
That's why you see this behavior, see 0021727.
Default time is 3 seconds, and can be changed by setting
$g_issue_activity_note_attachments_seconds_threshold = 3;

ajtruckle

ajtruckle

2017-01-27 03:35

reporter   ~0055364

But that is not very logical IMHO.

If I "include" some attachments when writing a note I expect those attachments to be "included".

I have no control over how a user will write their own note, and / or when in that process they will add attachments. Everyone has different abilities and speeds. And they could be using any kind of device that can slow things down. So setting a time limit is not efficient IMHO.

My proposal to make this more efficient:

  • Default all attachments to a note as "inline"
  • Allow the user to set if each attachment should be inline or not (to give them flexibility)
  • Present isolated attachments AFTER the note, not before
  • Potentially allow them to specify the order of the isolated attachments (if more than one)

Attachments are part of a discussion and it is logical that they are contained with the note that refers to them. For the reasons stated I really don't feel it is sensible to use a time delay to decide if attachments should be inline or not.

Thank you for considering.

atrol

atrol

2017-01-27 03:52

developer   ~0055366

But that is not very logical IMHO.

That's why there is the mentioned 0021733.

Issue History

Date Modified Username Field Change
2017-01-26 11:27 ajtruckle New Issue
2017-01-26 19:06 GunSmoker Note Added: 0055354
2017-01-27 01:57 atrol Severity minor => feature
2017-01-27 01:57 atrol Category feature => attachments
2017-01-27 01:59 atrol Assigned To => atrol
2017-01-27 01:59 atrol Status new => resolved
2017-01-27 01:59 atrol Resolution open => duplicate
2017-01-27 01:59 atrol Note Added: 0055361
2017-01-27 01:59 atrol Relationship added duplicate of 0021733
2017-01-27 03:35 ajtruckle Note Added: 0055364
2017-01-27 03:52 atrol Note Added: 0055366
2017-02-07 17:26 atrol Status resolved => closed