View Issue Details

IDProjectCategoryView StatusLast Update
0022342mantisbtcustomizationpublic2017-04-01 00:13
ReporteriszabiAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionunable to reproduce 
Product Version2.0.0 
Target VersionFixed in Version 
Summary0022342: "Assigned to Me (Unresolved)" box missing in "All Projects" project home.
Description

Hi,

I'd like to ask a question: How can I display in All projects - Assigned to Me (Unresolved) box?

I examined core/filter_api.php but I could not find any solutions for my issue.

In filter_api.php I found filter_create_assigned_to_unresolved function, from 3015 queu still 3032 witch responsibles boxes displaying :

function filter_create_assigned_to_unresolved( $p_project_id, $p_user_id ) {
              $t_filter = filter_get_default();

              if( $p_user_id == 0 ) {
                            $t_filter[FILTER_PROPERTY_HANDLER_ID] = array( '0' => META_FILTER_NONE );
              } else {
                            $t_filter[FILTER_PROPERTY_HANDLER_ID] = array( '0' => $p_user_id );
              }

              $t_bug_resolved_status_threshold = config_get( 'bug_resolved_status_threshold', null, $p_user_id, $p_project_id );
              $t_filter[FILTER_PROPERTY_HIDE_STATUS] = array( '0' => $t_bug_resolved_status_threshold );

              if( $p_project_id != ALL_PROJECTS ) {
                            $t_filter[FILTER_PROPERTY_PROJECT_ID] = array( '0' => $p_project_id );
              }

              return filter_ensure_valid_filter( $t_filter );
}

The All projects ID is 0 in our MantisBT v.2.0.0,
I'd like to display on main page Assigned to Me (Unresolved) box.
If I selected other proejcts, Assigned to Me (Unresolved) box displays successfull.

Thank you in advance,


iszabi

TagsNo tags attached.

Relationships

has duplicate 0022553 closedatrol Add "Assigned to Me" Issues in "My View" when "All Projects" is selected 

Activities

atrol

atrol

2017-03-29 15:41

developer   ~0056269

iszabi,

I was not able to reproduce your problem with a fresh install of the latest stable MantisBT release (2.2.1 at the moment).

I recommend that you upgrade to the latest (download from [1]). If after doing so the problem persists, do not hesitate to reopen the issue and provide detailed step-by-step instructions to reproduce the issue; the following additional information may also be useful:

  • Exact version of MantisBT, PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?

[1] http://mantisbt.org/download.php

Issue History

Date Modified Username Field Change
2017-02-08 09:48 iszabi New Issue
2017-02-08 11:38 dregad Description Updated View Revisions
2017-03-20 15:52 atrol Relationship added has duplicate 0022553
2017-03-29 15:41 atrol Assigned To => atrol
2017-03-29 15:41 atrol Status new => resolved
2017-03-29 15:41 atrol Resolution open => unable to reproduce
2017-03-29 15:41 atrol Note Added: 0056269
2017-04-01 00:13 vboctoradmin Status resolved => closed