View Issue Details

IDProjectCategoryView StatusLast Update
0022370mantisbtupgradepublic2017-02-16 11:06
Reportermatroos 
Assigned Toatrol 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionno change required 
PlatformWindowsOSWindows ServerOS Version2008 R2
Product Version2.1.0 
Target VersionFixed in Version 
Summary0022370: Application error 0000026 after upgrade from 1.2.19 to 2.1.0
Description

On my test environment, I have upgraded to 2.1.0 three times now (every time from my original working 1.2.19), and in quite an arbitrary way, upon clicking an issue to navigate to its details page, I get this "application error 0000026". I have been searching around on the internet and on the forum, but could not find anything that can solve my case.

Did something go wrong during database conversion? I have upgraded from 1.2.19.

Steps To Reproduce

Happens when trying to navigate to the details page of some of the issues. Does not happen on all of them.

Additional Information

APPLICATION ERROR 0000026
Data Type mismatch. Enable detailed error messages for further information.
Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.
Full path: D:\MantisBT - Copy\core\helper_api.php
Line: 189

Variable Value Type
p_var1 2 integer
p_var2 2 string
p_strict 1 boolean

Filename Line Function Args

D:\MantisBT - Copy\core\helper_api.php 189 - - trigger_error ( <string>'26', <integer>256 )
D:\MantisBT - Copy\core\helper_api.php 266 - - helper_check_variables_equal ( <integer>2, <string>'2', <boolean>true )
D:\MantisBT - Copy\core\html_api.php 1085 - - check_selected ( <integer>2, <string>'2' )
D:\MantisBT - Copy\core\html_api.php 1249 - - html_button_bug_assign_to ( <Object><BugData> ( [attachment_count] => NULL, [bugnotes_count] => NULL, [bug_text_id] => '145' ) )
D:\MantisBT - Copy\bug_view_inc.php 321 - - html_buttons_view_bug_page ( <integer>145 )
D:\MantisBT - Copy\view.php 37 - - include ( <string>'D:\MantisBT - Copy\bug_view_inc.php' )

TagsNo tags attached.

Relationships

Activities

matroos

matroos

2017-02-15 04:09

reporter   ~0055685

Would it make a difference if I would first upgrade to 1.3.6 and then to 2.1.0 from there on?

atrol

atrol

2017-02-15 04:30

developer   ~0055688

Would it make a difference if I would first upgrade to 1.3.6 and then to 2.1.0 from there on?

No. There is no difference in database schema between 1.3.6 and 2.1.0.

matroos

matroos

2017-02-15 10:00

reporter   ~0055697

OK. So tried to migrate from 1.2.19 to 1.3.6 anyway. And I have the same arbitrary "application error 26".

This time experienced it when I tried to assign an issue to someone else with "feedback".

matroos

matroos

2017-02-16 10:52

reporter   ~0055703

Found the solution.
The cause was the SetDueDate plugin. Adapted its version dependency to 2.1.0 manually in the plugin config file.

Also had an issue with disappearing due dates and errors when trying to alter due dates (or manually entering them). That got solved by entering a missing trailing double quote in the bug_change_status_page.php (line 245).

Seems I'm now ready to put 2.1.0 into production.

This issue can be closed.

atrol

atrol

2017-02-16 11:06

developer   ~0055704

Thanks for the feedback!

That got solved by entering a missing trailing double quote in the bug_change_status_page.php (line 245).

Will be fixed in 2.2.0, see 0022288

Issue History

Date Modified Username Field Change
2017-02-14 08:34 matroos New Issue
2017-02-15 04:09 matroos Note Added: 0055685
2017-02-15 04:30 atrol Note Added: 0055688
2017-02-15 10:00 matroos Note Added: 0055697
2017-02-16 10:52 matroos Note Added: 0055703
2017-02-16 11:06 atrol Assigned To => atrol
2017-02-16 11:06 atrol Status new => resolved
2017-02-16 11:06 atrol Resolution open => no change required
2017-02-16 11:06 atrol Note Added: 0055704