View Issue Details

IDProjectCategoryView StatusLast Update
0022384mantisbtfilterspublic2017-02-15 09:56
Reportermcmo 
Assigned Toatrol 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.1.0 
Target VersionFixed in Version 
Summary0022384: Missing versions in sub-projects when filtering the view of all issues
Description

if the parent project is selected, the product versions appear; if a sub-project is selected, then they do not appear, although the product versions of the parent project are available when reporting an issue
That affects v2.0.0, v2.1.0 and MantisBT 2.2.0-devmaster-e40a285

Steps To Reproduce

1- create a project Project01
2- create a sub project SubProject01
3- create 3 product versions in Project01
4- open the view all issues page
5- select the main Project01
6- check which product versions are available in the version filters
7- switch to SubProject01
8- check which product versions are available in the version filters: they are missing

TagsNo tags attached.

Relationships

duplicate of 0012261 new Cannot filter by versions of parent project when child project selected 

Issue History

Date Modified Username Field Change
2017-02-15 09:43 mcmo New Issue
2017-02-15 09:43 mcmo File Added: View Issues in SubProject01 - Product version filter does not show versions.png
2017-02-15 09:43 mcmo File Added: View Issues in Project01 - Product version filter shows versions.png
2017-02-15 09:43 mcmo File Added: Report Issue in Subproject01 - Project01 product versions are available.png
2017-02-15 09:43 mcmo File Added: Versions in Project01.png
2017-02-15 09:43 mcmo File Added: Existing Projects.png
2017-02-15 09:56 atrol Assigned To => atrol
2017-02-15 09:56 atrol Status new => resolved
2017-02-15 09:56 atrol Resolution open => duplicate
2017-02-15 09:56 atrol Relationship added duplicate of 0012261