View Issue Details

IDProjectCategoryView StatusLast Update
0022400mantisbtinstallationpublic2017-03-12 04:00
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0-beta.1 
Target Version2.2.0Fixed in Version2.2.0 
Summary0022400: Installer does not show "GOOD" status for DB connections
Description

See attached screenshot.

Additional Information

This is a regression from removal of DB2 support in MantisBT master 92fd6f64 (see 0021140)

TagsNo tags attached.

Relationships

related to 0021140 closedatrol Remove DB2 support 

Activities

dregad

dregad

2017-02-17 18:25

developer  

Selection_001.png (25,382 bytes)
Selection_001.png (25,382 bytes)

Related Changesets

MantisBT: master 42718557

2017-02-17 18:37:06

dregad

Details Diff
Show "GOOD" status for installer DB connect checks

Since removal of DB2 support (see issue 0021140), the installer does
not display "GOOD" status anymore for Admin and User DB connection
checks.

This also improves the logic for the Admin account connection check, we
now capture a "BAD" status if the Admin can connect to the DB, but does
not have access to the database.

Fixes 0022400
mod - admin/install.php Diff File

MantisBT: master 3b758931

2017-02-17 18:47:11

dregad

Details Diff
Remove leftover debugging code

Fixes 0022400
mod - admin/install.php Diff File

MantisBT: master-2.2 92f07eb6

2017-03-12 04:00:30

dregad


Committer: GitHub Details Diff
Install: fix db connection as admin check (#1049)

Commit 42718557933d1e58fc134ef3bea7db97aeb00c65 (issue 0022400)
introduced a regression in the installer, causing the 'Attempting to
connect to database as admin' check to fail for new installations, even
though the Admin user ID and password are correct.

Fixes 0022510
mod - admin/install.php Diff File

Issue History

Date Modified Username Field Change
2017-02-17 18:25 dregad New Issue
2017-02-17 18:25 dregad Status new => assigned
2017-02-17 18:25 dregad Assigned To => dregad
2017-02-17 18:25 dregad File Added: Selection_001.png
2017-02-17 18:26 dregad Relationship added related to 0021140
2017-02-17 18:45 dregad Changeset attached => MantisBT master 42718557
2017-02-17 18:45 dregad Status assigned => resolved
2017-02-17 18:45 dregad Resolution open => fixed
2017-02-17 18:45 dregad Fixed in Version => 2.2.0
2017-02-17 18:47 dregad Changeset attached => MantisBT master 3b758931
2017-02-26 21:17 vboctor Status resolved => closed
2017-03-12 04:00 dregad Changeset attached => MantisBT master-2.2 92f07eb6