View Issue Details

IDProjectCategoryView StatusLast Update
0022441mantisbtbugtrackerpublic2017-10-28 19:08
ReporterrupaAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1.0 
Target Version2.8.0Fixed in Version2.8.0 
Summary0022441: Notes are not in the correct order after cloning an issue
Description

After cloning an issue including the attached notices these are not sorted in the correct ascending or descending order by time. So there is a mess in long issues.

TagsNo tags attached.

Relationships

has duplicate 0023403 closedatrol activities out of order following cloning 

Activities

dregad

dregad

2017-03-01 07:53

developer   ~0055836

I didn't try to reproduce this, but looking at bug_copy() API function, the SQL statement retrieving the list of notes from the source issue does not have an ORDER BY clause so it's likely that this is the root cause of the issue.

No time to fix and test now, but I believe adding ORDER BY id should do the trick for future clones.

I don't think there is an easy way to retroactively fix previously copied issues.

rupa

rupa

2017-03-02 08:49

reporter   ~0055870

(This wouldn't be a problem to us... ) ;-)

helfy022

helfy022

2017-10-03 19:24

reporter   ~0057887

Hello,

Is the noted change slated for inclusion in an upcoming MantisCore version? We are currently using 2.5.1 and continue to see this issue.

Thanks,
Ryan.

Related Changesets

MantisBT: master 23db63f1

2017-09-30 07:46:01

cproensa


Committer: vboctor Details Diff
Fix order of activities with same timestamp

When activities of the same type have the same timestamp, for example
when created from cloning issues, use the element id for sorting.

Fixes: 0022441
mod - core/bug_activity_api.php Diff File

Issue History

Date Modified Username Field Change
2017-03-01 03:44 rupa New Issue
2017-03-01 07:53 dregad Status new => acknowledged
2017-03-01 07:53 dregad Note Added: 0055836
2017-03-02 08:49 rupa Note Added: 0055870
2017-09-27 03:04 atrol Relationship added has duplicate 0023403
2017-10-03 19:24 helfy022 Note Added: 0057887
2017-10-23 04:04 vboctor Changeset attached => MantisBT master 23db63f1
2017-10-23 04:04 cproensa Assigned To => cproensa
2017-10-23 04:04 cproensa Status acknowledged => resolved
2017-10-23 04:04 cproensa Resolution open => fixed
2017-10-23 04:04 cproensa Fixed in Version => 2.8.0
2017-10-23 04:08 vboctor Target Version => 2.8.0
2017-10-23 04:08 vboctor Summary Notices are not in the correct order after cloning an issue => Notes are not in the correct order after cloning an issue
2017-10-28 19:08 vboctor Status resolved => closed