View Issue Details

IDProjectCategoryView StatusLast Update
0022491mantisbtuipublic2017-03-19 16:03
ReporterChris_ZAssigned Todregad 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version2.2.0 
Target VersionFixed in Version 
Summary0022491: Add Note - confusing behavior after View Status toggle is selected
Description
  1. Shouldn't View Status ether be a two radio buttons och change label to View as Private?
  2. Gremlins ate the whole file Drop Zone when this toggle was selected.

See the screenshots:

TagsNo tags attached.

Relationships

duplicate of 0009802 acknowledged Private attachments 
duplicate of 0021843 closedvboctor Attachment dropzone missing from notes when the note is private 
related to 0022499 resolveddregad Document reuse of language strings 

Activities

Chris_Z

Chris_Z

2017-03-07 11:40

reporter  

dregad

dregad

2017-03-07 12:26

developer   ~0055967

This is by design. It is because we don't (yet) have the notion of private attachments, so we hide the dropzone to avoid misleading users in thinking that the file they are uploading will be private.

See duplicate 0021843, and actual implementation follow-up in 0009802.

dregad

dregad

2017-03-07 12:27

developer   ~0055968

Last edited: 2017-03-07 12:28

View 2 revisions

Re: the label, on this tracker it is clearly shown as private (what version are you on ?)

Chris_Z

Chris_Z

2017-03-07 14:51

reporter   ~0055971

Awww... now you saved me from the world of pain :)
It was my _customs_stringsinc.php which messed up your habitat.

And on closer investigation just realized that you are also massively re-using string identifiers from language files in multiple places (i.e. they are not unique per instance where they are used).

Probably mentioning the possibility of collisions in the 7.1. Strings / Translations chapter could help someone like me predict or minimize the collateral damage ;)
Sorry for the unintentional confusion.

Cheers

dregad

dregad

2017-03-08 06:27

developer   ~0055985

You're welcome. Say hello to the gremlins for me ;)

Probably mentioning the possibility of collisions in the 7.1. Strings / Translations chapter could help someone like me predict or minimize the collateral damage ;)

Tracked in 0022499

Issue History

Date Modified Username Field Change
2017-03-07 11:40 Chris_Z New Issue
2017-03-07 11:40 Chris_Z File Added: Snapshot-2017-03-07-173535.png
2017-03-07 11:40 Chris_Z File Added: Snapshot-2017-03-07-173619.png
2017-03-07 12:26 dregad Assigned To => dregad
2017-03-07 12:26 dregad Status new => resolved
2017-03-07 12:26 dregad Resolution open => duplicate
2017-03-07 12:26 dregad Note Added: 0055967
2017-03-07 12:26 dregad Relationship added duplicate of 0009802
2017-03-07 12:26 dregad Relationship added duplicate of 0021843
2017-03-07 12:27 dregad Note Added: 0055968
2017-03-07 12:28 dregad Note Edited: 0055968 View Revisions
2017-03-07 14:51 Chris_Z Note Added: 0055971
2017-03-08 06:27 dregad Note Added: 0055985
2017-03-08 06:27 dregad Relationship added related to 0022499
2017-03-19 16:03 atrol Status resolved => closed