View Issue Details

IDProjectCategoryView StatusLast Update
0022503mantisbttoolspublic2017-03-20 10:59
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.3.7Fixed in Version1.3.7 
Summary0022503: Travis CI builds fail for PHP > 5.5
Description

See the 1st failed build https://travis-ci.org/mantisbt/mantisbt/builds/209250215 which is a translation update, which doesn't contain any change that would cause the build to fail.

I would guess that Travis updated the version of PHPUnit they're running on their VMs.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master-1.3.x 1a015155

2017-03-10 10:03:24

dregad

Details Diff
Travis: force use of PHPUnit 5.7 with PHP >= 5.6

On 2017-03-09, Travis deployed the latest version of PHPUnit (6.0.8) on
their workers. Since that day, our builds on PHP >= 5.6 are failing,
because 6.0.8 only supports PHP 7.0 and 7.1 (<= 5.5 are OK, because they
are running an older PHPUnit version).

PHP 7.x builds are failing as well, because PHPUnit 6.x introduced
changes that are breaking the MantisBT tests.

As a workaround, we download and install PHPUnit 5.7 if the Travis PHP
version is 5.6 or later.

Fixes 0022503
mod - .travis.yml Diff File

MantisBT: master-2.1 5efd115e

2017-03-10 10:03:24

dregad

Details Diff
Travis: force use of PHPUnit 5.7 with PHP >= 5.6

On 2017-03-09, Travis deployed the latest version of PHPUnit (6.0.8) on
their workers. Since that day, our builds on PHP >= 5.6 are failing,
because 6.0.8 only supports PHP 7.0 and 7.1 (<= 5.5 are OK, because they
are running an older PHPUnit version).

PHP 7.x builds are failing as well, because PHPUnit 6.x introduced
changes that are breaking the MantisBT tests.

As a workaround, we download and install PHPUnit 5.7 if the Travis PHP
version is 5.6 or later.

Fixes 0022503
mod - .travis.yml Diff File

Issue History

Date Modified Username Field Change
2017-03-09 11:26 dregad New Issue
2017-03-10 17:21 dregad Changeset attached => MantisBT master-1.3.x 1a015155
2017-03-10 17:21 dregad Assigned To => dregad
2017-03-10 17:21 dregad Status new => resolved
2017-03-10 17:21 dregad Resolution open => fixed
2017-03-10 17:21 dregad Fixed in Version => 1.3.7
2017-03-12 05:58 atrol Target Version => 1.3.7
2017-03-12 19:23 vboctor Status resolved => closed
2017-03-20 10:59 dregad Changeset attached => MantisBT master-2.1 5efd115e