View Issue Details

IDProjectCategoryView StatusLast Update
0022700mantisbtlocalizationpublic2017-04-23 10:54
ReporterjdgriecoAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.3.0 
Target Version2.3.1Fixed in Version2.3.1 
Summary0022700: Due Date in bug_change_status_page.php
Description

An echo is missing in data-picker-locale atrribute in due_date rendering

TagsNo tags attached.

Relationships

related to 0020040 closedsyncguru Replace jscalendar by a newer widget 

Activities

atrol

atrol

2017-04-10 09:40

developer   ~0056472

jdgrieco,

The provided information is not sufficient to provide any help in resolving the issue. A complete and detailed description is required for the support team to get a clear understanding of the problem.

Please explain what you do, what are the results you expect to get and what you actually get.

Also provide detailed, step-by-step instructions to reproduce the issue; the additional information listed below may also be useful:

  • Exact version of MantisBT, PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
jdgrieco

jdgrieco

2017-04-10 10:51

reporter   ~0056479

Hi,
Thank you for the quick response.

I using 2.3.0 version, but it's also present in master branch.

I enabled Due Date field in config_inc.php using:
$g_due_date_update_threshold = MANAGER;
$g_due_date_view_threshold = VIEWER;

I use non engish date format, so I also include:
$g_default_timezone = 'America/Sao_Paulo';
$g_short_date_format = 'd/m/Y';
$g_normal_date_format = $g_short_date_format . ' H:i';
$g_datetime_picker_format = 'DD/MM/YYYY';

When I update a problem with the expiration date filled, the expiration date is not saved, this is related to the strtotime function of php with non-English date format (I think it's better to open another issue for this), and during the debug I realized the lack of this "echo".

I made also a PR (https://github.com/mantisbt/mantisbt/pull/1089) for this

atrol

atrol

2017-04-10 10:59

developer   ~0056480

Thanks @jdgrieco for the information and the PR.

mahindra

mahindra

2017-04-12 12:01

reporter   ~0056507

Is this in relation to "Edit Project Version => Date Order " ?
I'm using german language settings and it is difficult to change this date.

atrol

atrol

2017-04-12 14:25

developer   ~0056513

and it is difficult to change this date.

What does it is difficult mean?

mahindra

mahindra

2017-04-12 14:37

reporter   ~0056514

Please have a look:



Versionsdatum.png (44,016 bytes)
Versionsdatum.png (44,016 bytes)
atrol

atrol

2017-04-13 02:14

developer   ~0056516

@mahindra I was not able to reproduce the issue using the given information and using latest code of MantisBT.

Do you use latest code or 2.3.0?

mahindra

mahindra

2017-04-13 02:20

reporter   ~0056519

Thank you
We are using 2.3.0

mahindra

mahindra

2017-04-13 02:25

reporter   ~0056520

2.2.1 only
Sorry I think we will do the update next week, if the filter bugs will be "saved"

atrol

atrol

2017-04-13 02:35

developer   ~0056521

@mahindra wait until 2.3.1 or 2.4.0 is out as there will be some more fixes related to date and date picker.
Furthermore filtering by date is broken in 2.3.0, see 0022653

mahindra

mahindra

2017-04-13 02:49

reporter   ~0056524

Thank you - we will wait for the next release

dregad

dregad

2017-04-16 19:28

developer   ~0056594

Reopening since this was reverted in MantisBT master-2.3 bb527da1, so I'm not sure it can be considered as fixed in 2.3.1.

@cproensa please confirm, and resolve again if that's the case

cproensa

cproensa

2017-04-16 19:36

developer   ~0056596

so I'm not sure it can be considered as fixed in 2.3.1.

Since it was a regression in 2.3.0, and both this fix and the original change have been reverted, the issue is still technically fixed in 2.3.1
I'd say, keep it resolved as is, and let's be careful to not reintroduce the error when implementing the datepicker again.

Related Changesets

MantisBT: master-2.3 757320b2

2017-04-10 10:14:11

José D. Grieco


Committer: vboctor Details Diff
Missing "echo" in date-picker-locale attrib in due date field
mod - bug_change_status_page.php Diff File

Issue History

Date Modified Username Field Change
2017-04-10 09:33 jdgrieco New Issue
2017-04-10 09:40 atrol Status new => feedback
2017-04-10 09:40 atrol Note Added: 0056472
2017-04-10 10:51 jdgrieco Note Added: 0056479
2017-04-10 10:51 jdgrieco Status feedback => new
2017-04-10 10:58 atrol Relationship added related to 0020040
2017-04-10 10:59 atrol Assigned To => community
2017-04-10 10:59 atrol Status new => assigned
2017-04-10 10:59 atrol Target Version => 2.4.0
2017-04-10 10:59 atrol Note Added: 0056480
2017-04-10 11:47 vboctoradmin Status assigned => resolved
2017-04-10 11:47 vboctoradmin Resolution open => fixed
2017-04-10 11:47 vboctoradmin Product Version => 2.3.0
2017-04-10 11:47 vboctoradmin Fixed in Version => 2.3.1
2017-04-10 12:11 atrol Target Version 2.4.0 => 2.3.1
2017-04-10 12:18 atrol Changeset attached => MantisBT master-2.3 757320b2
2017-04-12 12:01 mahindra Note Added: 0056507
2017-04-12 14:25 atrol Note Added: 0056513
2017-04-12 14:37 mahindra File Added: Versionsdatum.png
2017-04-12 14:37 mahindra Note Added: 0056514
2017-04-13 02:14 atrol Note Added: 0056516
2017-04-13 02:20 mahindra Note Added: 0056519
2017-04-13 02:25 mahindra Note Added: 0056520
2017-04-13 02:35 atrol Note Added: 0056521
2017-04-13 02:49 mahindra Note Added: 0056524
2017-04-16 19:28 dregad Assigned To community => cproensa
2017-04-16 19:28 dregad Status resolved => feedback
2017-04-16 19:28 dregad Resolution fixed => reopened
2017-04-16 19:28 dregad Note Added: 0056594
2017-04-16 19:36 cproensa Note Added: 0056596
2017-04-21 17:44 atrol Status feedback => resolved
2017-04-21 17:44 atrol Resolution reopened => fixed
2017-04-23 10:54 atrol Status resolved => closed