View Issue Details

IDProjectCategoryView StatusLast Update
0022703mantisbtemailpublic2017-04-19 17:28
Reporterdharmangp25Assigned To 
PriorityhighSeverityminorReproducibilityN/A
Status closedResolutionno change required 
Product Version2.3.0 
Target VersionFixed in Version 
Summary0022703: Email is not working
Description

I am trying to configure email notification on Mantis which is on windows server MySQL database. I am using below configuration:

###########################

MantisBT Email Settings

###########################
#$g_webmaster_email = 'webmaster@example.com';
$g_from_email = 'osha@hunterconsulting.com';
$g_from_name = 'OSHA';
$g_return_path_email = 'dhansaliya@hunterconsulting.com';
$g_enable_email_notification = ON;
$g_email_notifications_verbose = OFF;
$g_default_notify_flags = array(
'reporter' => ON,
'handler' => ON,
'monitor' => ON,
'bugnotes' => ON,
'category' => ON,
'explicit' => ON,
'threshold_min' => NOBODY,
'threshold_max' => NOBODY
);
$g_notify_flags['new'] = array(
'bugnotes' => OFF,
'monitor' => OFF
);

$g_notify_flags['monitor'] = array(
'reporter' => OFF,
'handler' => OFF,
'monitor' => OFF,
'bugnotes' => OFF,
'explicit' => ON,
'threshold_min' => NOBODY,
'threshold_max' => NOBODY
);
$g_email_receive_own = OFF;
$g_validate_email = ON;
$g_email_ensure_unique = ON;
$g_check_mx_record = OFF;
$g_allow_blank_email = OFF;
$g_limit_email_domains = array();
$g_show_user_email_threshold = NOBODY;
$g_show_user_realname_threshold = NOBODY;
$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
$g_smtp_host = 'MY_SMTP_SERVER';
$g_smtp_username = 'username@MY_SMTP_SERVER';
$g_smtp_password = 'my SMTP_SERVER_PASSWORD';
$g_smtp_connection_mode = 'tls';
$g_smtp_port = 25;
$g_email_send_using_cronjob = OFF;
$g_email_separator1 = str_pad('', 70, '=');
$g_email_separator2 = str_pad('', 70, '-');
$g_email_padding_length = 28;

and I am getting following error. I not sure what I am doing wrong. I will really appreciate if you guys can help me.

Thanks

2017-04-10 11:11 EDT MAIL email_api.php:974 email_bugnote_add() Note ~18 added to issue 0000001
2017-04-10 11:11 EDT RECIPIENT email_api.php:280 email_collect_recipients() Issue = 0000001, add @U2 (reporter)
2017-04-10 11:11 EDT RECIPIENT email_api.php:290 email_collect_recipients() Issue = 0000001, add @U1 (handler)
2017-04-10 11:11 EDT RECIPIENT email_api.php:344 email_collect_recipients() Issue = 0000001, add @U1 (note author)
2017-04-10 11:11 EDT RECIPIENT email_api.php:427 email_collect_recipients() Issue = 0000001, drop @U1 (own action)

TagsNo tags attached.

Activities

atrol

atrol

2017-04-10 12:28

developer   ~0056482

dharmangp25,

I am getting following error

I don't see any error

drop @U1 (own action)

Maybe you expect to get notifications for your own actions?
If so, set $g_email_receive_own = ON;

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

dharmangp25

dharmangp25

2017-04-10 12:53

reporter   ~0056483

But I am not recieving any emails. Even after doing this $g_email_receive_own = ON;

atrol

atrol

2017-04-10 12:59

developer   ~0056484

Please check the forum for similar issues, especially read https://www.mantisbt.org/forums/viewtopic.php?f=3&t=15398

Feel free to reopen the issue if you should finally find that this is no configuration issue, but a bug in MantisBT.

Issue History

Date Modified Username Field Change
2017-04-10 11:23 dharmangp25 New Issue
2017-04-10 12:28 atrol Status new => resolved
2017-04-10 12:28 atrol Resolution open => no change required
2017-04-10 12:28 atrol Note Added: 0056482
2017-04-10 12:53 dharmangp25 Note Added: 0056483
2017-04-10 12:59 atrol Note Added: 0056484
2017-04-19 17:28 atrol Status resolved => closed