View Issue Details

IDProjectCategoryView StatusLast Update
0022740mantisbtperformancepublic2017-04-20 01:25
ReporterlibregeekAssigned Tovboctor 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version2.4.0Fixed in Version2.4.0 
Summary0022740: Allowed memory size of 268435456 bytes exhausted
Description

Tested the master branch in my development environment and got the following error:

[Mon Apr 17 12:35:05.009071 2017] [:error] [pid 3677] [client 127.0.0.1:38148] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /var/www/html/demo/mantisbt/library/adodb/drivers/adodb-mysqli.inc.php on line 908
[Mon Apr 17 12:35:05.011024 2017] [:error] [pid 3677] [client 127.0.0.1:38148] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 65536 bytes) in Unknown on line 0
Additional Information

Environment details:
OS: Fedora 25
PHP 7.0.17
httpd-2.4.25-1.fc25.x86_64

php.ini
memory_limit = 256M

TagsNo tags attached.

Relationships

related to 0004235 resolvedvboctor Support Generic Authentication through Plug-ins 

Activities

atrol

atrol

2017-04-17 04:36

developer   ~0056598

I am pretty sure it's caused by the changes for 0004235.

None of my test installations is running at the moment. I saw similar errors and got also web server crashes.

atrol

atrol

2017-04-17 17:08

developer   ~0056603

@vboctor I found the following endless loop

auth_get_current_user_id
    access_denied
        auth_login_page
            auth_flags
                auth_get_current_user_id
vboctor

vboctor

2017-04-18 20:40

manager   ~0056614

Is there specific steps or configuration that trigger this error vs. not? I will look into it and see if I can reproduce.

vboctor

vboctor

2017-04-18 21:25

manager   ~0056615

I was able to reproduce this. It happens when anonymous access is disabled and attempting to access a bug. Working on a fix.

vboctor

vboctor

2017-04-18 21:35

manager   ~0056616

PR: https://github.com/mantisbt/mantisbt/pull/1096

atrol

atrol

2017-04-19 10:35

developer   ~0056620

@libregeek can you confirm that the latest changes fix also your memory size issue?

libregeek

libregeek

2017-04-20 01:25

reporter   ~0056627

Yes, the issue is fixed.

Related Changesets

MantisBT: master 90bab53d

2017-04-18 21:32:15

vboctor

Details Diff
Fix access denied loop when user not logged in

Fixes 0022740
mod - core/authentication_api.php Diff File

Issue History

Date Modified Username Field Change
2017-04-17 03:11 libregeek New Issue
2017-04-17 04:36 atrol Note Added: 0056598
2017-04-17 17:04 atrol Relationship added related to 0004235
2017-04-17 17:04 atrol Severity major => block
2017-04-17 17:04 atrol Product Version 2.3.1 =>
2017-04-17 17:08 atrol Note Added: 0056603
2017-04-17 17:09 atrol Assigned To => vboctor
2017-04-17 17:09 atrol Status new => assigned
2017-04-17 17:09 atrol Target Version => 2.4.0
2017-04-18 20:40 vboctor Note Added: 0056614
2017-04-18 21:25 vboctor Note Added: 0056615
2017-04-18 21:35 vboctor Note Added: 0056616
2017-04-19 10:24 vboctor Changeset attached => MantisBT master 90bab53d
2017-04-19 10:24 vboctor Status assigned => resolved
2017-04-19 10:24 vboctor Resolution open => fixed
2017-04-19 10:24 vboctor Fixed in Version => 2.4.0
2017-04-19 10:35 atrol Note Added: 0056620
2017-04-20 01:25 libregeek Note Added: 0056627