View Issue Details

IDProjectCategoryView StatusLast Update
0022752mantisbtperformancepublic2017-06-20 01:44
Reportervits_soporteAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.3.1 
Target VersionFixed in Version 
Summary0022752: Status icons change to black
Description

Hello, according to attached graphs, when you press repeatedly on menu options, the status icons change to black as well as finally says

TagsNo tags attached.

Relationships

has duplicate 0023033 closedatrol All states are in the same color 

Activities

vits_soporte

vits_soporte

2017-04-20 15:53

reporter  

tk-1576.zip (907,477 bytes)
atrol

atrol

2017-04-21 02:31

developer   ~0056634

vits_soporte,

I was not able to reproduce your problem with a fresh install of MantisBT release.

The following additional information may be useful:

  • Exact version of PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
vits_soporte

vits_soporte

2017-04-21 11:46

reporter   ~0056641

Hi, I really Thank you for the answer:

A) php vrs 5.5 | Bd mysql (mysql) | Apache | Chrome, firefox, ie | Windows 8
B) nothing special, in fact restart again to standard 2.3.1 and the same color behavior of states in black, randomly, sometimes good, sometimes wrong
C) yes, Pokret Billing 2.0.0 and Snippets 1.1.0, but the same, I removed them and the new standard 2.3.1 shows the black color error already described
D) no, Has not been modified, highlighting that we came from vrs 2.3.0 without inconvenience and only came to see, when installing vrs 2.3.1

1 ) when would you release vrs 2.3.2?
2) when would you release vrs 2.4.0?

Thanks for the support,
regards.

Atn: Carlos Felipe Lozada



02.jpg (290,299 bytes)
02.jpg (290,299 bytes)
a.jpg (200,112 bytes)
a.jpg (200,112 bytes)
01.jpg (319,602 bytes)
vits_soporte

vits_soporte

2017-04-21 12:43

reporter   ~0056642

Hi,
the Operating System is Windows 8.1

And an additional question, is some plugin or configuration, to be able to visualize images in the notes of the .jpg attachments?

thanks.

Atn: Carlos Felipe

vits_soporte

vits_soporte

2017-04-21 13:07

reporter   ~0056643

Hello, attachment for chrome, debugging in case this is anything, highlighting that we have not made any modification in these files

Thank you for all the support you can give us

Atn: Carlos Lozada



03.jpg (274,607 bytes)
03.jpg (274,607 bytes)
atrol

atrol

2017-04-21 13:56

developer   ~0056645

There is certainly some more information behind the red marked GET in browser console.
Those two entries are responsible for the issue.

Check also your web server / PHP logs for errors and warnings.

vits_soporte

vits_soporte

2017-04-23 17:18

reporter   ~0056657

Hello Astrol, thanks for the reply, could you please help us? We are attaching the warnings and errors
And we have verified that it is a problem that vrs 2.3.1 and 2.3.0.

we have created from scratch the vrs 2.3.0 and you can enter:

www.hqo.sgep.venturitsoft.com/mantisbt-2.3.0/
user: vits_soporte
password: soporte-hqo

"login.jpg"
"DL_TK-1576_Detalle.pdf"

logs for errors :

[Sun Apr 23 15:48:39.829088 2017] [:error] [pid 574353:tid 140483523233536] (12)Cannot allocate memory: [client 181.53.217.203:52417] couldn't create child process: /opt/suphp/sbin/suphp for /home/venturit/public_html/_proyecto/hqo-sgep/mantisbt-2.3.0/css/status_config.php, referer: http://www.hqo.sgep.venturitsoft.com/mantisbt-2.3.0/my_view_page.php

Could you give us some new guidance?
Should the hosting have any particular permission?

Why do you think refreshing the page sometimes looks good color and sometimes does not load css / status_config.php styles? And other times yes load?

Thanks
Atn: Carlos Lozada



config_inc.php (753 bytes)
<?php
$g_hostname               = 'localhost';
$g_db_type                = 'mysqli';
$g_database_name          = 'venturit_hqo-sgep-mantisbt-2';
$g_db_username            = 'venturit_hqo';
$g_db_password            = 'soporte-hqo';

$g_default_timezone       = 'America/Bogota';

$g_crypto_master_salt     = '7knF11nm7ssTSXR5kAthKk9Wm2eayEnynG7VgmyAT+E+';


	//Cantidad de cajas de texto en el inicio, para simplificar la informaciĆ³n a mostrar
	$g_my_view_boxes = array (
	'assigned'      => '1', #1
	'unassigned'    => '0', #2
	'reported'      => '0', #3
	'resolved'      => '0', #4
	'recent_mod'    => '5', #5
	'monitored'     => '0', #6
	'feedback'      => '0', #0
	'verify'        => '0', #0
	'my_comments'   => '0' #0
	);
	
config_inc.php (753 bytes)
DL_TK-1576_Detalle.pdf (539,734 bytes)
common_config.php (2,426 bytes)
<?php
# MantisBT - A PHP based bugtracking system

# MantisBT is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 2 of the License, or
# (at your option) any later version.
#
# MantisBT is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with MantisBT.  If not, see <http://www.gnu.org/licenses/>.

/**
 * Generate Common CSS that requires PHP Output, and therefore can not be included in the .css files
 * For example, language specific settings
 *
 * @package MantisBT
 * @copyright Copyright 2000 - 2002  Kenzaburo Ito - kenito@300baud.org
 * @copyright Copyright 2002  MantisBT Team - mantisbt-dev@lists.sourceforge.net
 * @link http://www.mantisbt.org
 *
 * @uses config_api.php
 */

# Prevent output of HTML in the content if errors occur
define( 'DISABLE_INLINE_ERROR_REPORTING', true );

@require_once( dirname( dirname( __FILE__ ) ) . '/core.php' );
require_api( 'lang_api.php' );
require_api( 'config_api.php' );

/**
 * Send correct MIME Content-Type header for css content.
 */
header( 'Content-Type: text/css; charset=UTF-8' );

/**
 * Don't let Internet Explorer second-guess our content-type, as per
 * http://blogs.msdn.com/b/ie/archive/2008/07/02/ie8-security-part-v-comprehensive-protection.aspx
 */
header( 'X-Content-Type-Options: nosniff' );
$g_display_errors = null;

/**
 * WARNING: DO NOT EXPOSE SENSITIVE CONFIGURATION VALUES!
 *
 * All configuration values below are publicly available to visitors of the bug
 * tracker regardless of whether they're authenticated. Server paths should not
 * be exposed. It is OK to expose paths that the user sees directly (short
 * paths) but you do need to be careful in your selections. Consider servers
 * using URL rewriting engines to mask/convert user-visible paths to paths that
 * should only be known internally to the server.
 */
?>
div.form-container fieldset.required:after {
	position: absolute;
	margin: -1.75em 0em 0em .5em;
	font-size: 8pt;
	content: '* <?php echo lang_get( 'required' ); ?>';
	color: red;
}
common_config.php (2,426 bytes)
login.jpg (172,072 bytes)
login.jpg (172,072 bytes)
status_config.php (3,781 bytes)
<?php
# MantisBT - A PHP based bugtracking system

# MantisBT is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 2 of the License, or
# (at your option) any later version.
#
# MantisBT is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with MantisBT.  If not, see <http://www.gnu.org/licenses/>.

/**
 * Generate CSS from that requires output from php for specific settings e.g. status values
 *
 * @package MantisBT
 * @copyright Copyright 2000 - 2002  Kenzaburo Ito - kenito@300baud.org
 * @copyright Copyright 2002  MantisBT Team - mantisbt-dev@lists.sourceforge.net
 * @link http://www.mantisbt.org
 *
 * @uses config_api.php
 */

# Prevent output of HTML in the content if errors occur
define( 'DISABLE_INLINE_ERROR_REPORTING', true );

@require_once( dirname( dirname( __FILE__ ) ) . '/core.php' );
require_api( 'config_api.php' );

/**
 * Send correct MIME Content-Type header for css content.
 */
header( 'Content-Type: text/css; charset=UTF-8' );

/**
 * Don't let Internet Explorer second-guess our content-type, as per
 * http://blogs.msdn.com/b/ie/archive/2008/07/02/ie8-security-part-v-comprehensive-protection.aspx
 */
header( 'X-Content-Type-Options: nosniff' );

/**
 * WARNING: DO NOT EXPOSE SENSITIVE CONFIGURATION VALUES!
 *
 * All configuration values below are publicly available to visitors of the bug
 * tracker regardless of whether they're authenticated. Server paths should not
 * be exposed. It is OK to expose paths that the user sees directly (short
 * paths) but you do need to be careful in your selections. Consider servers
 * using URL rewriting engines to mask/convert user-visible paths to paths that
 * should only be known internally to the server.
 */

/**
 *	@todo Modify to run sections only on certain pages.
 *	eg. status colors are only necessary on a few pages.(my view, view all bugs, bug view, etc. )
 *	other pages may need to include dynamic css styles as well
 */
$t_referer_page = array_key_exists( 'HTTP_REFERER', $_SERVER )
	? basename( parse_url( $_SERVER['HTTP_REFERER'], PHP_URL_PATH ) )
	: basename( __FILE__ );
switch( $t_referer_page ) {
	case 'login_page.php':
	case 'signup_page.php':
	case 'lost_pwd_page.php':
	case 'account_update.php':
		# We don't need custom status colors on login page, and this is
		# actually causing an error since we're not authenticated yet.
		exit;
}

$t_status_string = config_get( 'status_enum_string' );
$t_statuses = MantisEnum::getAssocArrayIndexedByValues( $t_status_string );
$t_colors = config_get( 'status_colors' );
$t_status_percents = auth_is_user_authenticated() ? get_percentage_by_status() : array();

foreach( $t_statuses as $t_id => $t_label ) {
	$t_css_class = html_get_status_css_class( $t_id );

	# Status color class
	if( array_key_exists( $t_label, $t_colors ) ) {
		echo '.' . $t_css_class
			. " { color: {$t_colors[$t_label]}; background-color: {$t_colors[$t_label]}; }\n";
	}

	# Status percentage width class
	if( array_key_exists( $t_id, $t_status_percents ) ) {
		echo '.' . str_replace( 'color', 'percentage', $t_css_class )
			. " { width: {$t_status_percents[$t_id]}%; }\n";
	}
}

# Status legend width class
$t_color_count = count( $t_colors );
$t_color_width = ( $t_color_count > 0 ? ( round( 100/$t_color_count ) ) : 0 );
echo ".status-legend-width { width: $t_color_width%; }\n";
status_config.php (3,781 bytes)
atrol

atrol

2017-04-24 17:04

developer   ~0056697

that we came from vrs 2.3.0 without inconvenience and only came to see, when installing vrs 2.3.1

Seems this is no longer true, as the issue can also be reproduced on http://www.hqo.sgep.venturitsoft.com/mantisbt-2.3.0 which is 2.3.0

Cannot allocate memory: [client 181.53.217.203:52417] couldn't create child process

Seems this is no MantisBT issue, but an issue with your server (not enough memory) and/or your web server configuration.

You could also try to use another PHP version.

vits_soporte

vits_soporte

2017-04-24 18:51

reporter   ~0056699

Many thanks Astrol, we will escalate the issue with our hosting provider.

  1. we tried to change php and did not load MantisBT so we left in 5.5

  2. When do they have a new version release? 2.3.2? And 2.3.4? Approx

  3. according to the annex "answer_sobre_notas.jpg" is some pluguin with which we can respond to comments? Could you tell us the pluguin to use it?

Thank you so much



responder_sobre_notas.jpg (71,469 bytes)
responder_sobre_notas.jpg (71,469 bytes)
atrol

atrol

2017-04-25 03:05

developer   ~0056702

we tried to change php and did not load MantisBT so we left in 5.5

I recommend to use a newer version.

When do they have a new version release? 2.3.2? And 2.3.4? Approx

Should be in 1-2 weeks, but this will hardly solve your issue.

is some pluguin with which we can respond to comments?

This is a setting of the MantisBT Formatting core plugin that comes with a standard installation.
You can set Markdown Processing to On to enable this experimental feature.
The syntax to use is: https://github.com/adam-p/markdown-here/wiki/Markdown-Cheatsheet

vits_soporte,

This is not a bug or feature request for MantisBT (you are asking for help on how to deal with problems of your operating emvironment and for help on customization). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

dregad

dregad

2017-04-25 06:32

developer   ~0056704

For the record, I saw the "black squares" once while browsing https://mantisbt.org/bugs from my phone (iOS / Safari) yesterday; things went back to normal after a refresh.

vits_soporte

vits_soporte

2017-04-25 08:37

reporter   ~0056707

Thank you very much, very valuable your help, regards.

--
Equipo de Soporte
Atn: Carlos Felipe

vits_soporte

vits_soporte

2017-04-26 00:51

reporter   ~0056714

Hello, thank you very much for all the support and indeed, fine tuning with my hosting provider, we managed to prove that the problem was php memory that had been reinitialized on the server.

The solution is that the variable is above 256MB
Memory_limit

We attach file "Solution_Memory_Php_MEMORY_LIMIT.jpg" for whom this information can be used.

And we were looking at the administrator's documentation
Http://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/

We did not find this information and therefore our recommendation that the manual be updated with this prerequisite so that there are no failures as illustrated in this ticket.

Thanks and regards.

--
Equipo de Soporte
Atn: Carlos Lozada



atrol

atrol

2017-04-26 02:33

developer   ~0056715

Thanks @vits_soporte for this information.

I am a bit astonished, as memory usage on my test system is just about 2-3MB.
At least this is shown on the bottom of the page when having set $g_show_memory_usage = ON;

Issue History

Date Modified Username Field Change
2017-04-20 15:53 vits_soporte New Issue
2017-04-20 15:53 vits_soporte File Added: tk-1576.zip
2017-04-21 02:31 atrol Status new => feedback
2017-04-21 02:31 atrol Note Added: 0056634
2017-04-21 02:31 atrol Priority urgent => normal
2017-04-21 02:31 atrol Severity crash => minor
2017-04-21 11:46 vits_soporte File Added: a.jpg
2017-04-21 11:46 vits_soporte File Added: 01.jpg
2017-04-21 11:46 vits_soporte File Added: 02.jpg
2017-04-21 11:46 vits_soporte Note Added: 0056641
2017-04-21 11:46 vits_soporte Status feedback => new
2017-04-21 12:43 vits_soporte Note Added: 0056642
2017-04-21 13:07 vits_soporte File Added: 03.jpg
2017-04-21 13:07 vits_soporte Note Added: 0056643
2017-04-21 13:56 atrol Status new => feedback
2017-04-21 13:56 atrol Note Added: 0056645
2017-04-23 17:18 vits_soporte File Added: login.jpg
2017-04-23 17:18 vits_soporte File Added: DL_TK-1576_Detalle.pdf
2017-04-23 17:18 vits_soporte File Added: common_config.php
2017-04-23 17:18 vits_soporte File Added: config_inc.php
2017-04-23 17:18 vits_soporte File Added: status_config.php
2017-04-23 17:18 vits_soporte Note Added: 0056657
2017-04-23 17:18 vits_soporte Status feedback => new
2017-04-24 17:04 atrol Status new => feedback
2017-04-24 17:04 atrol Note Added: 0056697
2017-04-24 18:51 vits_soporte File Added: responder_sobre_notas.jpg
2017-04-24 18:51 vits_soporte Note Added: 0056699
2017-04-24 18:51 vits_soporte Status feedback => new
2017-04-25 03:05 atrol Assigned To => atrol
2017-04-25 03:05 atrol Status new => resolved
2017-04-25 03:05 atrol Resolution open => no change required
2017-04-25 03:05 atrol Note Added: 0056702
2017-04-25 06:32 dregad Note Added: 0056704
2017-04-25 08:37 vits_soporte Note Added: 0056707
2017-04-26 00:51 vits_soporte File Added: Solution_Memory_Php_MEMORY_LIMIT.jpg
2017-04-26 00:51 vits_soporte Note Added: 0056714
2017-04-26 02:33 atrol Note Added: 0056715
2017-04-30 14:48 vboctor Status resolved => closed
2017-06-20 01:44 atrol Relationship added has duplicate 0023033