View Issue Details

IDProjectCategoryView StatusLast Update
0023016mantisbtauthorizationpublic2017-06-28 02:34
ReporterpjjAssigned Toatrol 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version2.5.0 
Target VersionFixed in Version 
Summary0023016: Cannot update the status of an issue if resolution set to a certain value
Description

We have customized Mantis to match a desired workflow.
For issues that are "change request" to be analysed by us (supplier of the customer) we have defined

  • status = "Pending"
  • Resolution "Change Request"
    For issue having other status, it is impossible to reach that configuration (allowed by Workflow definitions).
    Once you have tried, it is impossible to change the status of the issue :

    APPLICATION ERROR #24
    Resolution "Change Request" is not allowed for status "open".
    Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.
TagsNo tags attached.

Activities

atrol

atrol

2017-06-15 06:27

developer   ~0057087

pjj,

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Issue History

Date Modified Username Field Change
2017-06-15 06:04 pjj New Issue
2017-06-15 06:27 atrol Assigned To => atrol
2017-06-15 06:27 atrol Status new => resolved
2017-06-15 06:27 atrol Resolution open => no change required
2017-06-15 06:27 atrol Note Added: 0057087
2017-06-28 02:34 atrol Status resolved => closed