View Issue Details

IDProjectCategoryView StatusLast Update
0023103mantisbtinstallationpublic2017-07-27 04:10
ReporterjweinraubAssigned Toatrol 
PriorityurgentSeverityblockReproducibilityalways
Status closedResolutionno change required 
Product Version2.5.1 
Target VersionFixed in Version 
Summary0023103: Installation redirects to non-existent URI
Description

I have successfully installed mantisbt on my debian test server. However, when I tried to install on my production RHEL server, it doesn't work. It attempts to redirect from mantis/admin/install.php to mantis/admin/core/install.php, which then 404s. The server shows it is trying to redirect to the non-existent site. If I copy everything into the core directory since it is thinking to use it, I get error 500 instead.

Steps To Reproduce

Use RHEL 7 x64.
Use PHP from the non-standard channel to use the newer version
Extract tarball into /var/www/html
Go to http://localhost/mantis/admin/install.php
It fails.

Additional Information

I have on forums, but nobody seems to want to care or help.
https://www.mantisbt.org/forums/viewtopic.php?f=3&t=24772&p=62699#p62699

TagsNo tags attached.

Activities

atrol

atrol

2017-07-14 18:27

developer   ~0057227

Use RHEL 7 x64.

Can you provide step by step instructions to reproduce it on CentOS?

Use PHP from the non-standard channel to use the newer version

Do you get the issue when using the standard PHP?

I have on forums, but nobody seems to want to care or help.

Seems I am nobody

jweinraub

jweinraub

2017-07-17 09:44

reporter   ~0057241

I am using php 5.6 which is a non standard version with RHEL 7.
I am unable to reproduce on Centos, I used it in a virtual machine and it installed fine.
I was able to install by making a symbolic link core from within the admin folder.
However, the css did not load for admin, and while it did populate the database tables, it added _mantis as a suffix and it was expecting suffix _table, which forced me to rename all the tables from within the database in the mysql console.

This is what I have:

[root@nj-way-intranet:/var/www/html/mantis/admin]# rpm -qa | grep php
php56w-mysql-5.6.30-1.w7.x86_64
php56w-opcache-5.6.30-1.w7.x86_64
php56w-pear-1.10.1-1.w7.noarch
php56w-devel-5.6.30-1.w7.x86_64
php56w-mbstring-5.6.30-1.w7.x86_64
php56w-cli-5.6.30-1.w7.x86_64
php56w-pdo-5.6.30-1.w7.x86_64
php56w-snmp-5.6.30-1.w7.x86_64
php56w-5.6.30-1.w7.x86_64
php56w-gd-5.6.30-1.w7.x86_64
php56w-common-5.6.30-1.w7.x86_64
php56w-xml-5.6.30-1.w7.x86_64
php56w-imap-5.6.30-1.w7.x86_64
php56w-process-5.6.30-1.w7.x86_64

atrol

atrol

2017-07-17 10:38

developer   ~0057242

jweinraub,

As a first step I recommend to compare the Apache configuration of your CentOS and RHEL installations.
Especially have a look at any Rewrite or Redirect configuration in httpd.conf.

This seems not to be a bug or feature request for MantisBT (you are asking for help on how to deal with configuration problems of your web server). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Feel free to reopen the issue if you finally find that Mantis is dealing wrong with a Webserver / PHP configuration that should work.

Issue History

Date Modified Username Field Change
2017-07-11 14:52 jweinraub New Issue
2017-07-14 18:27 atrol Status new => feedback
2017-07-14 18:27 atrol Note Added: 0057227
2017-07-17 09:44 jweinraub Note Added: 0057241
2017-07-17 09:44 jweinraub Status feedback => new
2017-07-17 10:38 atrol Assigned To => atrol
2017-07-17 10:38 atrol Status new => resolved
2017-07-17 10:38 atrol Resolution open => no change required
2017-07-17 10:38 atrol Note Added: 0057242
2017-07-27 04:10 atrol Status resolved => closed