View Issue Details

IDProjectCategoryView StatusLast Update
0023112mantisbtcustom fieldspublic2017-08-11 01:45
ReporterjlballoisAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.1.0 
Target Version2.6.0Fixed in Version2.6.0 
Summary0023112: Custom fields badly filtered when multi-projects
Description

Hi everyone,

We've recently tested and upgraded from our old Mantis version to version 2.1.0.

We are using it for several projects and have added specific custom fields. One of them is shared and used on many of our projects and called "priorite secondaire" (French). This custom field is a simple and free text field (alowing alpha characters).

Since we've upgraded in 2.1.0, it is still possible to filter on "priorite secondaire" on the view page but the combo box is showing all possible custom fields values (stored in database) no matter the selected project.

This is very embarrassing as we share our mantis bugtracker with our clients and don't want custom fields values from client A to show up on client B page.

This bug might be related to the 0022209 bug fix I guess.

Could you please help me ?

Thx.

JL.

Steps To Reproduce

Add the same custom field (free text field) on project A and project B.

Log to the project A and add a bug specifying value "aaaaa" in the custom field.

Log to the project B and add a bug specifying value "bbbbb" in the custom field.

Go to the view bug page (still keeping the project B as selected).

Try to filter on the custom fiel value and both "aaaaa" and "bbbbb" will show up in the combo box.

Note : this behaviour happened on a migrated database from version 1.2.x to version 2.1.0. This has not been tested on a freshly installed 2.1.0 mantis.

TagsNo tags attached.

Relationships

related to 0021935 closedcproensa Filter api refactoring, manage stored filters 

Activities

atrol

atrol

2017-07-23 08:41

developer   ~0057294

Does not occur in 2.0.0, so this seems to be caused by the major filter rewrite in 2.1.0

cproensa

cproensa

2017-08-09 18:50

developer   ~0057418

Does not occur in 2.0.0, so this seems to be caused by the major filter rewrite in 2.1.0

yes, this is a regression from previous behaviour. A quick fix can be done for that.

However, i'm not sure if that is actually correct, beacuse:

  • Viewing a parent project for projects A and B, none of the values from A and B are populated, even when i can see those issues with my current filter (a simple filter)
  • Current filter may be showing any arbitrary project different thatn "current project", thus populating the wrong values for the visible issues.
cproensa

cproensa

2017-08-09 19:32

developer   ~0057419

PR https://github.com/mantisbt/mantisbt/pull/1148

Related Changesets

MantisBT: master 508ab61c

2017-08-09 19:27:09

cproensa


Committer: vboctor Details Diff
Fix filter by custom fields distinct values

Fix populating available values for a custom field, to match the
behaviour of version < 2.1, where the retrieved values are those
existing only for current project issues.

Fixes: 0023112
mod - core/filter_form_api.php Diff File

Issue History

Date Modified Username Field Change
2017-07-13 14:49 jlballois New Issue
2017-07-23 08:41 atrol Assigned To => cproensa
2017-07-23 08:41 atrol Status new => confirmed
2017-07-23 08:41 atrol Note Added: 0057294
2017-07-23 08:42 atrol Relationship added related to 0021935
2017-08-09 18:50 cproensa Note Added: 0057418
2017-08-09 19:32 cproensa Note Added: 0057419
2017-08-10 21:56 vboctor Changeset attached => MantisBT master 508ab61c
2017-08-10 21:56 cproensa Status confirmed => resolved
2017-08-10 21:56 cproensa Resolution open => fixed
2017-08-10 21:56 cproensa Fixed in Version => 2.6.0
2017-08-11 01:45 atrol Target Version => 2.6.0