View Issue Details

IDProjectCategoryView StatusLast Update
0023338mantisbttoolspublic2017-09-20 17:01
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0023338: Fix TravisCI builds following changes in their infrastructure
Description

Since July 2017, TravisCI builders are defaulting to Ubuntu 14.04 trusty (changed from 12.04 precise).

This caused a couple of issues with the MantisBT builds:

  • PHP 5.3 jobs fail because that version is not supported under precise (1.3.x branch only)
  • PHP 7.x jobs errors in before_install due to the /home/travis/bin directory already existing (all version)
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 9eabe60c

2017-09-04 08:26:02

dregad

Details Diff
Fix TravisCI builds

The before_install command to force use of phpunit 5.7 on PHP 7.x failed
because the /home/travis/bin directory already existed.

Added '-p' flag to mkdir command to avoid error.
mod - .travis.yml Diff File

MantisBT: master-2.6 e184e8e5

2017-09-04 08:26:02

dregad

Details Diff
Fix TravisCI builds

The before_install command to force use of phpunit 5.7 on PHP 7.x failed
because the /home/travis/bin directory already existed.

Added '-p' flag to mkdir command to avoid error.
mod - .travis.yml Diff File

MantisBT: master-1.3.x 97089311

2017-09-04 08:26:02

dregad

Details Diff
Fix TravisCI builds

The before_install command to force use of phpunit 5.7 on PHP 7.x failed
because the /home/travis/bin directory already existed.

Added '-p' flag to mkdir command to avoid error.

Backported from 9eabe60c77d46d427182ec9f431b0309f1789306
mod - .travis.yml Diff File

MantisBT: master-1.3.x ff14f1c1

2017-09-10 19:47:37

dregad

Details Diff
Travis: force PHP 5.3 builds on precise

PHP 5.3.x is not supported on default TravisCI builders (Trusty).

Reference:
https://docs.travis-ci.com/user/reference/trusty#PHP-images

PHP 5.3 is removed from the main php list, and setup as an include in
the build matrix. This is required, otherwise the 5.3 builds end up
being executed twice, once with default 'trusty' and one with 'precise.
mod - .travis.yml Diff File

Issue History

Date Modified Username Field Change
2017-09-11 04:58 dregad New Issue
2017-09-11 04:58 dregad Status new => assigned
2017-09-11 04:58 dregad Assigned To => dregad
2017-09-11 05:26 dregad Changeset attached => MantisBT master-1.3.x 97089311
2017-09-11 05:26 dregad Changeset attached => MantisBT master-2.6 e184e8e5
2017-09-11 05:27 dregad Changeset attached => MantisBT master 9eabe60c
2017-09-11 05:27 dregad Changeset attached => MantisBT master-1.3.x ff14f1c1
2017-09-11 05:27 dregad Status assigned => resolved
2017-09-11 05:27 dregad Resolution open => fixed
2017-09-20 17:01 atrol Status resolved => closed