View Issue Details

IDProjectCategoryView StatusLast Update
0023451mantisbtperformancepublic2017-10-11 10:28
ReporteratrolAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version2.8.0Fixed in Version2.8.0 
Summary0023451: Unneeded code delivered to support unsupported IE9
Description

Our minimal client requirement for Internet Explorer is version 10 according Admin Guide.
https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.install.requirements.client

There is no need to go on delivering code that is just used for IE9 and older.

We should also think about supporting just IE >= 11 as IE10 is no longer supported since January 2016 and IE11 is available on all currently supported Windows versions (7, 8.1, 10).

TagsNo tags attached.

Activities

Related Changesets

MantisBT: master 372f08fb

2017-10-10 02:50:15

atrol

Details Diff
Do not deliver code for outdated unsupported IE9 browser

Fixes 0023451
mod - core/layout_api.php Diff File
rm - css/ace-ie.min.css Diff File
rm - css/ace-part2.min.css Diff File

Issue History

Date Modified Username Field Change
2017-10-10 02:48 atrol New Issue
2017-10-10 02:48 atrol Status new => assigned
2017-10-10 02:48 atrol Assigned To => atrol
2017-10-10 02:53 atrol Note Added: 0057922
2017-10-11 10:28 atrol Changeset attached => MantisBT master 372f08fb
2017-10-11 10:28 atrol Status assigned => resolved
2017-10-11 10:28 atrol Resolution open => fixed
2017-10-11 10:28 atrol Fixed in Version => 2.8.0