View Issue Details

IDProjectCategoryView StatusLast Update
0023666mantisbtapi soappublic2017-12-04 02:17
ReportermantisiatorAssigned Todregad 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.8.0 
Target VersionFixed in Version 
Summary0023666: mc_issue_add does not trigger EVENT_REPORT_BUG/EVENT_REPORT_BUG_DATA event in plugin associated to bug creation
Description

When creating an issue via the Web interface, the plugin is called properly whereas when using the mc_issue_add api function, the plugin functions related to the events EVENT_REPORT_BUG/EVENT_REPORT_BUG_DATA are not called.

TagsNo tags attached.

Relationships

duplicate of 0011993 acknowledgedrombert trigger events when bug added etc via soap 

Activities

mantisiator

mantisiator

2017-11-23 05:38

reporter   ~0058240

Last edited: 2017-11-23 09:16

View 2 revisions

@atrol @rombert,
I just found that a similar point has been discussed in 0015235 pointing itself on 0013498. Do you know if a change has been merged into 2.8.0 ?

Thank you very much in advance

dregad

dregad

2017-11-23 09:26

developer   ~0058242

Do you know if a change has been merged into 2.8.0

No. @cproensa started working on this last year (see 0020578) but I don't think he got anywhere.

I'll resolve this as duplicate, please follow up in the other issue.

cproensa

cproensa

2017-11-23 10:13

developer   ~0058244

but I don't think he got anywhere.

The implementation is done, but still not approved:
https://github.com/mantisbt/mantisbt/pull/1098

dregad

dregad

2017-11-23 11:46

developer   ~0058245

The implementation is done, but still not approved

You're right. Sorry :-)

mantisiator

mantisiator

2017-11-23 14:57

reporter   ~0058246

Thank you very much for this feedback and the significant implementation. The implementation is rather a major change. When do you expect the change to be integrated into the kernel version ?

Issue History

Date Modified Username Field Change
2017-11-23 05:19 mantisiator New Issue
2017-11-23 05:38 mantisiator Note Added: 0058240
2017-11-23 09:16 dregad Note Edited: 0058240 View Revisions
2017-11-23 09:26 dregad Assigned To => dregad
2017-11-23 09:26 dregad Status new => resolved
2017-11-23 09:26 dregad Resolution open => duplicate
2017-11-23 09:26 dregad Note Added: 0058242
2017-11-23 09:26 dregad Relationship added duplicate of 0011993
2017-11-23 10:13 cproensa Note Added: 0058244
2017-11-23 11:46 dregad Note Added: 0058245
2017-11-23 14:57 mantisiator Note Added: 0058246
2017-12-04 02:17 vboctor Status resolved => closed