View Issue Details

IDProjectCategoryView StatusLast Update
0009450mantisbttaggingpublic2017-02-14 17:51
ReporterkrmichalAssigned Tovboctor 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformAllOSAllOS VersionAll
Product Version1.2.0a1 
Target VersionFixed in Version1.3.0-rc.2 
Summary0009450: Tagging possibility directly from "Report Issue" screen
Description

Would be great to have tagging possibility directly from "Report Issue" screen, and not only when editing already existing issue.

Tagsmantishub

Relationships

related to 0022088 new Can't add tag that is substring of a tag in the text field 
has duplicate 0017513 closedatrol Add ability to add tags when reporting an issue 
related to 0021679 closedatrol Tagging UI visible without having rights to attach tags 

Activities

XCompWiz

XCompWiz

2012-08-13 19:13

reporter   ~0032558

This issue has been open and acknowledged for 4 years?

Since I use Mantis as a public bug tracker and I want untrained users to correctly use tags it would be of huge benefit if I could make it possible to add tags from the initial Report. Any chance of this at all?

dregad

dregad

2012-08-14 13:22

developer   ~0032563

You can greatly increase your chances of this happening, by submitting a patch or even better a github pull request for this feature.

XCompWiz

XCompWiz

2014-07-24 05:23

reporter   ~0040966

This issue has been open and acknowledged for 6 years?

The response I received to this, while true, was so unhelpful I was too annoyed to bother responding at the time.
If there was anything else to the message than "you do it, we can't be bothered" then it would have come across better.

I've stopped using Mantis. There are other, more friendly solutions out there.
The fact that THIS issue tracker instance has "new" issues last touched in 2004 means it isn't doing it's job.

atrol

atrol

2014-07-24 16:58

developer   ~0040976

XCompWiz, Open source products (especially the ones where non payed volunteers are working in their free time on it) need people that contribute to the product to get enhancements.

Complaining does not help.

All contributions are welcome and greatly appreciated.
http://www.mantisbt.org/wiki/doku.php/mantisbt:contributing

XCompWiz

XCompWiz

2014-07-25 12:06

reporter   ~0040989

Last edited: 2014-07-25 12:08

View 2 revisions

Yes, I'm aware, sorry for coming off as grumpy and whining. I'm just still annoyed with the original response.

The last part of my message I stick to, though, though I think it should be reframed, and it probably isn't worth while to discuss it here:
"Has Mantis reached the end of its useful lifetime (It was fantastic in its time), given that there are easier to use solutions with more energy behind them now?"
Just food for thought, not really a proper place to discuss it.

I can fully grasp the volunteer work concept, as I used Mantis as a tracker for my own project which is not paid. Only real difference was that it is a closed source project, so I do all the work.
Perhaps it's too easy to fall into the "its open source, so if you want something you should make it" and "its open source, so someone else will do it." Those two conjoined pits seem to swallow a lot of open source projects, and that's most of what annoyed me, I think; that the response was basically an admission that Mantis had, too.

I'm not at all familiar with the Mantis codebase, or else I would have made such a pull request to begin with. At this juncture it's not worth the time and effort to learn the codebase, as I stopped using Mantis for various reasons over a year ago.

Good luck with all. :)

dregad

dregad

2014-08-08 16:43

developer   ~0041035

XCompWiz,

I just feel compelled to respond to your comments. You said you were annoyed by my response; I understand your reaction and I'm sorry for not having taken the time for a friendlier note. On the other hand, I'd like to say that I was similarly annoyed by your own comment. We get a lot of these, and while I usually ignore them or try to be more constructive/helpful, I guess I was having a bad day when I responded to you.

We are a very small team, and just lack the resources to implement all the bug fixes and features that get requested here, and as you've noticed, we even don't have time to respond or follow up with them. Because of that, we have to rely on our users to contribute patches; so my comment basically a poorly written request for "help me help you".

I regret you decided to stop using Mantis.

hamx0r

hamx0r

2015-08-03 10:25

reporter   ~0051188

I've forked he code and used the master 1.2.x branch to make a fix, but then thought i should check in with devs to see if this feature should go into a different branch. I see some ToDo comments suggesting things like parsing the CSV of tags should go into the API layer. How would you prefer i implement this feature? If in the 1.2.x branch, i see at least 3 files needing updates:

  • bug_reportpage.php - copy the $tpl and other variables from bug_view_inc along with <tr> from the tpl_can_attach_tag block
  • Somehow hide the Attach button - we want to just create a CSV of tags on the bug_report_page. This likely means modifying print_api.php's print_tag_attach_form function or else copying it to not have the submit button and using that copy
  • Update bug_report.php so it will also take in tags, split the CSV and store them just like tag_attach.php
dregad

dregad

2015-08-03 11:15

developer   ~0051190

New features should be targeted at master branch (1.3.x) only.

Kindly submit a pull request at Github with your proposed patch.

vboctor

vboctor

2016-03-21 12:07

manager   ~0052824

PR: https://github.com/mantisbt/mantisbt/pull/745

atrol

atrol

2016-06-07 04:26

developer   ~0053276

Last edited: 2016-06-07 04:27

View 2 revisions

Does not work for me using Safari Version 9.1.1 (11601.6.17)

Sometimes I am not able to add any tag from list of tags, sometimes I am able to add one tag but are not able to add a second one. After trying to add a second one I am no longer able to open the tag list.

I am not able to reproduce it using FF or Chrome.

I am not able to reproduce it using Safari when trying to add tags to existing issues (view.php).

atrol

atrol

2016-06-27 10:06

developer   ~0053470

@vboctor, does this work for you using Safari?

vboctor

vboctor

2016-06-29 23:59

manager   ~0053485

@atrol This works fine for me on Safari Version 9.1.1 (11601.6.17)

atrol

atrol

2016-07-01 04:47

developer   ~0053490

I will check again this week end.

atrol

atrol

2016-07-01 19:08

developer   ~0053497

Does not work for me

Result:
Keyboard focus is in tags text field, no content has been added to the field

  • Click again on "Existing Tags"

Result: No action triggered, drop down list does not open

atrol

atrol

2016-07-18 16:09

developer   ~0053634

Still the same with latest version from today 9.1.2 (11601.7.7)

vboctor

vboctor

2016-12-28 21:54

manager   ~0054859

Just tested on Safari Version 10.0.2 (12602.3.12.0.1) and it works. See video below:
http://www.screencast.com/t/clJuzW1pH

atrol

atrol

2016-12-29 08:18

developer  

TagAttach.mov (736,537 bytes)
atrol

atrol

2016-12-29 08:20

developer   ~0054867

Just tested on Safari Version 10.0.2 (12602.3.12.0.1) and it works.

Doesn't work for me using the same version, see attached TagAttach.mov

vboctor

vboctor

2016-12-29 14:15

manager   ~0054873

@atrol, can you check the javascript console to see if there are errors that can provide a hint of what is going on.

atrol

atrol

2016-12-29 17:10

developer   ~0054874

There are no errors in console related to tags, just the known CSP violation caused by our custom footer for Google Analytics.

I am not able to reproduce the issue on my own 1.3.x test installation.

atrol

atrol

2017-02-14 17:51

developer   ~0055681

Setting to resolved as there is no longer an environment where it can reproduced.
There is no problem in 2.x using Safari Version 10.0.3 (12602.4.8).

Related Changesets

MantisBT: master f67ec459

2015-12-14 20:49:05

vboctor

Details Diff
Support tagging from report issue page

Fixes 0009450
mod - bug_report.php Diff File
mod - bug_report_page.php Diff File
mod - config_defaults_inc.php Diff File
mod - core/print_api.php Diff File
mod - core/tag_api.php Diff File
mod - docbook/Admin_Guide/en-US/config/fields.xml Diff File
mod - tag_attach.php Diff File

MantisBT: master f008b8d8

2016-04-21 10:09:14

vboctor

Details Diff
Fix error on reporting issues w/ tags field hidden

Fixes 0009450
mod - bug_report.php Diff File

Issue History

Date Modified Username Field Change
2008-07-29 07:40 krmichal New Issue
2008-07-29 07:56 vboctor Status new => acknowledged
2012-08-13 19:13 XCompWiz Note Added: 0032558
2012-08-14 13:22 dregad Note Added: 0032563
2014-07-16 02:11 atrol Relationship added has duplicate 0017513
2014-07-24 05:23 XCompWiz Note Added: 0040966
2014-07-24 16:58 atrol Note Added: 0040976
2014-07-25 12:06 XCompWiz Note Added: 0040989
2014-07-25 12:08 XCompWiz Note Edited: 0040989 View Revisions
2014-08-08 16:43 dregad Note Added: 0041035
2015-08-03 10:25 hamx0r Note Added: 0051188
2015-08-03 11:15 dregad Note Added: 0051190
2015-12-26 19:30 vboctor Tag Attached: mantishub
2016-03-21 12:03 vboctor Assigned To => vboctor
2016-03-21 12:03 vboctor Status acknowledged => assigned
2016-03-21 12:07 vboctor Note Added: 0052824
2016-03-24 21:08 vboctor Changeset attached => MantisBT master f67ec459
2016-03-24 21:08 vboctor Status assigned => resolved
2016-03-24 21:08 vboctor Resolution open => fixed
2016-03-24 21:08 vboctor Fixed in Version => 1.3.0-rc.2
2016-04-04 11:04 atrol Target Version => 1.3.0-rc.2
2016-04-21 10:09 vboctor Changeset attached => MantisBT master f008b8d8
2016-06-07 04:26 atrol Status resolved => feedback
2016-06-07 04:26 atrol Resolution fixed => reopened
2016-06-07 04:26 atrol Note Added: 0053276
2016-06-07 04:27 atrol Note Edited: 0053276 View Revisions
2016-06-12 02:37 atrol Target Version 1.3.0-rc.2 => 1.3.0
2016-06-27 10:06 atrol Note Added: 0053470
2016-06-29 23:59 vboctor Note Added: 0053485
2016-07-01 04:47 atrol Note Added: 0053490
2016-07-01 19:08 atrol Note Added: 0053497
2016-07-10 07:57 atroladmin Target Version 1.3.0 => 1.3.1
2016-07-18 16:09 atrol Note Added: 0053634
2016-08-28 10:37 atrol Target Version 1.3.1 => 1.3.2
2016-09-08 13:21 atrol Relationship added related to 0021679
2016-10-02 19:36 atrol Target Version 1.3.2 => 1.3.3
2016-10-30 23:23 vboctor Target Version 1.3.3 => 1.3.4
2016-11-27 08:22 dregad Target Version 1.3.4 => 1.3.5
2016-12-28 21:54 vboctor Note Added: 0054859
2016-12-28 22:23 vboctor Relationship added related to 0022088
2016-12-29 08:18 atrol File Added: TagAttach.mov
2016-12-29 08:20 atrol Note Added: 0054867
2016-12-29 14:15 vboctor Note Added: 0054873
2016-12-29 17:10 atrol Note Added: 0054874
2016-12-30 16:24 atrol Target Version 1.3.5 => 1.3.6
2017-02-01 22:47 vboctor Target Version 1.3.6 => 1.3.7
2017-02-14 17:51 atrol Status feedback => resolved
2017-02-14 17:51 atrol Target Version 1.3.7 =>
2017-02-14 17:51 atrol Note Added: 0055681
2017-02-14 17:51 atrol Status resolved => closed
2017-02-14 17:51 atrol Resolution reopened => fixed