View Revisions: Issue #24600

Summary 0024600: BugFilterQuery - issue? - trying to add join & where conditions
Revision 2018-12-24 08:15 by dregad
Description

I need to do a customization on the query used to extract rows for the bug listing (view feature).

Because I was not able (my fault) to understand where the query is build and setted, the best solution I've found was to do changes on function filter_get_bug_rows()

I've tried to use $t_filter_query->add_join() and $t_filter_query->add_where() after :

# build a filter query, here for counting results
$t_filter_query = new BugFilterQuery(
        $t_filter,
        array(
            'query_type' => BugFilterQuery::QUERY_TYPE_LIST,
            'project_id' => $p_project_id,
            'user_id' => $p_user_id,
            'use_sticky' => $p_show_sticky
            )
        ); 

Everything OK retrieving COUNT, but when doing $t_rows = $t_filter_query->fetch_all() it seems that the pieces I've added via ->add_join(); and ->add_where() were ignored.

Do you have any tip/hint/pointer to some documentation?
Right now IMHO it seems a bug

best regards

Revision 2018-07-10 06:20 by fman
Description

I need to do a customization on the query used to extract rows for the bug listing (view feature).

Because I was not able (my fault) to understand where the query is build and setted, the best solution I've found was to do changes on function filter_get_bug_rows()

I've tried to use $t_filter_query->add_join() and $t_filter_query->add_where() after :

build a filter query, here for counting results

$t_filter_query = new BugFilterQuery(
        $t_filter,
        array(
            'query_type' => BugFilterQuery::QUERY_TYPE_LIST,
            'project_id' => $p_project_id,
            'user_id' => $p_user_id,
            'use_sticky' => $p_show_sticky
            )
        ); 

Everything OK retrieving COUNT, but when doing $t_rows = $t_filter_query->fetch_all() it seems that the pieces I've added via ->add_join(); and ->add_where() were ignored.

Do you have any tip/hint/pointer to some documentation?
Right now IMHO it seems a bug

best regards