View Issue Details

IDProjectCategoryView StatusLast Update
0012433mantisbtinstallationpublic2019-10-18 07:13
ReporterInspectorMorose Assigned Todregad  
PrioritynormalSeveritymajorReproducibilityN/A
Status closedResolutionno change required 
Product Version1.2.2 
Summary0012433: No 'Assign to' button on the Issue View page
Description

We have a fresh installation of Mantis which we are importing all our existing bugtracker information into. However when we view existing or newly created issues we are unable to change the assignment, as the 'Assign to' button is not displayed.

TagsNo tags attached.

Activities

squarebox

squarebox

2010-10-08 04:48

reporter   ~0026997

two things to check...
What is the role that user logging in has? The ability to assign by default is only available to developer, manager and administrator. I.e. if you were an "updater" you would be abel to edit everything but the assign-to field.

go into manage --> manage configuration --> workflow threshhold

If it still isn't appearing check your config_inc.php to see if you are using the g_bug_view_page_fields variable and that "handler" (i think this is assigned to field) is listed in the array.

InspectorMorose

InspectorMorose

2010-10-08 06:25

reporter   ~0026998

I am logging in as an administrator, in config_inc.php I have the following:-

$g_update_bug_assign_threshold = 'REPORTER';
$g_handle_bug_threshold = 'REPORTER';

$g_bug_view_page_fields is not present in config_inc.php, and regardless I am not concerned about the 'handler' field - it is displaying fine. What is missing is the 'Assign to' button, and the drop-down list of users.

I get the feeling something isn't quite right about the installation, but I have no knowledge of Mantis or PHP, so apologies for the lack of information.

InspectorMorose

InspectorMorose

2010-10-08 09:21

reporter   ~0026999

UPDATE:
I have 2 users testing our installation. One has administrator access, the other has manager.
They have both logged an issue, for different projects (both are 'private' projects).
When I view the issue raised by the admin user, I see an 'Assign to' button and drop-down list of users, however the only users displayed are also administrators even though I have explicitly added Reporters and Updaters to the project.
When I view the issue raised by the manager I do not see the 'Assign to' button or the drop-down list of users.

andrea.mills

andrea.mills

2011-08-08 13:56

reporter   ~0029397

I, too am having this issue that none of the users (admin included) can see the Assign To field in the action section (Edit, Monitor, Change Status, etc.)

It may be worth noting that I no longer have an "Assigned" status, as per custom project workflow.

Workflow Threshold allows reporters and up to assign and be assigned to issues.

andrea.mills

andrea.mills

2011-08-08 14:06

reporter   ~0029398

I solved the issue by setting $g_auto_set_status_to_assigned = OFF in config_inc.php. Though I don't really understand what the setting is supposed to mean.

dregad

dregad

2011-08-09 11:48

developer   ~0029414

InspectorMorose

Assuming you have not resolved your problem since last year: according to your last update 0012433:0026999, the problem is caused by a combination of

  • private projects (then you need to specifically assign users to it)
  • user's access level (by default only >= developers can be assigned issues to

You need to either assign one or more developers to your private project(s), or change the threshold for bug handling ($g_handle_bug_threshold) to a lower value

andrea.mills

If you really need to remove "Assigned" status from your workflow, you should also update $g_bug_assigned_status

andrea.mills

andrea.mills

2011-08-09 11:54

reporter   ~0029416

but what if I don't want the status to change just because it has been assigned to someone?

Issue History

Date Modified Username Field Change
2010-10-07 10:10 InspectorMorose New Issue
2010-10-08 04:48 squarebox Note Added: 0026997
2010-10-08 06:25 InspectorMorose Note Added: 0026998
2010-10-08 09:21 InspectorMorose Note Added: 0026999
2011-08-08 13:56 andrea.mills Note Added: 0029397
2011-08-08 14:06 andrea.mills Note Added: 0029398
2011-08-09 11:48 dregad Note Added: 0029414
2011-08-09 11:48 dregad Status new => resolved
2011-08-09 11:48 dregad Resolution open => no change required
2011-08-09 11:48 dregad Assigned To => dregad
2011-08-09 11:54 andrea.mills Note Added: 0029416
2011-08-29 07:05 atrol Status resolved => closed