View Issue Details

IDProjectCategoryView StatusLast Update
0022368mantisbtroadmappublic2017-02-24 13:46
Reporterevans Assigned Toatrol  
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionno change required 
PlatformWebOSWindows Seven 
Product Version1.3.3 
Summary0022368: Problems with resolution when changing Status
Description

I created some new status values ​​and some new values ​​for Resolution.
Those of resolution, I used the same numbering that was there, changing only the nomenclature.

The problem is that I can not change any fault status, because whenever I choose the resolution the following message appears:

Resolution "reopened" is not allowed for status "Under review".

This happens for all changes and for any X status resolution.

Steps To Reproduce

Click on change Status
Choose the resolution.

Additional Information

config_inc.php:

$s_resolution_enum_string = '10:aberto,20:corrigido,30:reaberto,40:incapaz de reproduzir,50:não corrigível,60:duplicado,70:não é um caso,80:suspenso,90:não será corrigido';

$g_status_enum_string = '10:Aberto, 11:Em análise,12:Rejeitado, 13:Corrigido, 14:Reaberto, 15:Adiado, 16:Cancelado, 17:Duplicado, 18:Pronto para Teste, 19:Pendente de Informação, 20:Retorno, 21:Em desenvolvimento, 50:Atribuído,90:Fechado';

custom_constant_inc.php:

status default

define( 'OPEN_', 10 );
define( 'FEEDBACK', 20 );
define( 'ASSIGNED', 50 );
define( 'Fechado', 90 );

status New

define( 'EM_ANÁLISE', 11 );
define( 'REJEITADO', 12 );
define( 'CORRIGIDO', 13 );
define( 'REABERTO', 14 );
define( 'ADIADO', 15 );
define( 'CANCELADO', 16 );
define( 'DUPLICADO', 17 );
define( 'PRONTO_PARA_TESTE', 18 );
define( 'PENDENTE_DE_INFORMAÇÃO', 19 );
define( 'EM_DESENVOLVIMENTO', 21 );

TagsNo tags attached.

Activities

evans

evans

2017-02-13 09:17

reporter  

step1.png (14,342 bytes)   
step1.png (14,342 bytes)   
step2.png (25,511 bytes)   
step2.png (25,511 bytes)   
step3.png (17,403 bytes)   
step3.png (17,403 bytes)   
evans

evans

2017-02-13 09:22

reporter   ~0055662

@atrol, can you help me to understand and solve this problem, please?

atrol

atrol

2017-02-13 09:59

developer   ~0055663

Last edited: 2017-02-13 09:59

View 2 revisions

evans,

this is how it works:

# Don't allow changing the Resolution in the following cases:
# - new status < RESOLVED and resolution denoting completion (>= fixed_threshold)
# - new status >= RESOLVED and resolution < fixed_threshold
# - resolution = REOPENED and current status < RESOLVED and new status >= RESOLVED

Refer to 0015653 for further details (particularly note 0015653:0037180

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Issue History

Date Modified Username Field Change
2017-02-13 09:17 evans New Issue
2017-02-13 09:17 evans File Added: step1.png
2017-02-13 09:17 evans File Added: step2.png
2017-02-13 09:17 evans File Added: step3.png
2017-02-13 09:22 evans Note Added: 0055662
2017-02-13 09:59 atrol Assigned To => atrol
2017-02-13 09:59 atrol Status new => resolved
2017-02-13 09:59 atrol Resolution open => no change required
2017-02-13 09:59 atrol Note Added: 0055663
2017-02-13 09:59 atrol Note Edited: 0055663 View Revisions
2017-02-24 13:46 atrol Status resolved => closed