View Issue Details

IDProjectCategoryView StatusLast Update
0023037mantisbtuipublic2019-04-21 02:53
ReporterneumannAssigned Tocproensa 
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version2.5.0 
Target Version2.21.0Fixed in Version2.21.0 
Summary0023037: Focus on project search
Description

If you want to search for a project you need to click on the Drop-Down Menu in the top right corner and then click again for the textfield.
The second click can be avoided if the focus is on the textfield after the first click.

Tagsmodern-ui

Relationships

related to 0022520 closedcproensa Improvements for project selection 
has duplicate 0022802 closedcproensa [feature request] autofocus for search input in menu selection 
has duplicate 0025584 closedcproensa Add autofocus to search in projects-list dropdown 
has duplicate 0025689 closeddregad selecting project not possible by keyboard (start letter) anymore 
related to 0025594 closedcproensa Projects menu search box should be hidden when having a small number of projects 
related to 0025535 new GUI - fast switching between Projekts are needed i'm a manager, its difficult to mange various projekts at the same time 

Activities

neumann

neumann

2017-06-20 09:23

reporter  

atrol

atrol

2017-06-20 17:03

developer   ~0057109

The second click can be avoided if the focus is on the textfield after the first click.

Right, but there would be one more click for users that use the up/down keys to choose a project (not sure if this is a typical use case)

emmguyot

emmguyot

2017-07-20 11:19

reporter   ~0057272

Hi,

I vote for this issue.
The change in the modern-ui of the select box should be improved : It isn't perfectly usable with keyboard (no first letter jump, no search, ...).

Maybe a keyboard shortcut to go to the search field would be a great way to deal with every one usage.

hloehnert

hloehnert

2017-11-16 07:38

reporter   ~0058209

I vote for this issue, too.
We have a quite big list of projects and at the moment our users complain about the necessity of scrolling up to the search field.
In my opinion entering any alphanumeric key should activate the search-field automatically with the content of the entered key.
There would be no impact for users, who are using the up/down keys.

Another maybe easier approach is to have the search-field always visible. Then at least it can be activated by a simple click without scrolling.

nedschlecht

nedschlecht

2018-01-15 07:33

reporter   ~0058550

imho this issue is mandatory, at leats the 2nd way, as hloehnert mentioned =>
Another maybe easier approach is to have the search-field always visible. Then at least it can be activated by a simple click without scrolling.

cproensa

cproensa

2019-03-12 18:10

developer   ~0061666

PR https://github.com/mantisbt/mantisbt/pull/1478

The second click can be avoided if the focus is on the textfield after the first click.

Right, but there would be one more click for users that use the up/down keys to choose a project (not sure if this is a typical use case)

Which is a bigger problem in touch interface, where having the focus right away will trigger the on-screen keyboard.

rogueresearch

rogueresearch

2019-03-18 16:23

reporter   ~0061696

+1 from me. Was going to type up a similar request, but found this. It would be nice if that search field was immediately focused so you could start typing straight away.

thE_iNviNciblE

thE_iNviNciblE

2019-03-19 00:01

reporter   ~0061705

Last edited: 2019-03-19 00:02

View 2 revisions

+1 for the mentioned features :-)

yes, search always visible sounds really nice, activating by a shortcut ALT + S

@cproensa: info links...

https://www.w3schools.com/jsref/event_onkeypress.asp
https://www.w3schools.com/jsref/obj_keyboardevent.asp

dregad

dregad

2019-04-11 10:56

developer   ~0061889

Assigning to @cproensa since he authored PR https://github.com/mantisbt/mantisbt/pull/1478

thE_iNviNciblE

thE_iNviNciblE

2019-04-13 01:18

reporter   ~0061914

ok will follow mantisbt now on github and i've forked mantisbt ...

how to spend source to mantisbt i'm new at contributing source to a open source plattform (over github, i can do an update and do an pull request?)

Related Changesets

MantisBT: master d47a7c60

2019-03-09 13:12:26

cproensa


Committer: dregad Details Diff
Projects list js

Changes and clean up for the navbar project list dropdown:

- When the dropdown is displayed:
- Apply focus to the active list element to position the
scrollable area over that element.
- If the list is empty, apply focus to the searchbox.

- Manage key events in the dropdown elements:
- When using the list and any key not related to list navigation is
pressed (for example, typing a text for searching), switch the focus
to the search box for it to receive the input.
- When using the searchbox and any key of up, down, pageup, pagedown,
is pressed, switch the focus to the list to allow navigating with
keyboard.
- Escape key in the search box will close the dropdown.

- Fix hiding the searchbox when only 10 or less items are displayed.

- Code clean-up:
- Move all the code related to the navbar projects menu to the same
place in the js file.
- Rename variables for less probability of collision with other
unrelated code.

Fixes: 0023037, 0025594
Affected Issues
0023037, 0025594
mod - js/common.js Diff File

MantisBT: master 9ba56530

2019-04-13 12:25:25

dregad

Details Diff
Fix projects selector navigation and search

Fixes 0023037, 0025594
PR https://github.com/mantisbt/mantisbt/pull/1478
Affected Issues
0023037, 0025594
mod - core/layout_api.php Diff File
mod - css/ace-mantis.css Diff File
mod - js/common.js Diff File

Issue History

Date Modified Username Field Change
2017-06-20 09:23 neumann New Issue
2017-06-20 09:23 neumann File Added: 2017_06_20_15_17_19_Eintrag_erfassen_MantisBT.png
2017-06-20 17:03 atrol Note Added: 0057109
2017-06-20 17:04 atrol Tag Attached: modern-ui
2017-07-20 11:19 emmguyot Note Added: 0057272
2017-08-19 07:46 cproensa Relationship added has duplicate 0022802
2017-08-19 07:49 cproensa Relationship added related to 0022520
2017-11-16 07:38 hloehnert Note Added: 0058209
2018-01-15 07:33 nedschlecht Note Added: 0058550
2019-03-09 07:17 cproensa Relationship added has duplicate 0025584
2019-03-12 18:10 cproensa Note Added: 0061666
2019-03-18 16:23 rogueresearch Note Added: 0061696
2019-03-19 00:01 thE_iNviNciblE Note Added: 0061705
2019-03-19 00:02 thE_iNviNciblE Note Edited: 0061705 View Revisions
2019-04-11 10:55 dregad Relationship added has duplicate 0025689
2019-04-11 10:56 dregad Assigned To => cproensa
2019-04-11 10:56 dregad Status new => assigned
2019-04-11 10:56 dregad Note Added: 0061889
2019-04-11 10:57 dregad Relationship added related to 0025594
2019-04-13 01:18 thE_iNviNciblE Note Added: 0061914
2019-04-13 12:26 dregad Relationship added related to 0025535
2019-04-13 12:31 dregad Changeset attached => MantisBT master d47a7c60
2019-04-13 12:31 dregad Changeset attached => MantisBT master 9ba56530
2019-04-13 12:31 dregad Assigned To cproensa => dregad
2019-04-13 12:31 dregad Status assigned => resolved
2019-04-13 12:31 dregad Resolution open => fixed
2019-04-13 12:31 dregad Fixed in Version => 2.21.0
2019-04-13 12:33 dregad Assigned To dregad => cproensa
2019-04-13 12:33 dregad Target Version => 2.21.0
2019-04-13 12:33 dregad Category feature => ui
2019-04-21 02:53 vboctor Status resolved => closed