View Issue Details

IDProjectCategoryView StatusLast Update
0024090mantisbtuipublic2018-03-31 19:58
Reporterclan_destinaAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version2.12.1Fixed in Version2.12.1 
Summary0024090: Username (Realnames) format not showing on timeline (my_view_page)
Description

If the variable: $g_show_realname = ON

The realname on the timeline should be displayed: Username (RealName) instead of just the RealName

TagsNo tags attached.

Relationships

related to 0024087 closedatrol $g_show_realname problem on 2.12.0 
related to 0024161 closedatrol Wrong color of username in timeline 
related to 0024069 closedvboctor Show realname not working 
related to 0024167 closedatrol History entries display realname instead of username 

Activities

atrol

atrol

2018-03-09 10:26

developer   ~0059143

Does adding the following line to file config_inc.php fix the issue?

$g_show_user_realname_threshold = ANYBODY;
fman

fman

2018-03-10 05:20

reporter   ~0059148

I'm checking the code because I'm not able to display realnames on combo, and seems that refactoring in 2.12.0 has introduced this problem
probably with new config option, but also there is a related error on
function user_get_expanded_name_from_row(), because realname is not used

If you want I will open a new issue related to this.

Anyway IMHO, the choice of 'username (realname)' at least on combos has to be configurable and not the default as seems to be on 2.12.0

fman

fman

2018-03-10 05:24

reporter   ~0059149

Common error write before test => the error on user_get_expanded_name_from_row() is that return value is:
realname (username) and not as described on function header:

  • Get display name in format "username (realname)"
fman

fman

2018-03-10 05:25

reporter   ~0059150

I've added $g_show_user_realname_threshold = VIEWER;

clan_destina

clan_destina

2018-03-10 17:34

reporter   ~0059160

$g_show_user_realname_threshold = ANYBODY;

The problem persists

vboctor

vboctor

2018-03-12 21:52

manager   ~0059190

Last edited: 2018-03-13 05:25

View 2 revisions

I have submitted a PR that changes timeline to use the standard API for displaying usernames
PR: https://github.com/mantisbt/mantisbt/pull/1317

This means:

  • Always display usernames
  • Hyperlink to user page which has more info about the user.
  • Have the user realname as a bubble.
  • Only show realname when $g_show_realname = ON and logged in user has access level >= $g_show_user_realname_threshold

Related Changesets

MantisBT: master-2.12 02d8b8af

2018-03-12 21:47:50

vboctor

Details Diff
Use standard API to display username in timeline

Fixes 0024090
Affected Issues
0024090
mod - core/classes/IssueAssignedTimelineEvent.class.php Diff File
mod - core/classes/IssueCreatedTimelineEvent.class.php Diff File
mod - core/classes/IssueMonitorTimelineEvent.class.php Diff File
mod - core/classes/IssueNoteCreatedTimelineEvent.class.php Diff File
mod - core/classes/IssueStatusChangeTimelineEvent.class.php Diff File
mod - core/classes/IssueTagTimelineEvent.class.php Diff File

Issue History

Date Modified Username Field Change
2018-03-08 20:06 clan_destina New Issue
2018-03-09 10:26 atrol Status new => feedback
2018-03-09 10:26 atrol Note Added: 0059143
2018-03-09 10:27 atrol Relationship added related to 0024087
2018-03-10 05:20 fman Note Added: 0059148
2018-03-10 05:24 fman Note Added: 0059149
2018-03-10 05:25 fman Note Added: 0059150
2018-03-10 12:43 atrol Relationship added related to 0024069
2018-03-10 17:34 clan_destina Note Added: 0059160
2018-03-10 17:34 clan_destina Status feedback => new
2018-03-12 21:52 vboctor Assigned To => vboctor
2018-03-12 21:52 vboctor Status new => assigned
2018-03-12 21:52 vboctor Target Version => 2.12.1
2018-03-12 21:52 vboctor Note Added: 0059190
2018-03-13 05:25 atrol Note Edited: 0059190 View Revisions
2018-03-17 22:23 vboctor Changeset attached => MantisBT master-2.12 02d8b8af
2018-03-17 22:23 vboctor Status assigned => resolved
2018-03-17 22:23 vboctor Resolution open => fixed
2018-03-18 04:58 atrol Fixed in Version => 2.12.1
2018-03-24 06:39 atrol Relationship added related to 0024161
2018-03-26 07:19 dregad Relationship added related to 0024167
2018-03-31 19:58 vboctor Status resolved => closed