View Issue Details

IDProjectCategoryView StatusLast Update
0024291mantisbtcustomizationpublic2018-04-23 03:16
ReporterYJLAssigned Toatrol 
PrioritylowSeveritytweakReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.13.1 
Target VersionFixed in Version 
Summary0024291: Can customize the Bug Id?
Description

I want customize in red box.
In mantis, it generating the bug id as 00000001,0000002...
I like to generating the bug id as 1,2,3...
Can I customize that field?

TagsNo tags attached.

Activities

YJL

YJL

2018-04-13 02:07

reporter  

nume.png (62,291 bytes)
nume.png (62,291 bytes)
atrol

atrol

2018-04-13 02:18

developer   ~0059552

YJL,

There is a configuration option $g_display_bug_padding

/**
 * The padding level when displaying bug ids
 *  The bug id will be padded with 0's up to the size given
 * @global integer $g_display_bug_padding
 */
$g_display_bug_padding = 7;

If this is not enough for you, you can write a plugin that uses event EVENT_DISPLAY_BUG_ID.
For more details, have a look at the MantisBT Developers Guide.

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Issue History

Date Modified Username Field Change
2018-04-13 02:07 YJL New Issue
2018-04-13 02:07 YJL File Added: nume.png
2018-04-13 02:18 atrol Assigned To => atrol
2018-04-13 02:18 atrol Status new => resolved
2018-04-13 02:18 atrol Resolution open => no change required
2018-04-13 02:18 atrol Note Added: 0059552
2018-04-23 03:16 atrol Status resolved => closed