View Issue Details

IDProjectCategoryView StatusLast Update
0024530mantisbtemailpublic2018-06-22 02:40
Reporterr.walidAssigned Toatrol 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.14.0 
Target VersionFixed in Version 
Summary0024530: Email Notification issue
Description

Hi all,

I have a project in wich, i have 4 reporters.
When developers publish a note or a reporter start an issue, some reporters get notifications via email , other dont.
All the reporters are on the same email service.

what can cause the problem ? why some reporters get emails and other dont ?

Thank you in advance for help

TagsNo tags attached.

Activities

atrol

atrol

2018-06-08 02:35

developer   ~0060045

Are you aware that (at least with default settings) users get just notifications for issues where they participated in some way?
For example, reporters get just notifications about issue changes if they reported the issue, added a note or are added to the monitor list.

r.walid

r.walid

2018-06-08 03:55

reporter   ~0060046

Yes, i know that.
All these reporters are in the same Project, if reporter 1 start an issue, the rest of the groupe must get notification. btw all report have the same profil config.
But i just notice that the reporters dont have the same email domain:
Reporter 1 : adresse@domain1.com : get notification
All the rest : adresse@domain2.com : dont get notification.

Can Mantis ban an email domain ? or the problem is the email service "domain2" ?

atrol

atrol

2018-06-09 09:07

developer   ~0060049

Can Mantis ban an email domain ?

Yes in a certain way. It prevents users from setting their e-mail address to one of a list of disposable domains.
But this is not your problem, as the checking for those domains is not done when sending e-mails.
To be complete sure, check the domain list in <YourMantis>//vendor/vboctor/disposable_email_checker/data/domains.txt

You can enable e-mail logging to find out if Mantis tries to send e-mail
e.g. set`$g_log_level = LOG_EMAIL | LOG_EMAIL_RECIPIENT | LOG_EMAIL_VERBOSE;
http://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.logging

If Mantis does try to send, there is a problem with your e-mail server or a spam filter or your e-mail client.
If Mantis does not try to send, there is a problem with your global e-mail notification setting or the individual e-mail notification setting of the user.

Feel free to reopen the issue if you should find out there is a bug in Mantis.

r.walid,

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system or how to deal with problems of your e-mail stack). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Issue History

Date Modified Username Field Change
2018-06-07 14:32 r.walid New Issue
2018-06-08 02:35 atrol Status new => feedback
2018-06-08 02:35 atrol Note Added: 0060045
2018-06-08 03:55 r.walid Note Added: 0060046
2018-06-08 03:55 r.walid Status feedback => new
2018-06-09 09:07 atrol Assigned To => atrol
2018-06-09 09:07 atrol Status new => resolved
2018-06-09 09:07 atrol Resolution open => no change required
2018-06-09 09:07 atrol Note Added: 0060049
2018-06-22 02:40 atrol Status resolved => closed