View Issue Details

IDProjectCategoryView StatusLast Update
0024548mantisbthtmlpublic2018-07-05 17:29
ReporteravezinaAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.14.0 
Target VersionFixed in Version 
Summary0024548: HREF not consistent, causes problem with IIS/ARR
Description

Bonjour, Hi,

I use MantisBT on a CentOS7 server, served by apache and php72. The website is behind a reverse proxy (ARR) on IIS.

Mantis PHP sometimes returns A tags this way : " /manage_tags_page.php ",
and on the plugin manager page, I get this : " <td class="center">manage_plugin_uninstall.php?name=Activity&manage_plugin_uninstall_token=20180618S7l0J4dqxtNVtrIEVo0qO1QEqGa8TC3C</td> ".

The missing front slash in the href breaks my reverse proxy rewrite. All other links works with the reverse proxy.

TagsNo tags attached.

Activities

avezina

avezina

2018-06-18 12:53

reporter   ~0060098

The problem was on my side, as Expected.

Sidenote : My initial description was note saved correctly. I wrote some HTML A tag, and they disapeared.

test : google.ca

atrol

atrol

2018-06-18 14:09

developer   ~0060101

Sidenote : My initial description was note saved correctly. I wrote some HTML A tag,

It's saved correctly, but not rendered the way you expect as it's not in the list of the configured valid tags $g_html_valid_tags = 'p, li, ul, ol, br, pre, i, b, u, em, strong';

Issue History

Date Modified Username Field Change
2018-06-18 12:46 avezina New Issue
2018-06-18 12:53 avezina Note Added: 0060098
2018-06-18 14:09 atrol Assigned To => atrol
2018-06-18 14:09 atrol Status new => resolved
2018-06-18 14:09 atrol Resolution open => no change required
2018-06-18 14:09 atrol Note Added: 0060101
2018-07-05 17:29 atrol Status resolved => closed