View Issue Details

IDProjectCategoryView StatusLast Update
0024628mantisbtmarkdownpublic2019-09-24 06:31
Reporterzringele Assigned Todregad  
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionopen 
Product Version2.12.1 
Target Version2.23.0 
Summary0024628: Double quotes " and lesser than sign < are shown as HTML entity within Markdown code blocks
Description

When Markdown option is enabled in MantisCoreFormatting plugin, HTML special chars within backticks are displayed as the corresponding entities.

  • double quote " &quot;
  • lesser than < &lt;

Same issue with code blocks

&quot; &lt;
TagsNo tags attached.

Relationships

related to 0024241 assigneddregad $g_html_valid_tags are not rendered if Markdown is enabled 
has duplicate 0025379 closedatrol Code in decription replacing html chars 
has duplicate 0023206 closeddregad Markdown shows html tags in code-block 
has duplicate 0024240 closeddregad XML in Markdown Code ist not rendered correct 
related to 0025405 closeddregad Links on summary, notes, and Details converted to other chars 
related to 0022175 closedjoel Markdown converting '<' within backticks to & lt; 
related to 0022246 closedjoel Markdown is converting '&' signs to (ampersand[amp;]) inside code block or backtick as well 
related to 0022315 assignedjoel Markdown converts " to " within code blocks and inline code 
related to 0024810 confirmed Markdown links/code always show HTML entities for Ampersand and Less-than sign 
child of 0022180 new Markdown issues following implementation in 0017920 

Activities

zringele

zringele

2018-07-24 05:42

reporter   ~0060309

& quot ; I mean

atrol

atrol

2018-07-24 05:59

developer   ~0060311

zringele,

I was not able to reproduce your problem with a fresh install of the latest stable MantisBT release (2.15.0 at the moment).

If you are running an older version, I recommend that you upgrade to the latest (download from [1]). If after doing so the problem persists, do not hesitate to reopen the issue and provide detailed step-by-step instructions to reproduce the issue; the following additional information may also be useful:

  • Exact version of MantisBT, PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?

[1] http://mantisbt.org/download.php

zringele

zringele

2018-07-24 08:14

reporter   ~0060312

Last edited: 2018-07-24 08:15

View 2 revisions

&quot;
Looks like the problem is only when using " inside a code tag like this &quot;

atrol

atrol

2018-07-24 15:06

developer   ~0060313

The PR that fixes 0024241 fixes also this issue.

dregad

dregad

2019-05-28 04:21

developer   ~0062147

Work-in-progress fix https://github.com/mantisbt/mantisbt/pull/1332

Issue History

Date Modified Username Field Change
2018-07-24 05:39 zringele New Issue
2018-07-24 05:42 zringele Note Added: 0060309
2018-07-24 05:59 atrol Assigned To => atrol
2018-07-24 05:59 atrol Status new => resolved
2018-07-24 05:59 atrol Resolution open => unable to reproduce
2018-07-24 05:59 atrol Note Added: 0060311
2018-07-24 08:14 zringele Note Added: 0060312
2018-07-24 08:15 zringele Note Edited: 0060312 View Revisions
2018-07-24 08:15 zringele Status resolved => feedback
2018-07-24 08:15 zringele Resolution unable to reproduce => reopened
2018-07-24 15:05 atrol Relationship added related to 0024241
2018-07-24 15:06 atrol Note Added: 0060313
2018-07-24 15:07 atrol Assigned To atrol => dregad
2018-07-24 15:07 atrol Status feedback => assigned
2018-07-24 15:07 atrol Resolution reopened => open
2018-07-24 15:07 atrol Product Version => 2.12.1
2018-07-24 15:07 atrol Target Version => 2.15.1
2018-07-24 15:07 atrol Description Updated View Revisions
2018-07-30 05:32 atrol Target Version 2.15.1 => 2.16.1
2018-09-04 05:54 atrol Target Version 2.16.1 => 2.18.0
2018-10-16 23:45 vboctor Target Version 2.18.0 => 2.19.0
2019-01-02 17:32 vboctor Target Version 2.19.0 => 2.20.0
2019-01-24 02:30 atrol Relationship added has duplicate 0025379
2019-02-01 02:32 atrol Relationship added related to 0023206
2019-02-01 02:34 atrol Relationship added related to 0025405
2019-03-16 20:33 vboctor Target Version 2.20.0 => 2.21.0
2019-04-21 05:25 atrol Target Version 2.21.0 => 2.22.0
2019-05-28 04:09 dregad Relationship replaced has duplicate 0023206
2019-05-28 04:14 dregad Summary When i have markdown enabled quotes are messed up => With markdown enabled, HTML special chars within quotes shown as quotes are messed up
2019-05-28 04:14 dregad Description Updated View Revisions
2019-05-28 04:15 dregad Description Updated View Revisions
2019-05-28 04:15 dregad Description Updated View Revisions
2019-05-28 04:16 dregad Description Updated View Revisions
2019-05-28 04:16 dregad Relationship added child of 0022180
2019-05-28 04:17 dregad Relationship added related to 0022175
2019-05-28 04:18 dregad Summary With markdown enabled, HTML special chars within quotes shown as quotes are messed up => With markdown enabled, double quotes " and lesser than < are shown as HTML entity
2019-05-28 04:19 dregad Relationship added related to 0022246
2019-05-28 04:19 dregad Relationship added related to 0022315
2019-05-28 04:21 dregad Note Added: 0062147
2019-05-28 04:27 dregad Relationship added has duplicate 0024240
2019-05-28 04:27 dregad Summary With markdown enabled, double quotes " and lesser than < are shown as HTML entity => Double quotes " and lesser than sign < are shown as HTML entity within Markdown code blocks
2019-05-28 04:28 dregad Relationship added related to 0024810
2019-08-25 13:02 vboctor Target Version 2.22.0 => 2.23.0