View Issue Details

IDProjectCategoryView StatusLast Update
0024718mantisbtjavascriptpublic2019-12-09 15:04
Reportercas Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.16.0 
Summary0024718: version of Typeahead wrongly defined
Description

in constant_inc.php the version of the typeahead library is stated as "1.1.1" wheer as opn the website (https://cdnjs.com/libraries/typeahead.js) it is stated as "0.11.1"

TagsNo tags attached.

Relationships

related to 0022256 closedsyncguru Unbundle JS libraris from Ace theme files 
related to 0026382 closeddregad Update corejs-typeahead.js library to 1.3.0 

Activities

atrol

atrol

2018-09-01 13:11

developer   ~0060584

The CDN obviously delivers version 1.1.1 from 2017.
It's a bit strange that the latest version on Github is 0.11.1.
I did a quick search and did not find source of version 1.1.1
@syncguru might comment, as he added this version in 2.2.0, see 0022256.

dregad

dregad

2019-11-23 14:06

developer   ~0063129

0.11.1 is the last release of the original library by Twitter (https://twitter.github.io/typeahead.js/), and they apparently stopped maintaining it.

We are actually using a fork, corejs-typeahead: https://github.com/corejavascript/typeahead.js so the version number is correct.

Issue History

Date Modified Username Field Change
2018-09-01 07:20 cas New Issue
2018-09-01 13:11 atrol Note Added: 0060584
2018-09-01 13:11 atrol Relationship added related to 0022256
2019-11-23 14:06 dregad Assigned To => dregad
2019-11-23 14:06 dregad Status new => resolved
2019-11-23 14:06 dregad Resolution open => no change required
2019-11-23 14:06 dregad Note Added: 0063129
2019-11-23 14:13 dregad Relationship added related to 0026382
2019-12-09 15:04 atrol Status resolved => closed