View Issue Details

IDProjectCategoryView StatusLast Update
0024737mantisbtuipublic2018-09-18 14:56
ReporterMantis LBAssigned Toatrol 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version2.16.0 
Target VersionFixed in Version 
Summary0024737: Blank page appears when submitting new issue
Description

If you don't select a category field and press the Submit issue button a blank page is shown (0 sized response).

If you don't fill in the Summary or Description fields a popup is shown to fill these in, which is what should happen for the Category field too.

This confuses our end users to no end :)

Steps To Reproduce

Report a new issue without selecting a Category, fill in Summary and Description, press Submit issue button.

TagsNo tags attached.

Activities

atrol

atrol

2018-09-06 06:00

developer   ~0060610

I was not able to reproduce using the given information.
I get the following message when trying to report an issue without selecting a category

APPLICATION ERROR # 11

A necessary field "category" was empty. Please recheck your inputs.

As a first step, check your web server / PHP logs for errors and warnings.

Mantis LB

Mantis LB

2018-09-06 06:46

reporter   ~0060611

Enabled logging and saw db requests regarding a custom plugin on successful submission (i.e. with category), thought I'd try disabling the plugin and then indeed the error you quote above indeed appears.
So this may be a plugin bug, will be conferring with the developers of that.

atrol

atrol

2018-09-06 07:33

developer   ~0060612

Thanks for the feedback.
Feel free to reopen if this is not a plugin bug.

Issue History

Date Modified Username Field Change
2018-09-06 05:26 Mantis LB New Issue
2018-09-06 06:00 atrol Status new => feedback
2018-09-06 06:00 atrol Note Added: 0060610
2018-09-06 06:46 Mantis LB Note Added: 0060611
2018-09-06 06:46 Mantis LB Status feedback => new
2018-09-06 07:33 atrol Assigned To => atrol
2018-09-06 07:33 atrol Status new => resolved
2018-09-06 07:33 atrol Resolution open => no change required
2018-09-06 07:33 atrol Note Added: 0060612
2018-09-18 14:56 atrol Status resolved => closed