View Issue Details

IDProjectCategoryView StatusLast Update
0024826mantisbtwebpagepublic2018-10-15 06:52
ReporterBourneAssigned Toatrol 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformOSSUSE Linux Enterprise serversOS VersionSP4
Product Version2.17.0 
Target VersionFixed in Version 
Summary0024826: There are no Report issues after deployment
Description

Hello , I don't have the "Report Issue" function after deployment. Please help me see it, thank you.

MantisBT Version:2.17.0
Schema Version:209
PHP Version:5.5.13
Database Driver:mysqli
Database Version, Description:5.6.41, 5.6.41

TagsNo tags attached.

Activities

Bourne

Bourne

2018-10-05 01:45

reporter   ~0060741

Somebody look at it, thanks

Bourne

Bourne

2018-10-05 03:16

reporter   ~0060742

Mantis 2.15.0, mantis 2.17.1 are installed separately, and there is no "report issue" function.

atrol

atrol

2018-10-05 04:49

developer   ~0060743

Bourne,

I was not able to reproduce your problem with a fresh install of the latest stable MantisBT release (2.17.1 at the moment).

Please provide detailed step-by-step instructions to reproduce the issue; the following additional information may also be useful:

  • Exact version of Web server and Browser
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
Bourne

Bourne

2018-10-05 05:53

reporter   ~0060745

Hi,
thank you for your support.
I used Mantis 2.15.0, mantis 2.17.1 after installation is the same problem, no changes to the code.
I did not deploy this on Centos 5.6 before, and I suspect that it is related to the SUSE (SUSE Linux 11 sp4) operating system.
Config_inc.php just did some basic configuration.
The main google browser, version number is 65.1233, but the same problem in IE10 and frefox, other browsers did not try.

The version information is as follows:
MantisBT Version:2.17.0
Apache Version: 2.17.0 and 2.17.1 and 2.15.1
Schema Version:209
PHP Version:5.5.13
Database Driver:mysqli
Database Version, Description:5.6.41, 5.6.41



config_inc.php (3,447 bytes)
<?php
# MantisBT - A PHP based bugtracking system

# MantisBT is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 2 of the License, or
# (at your option) any later version.
#
# MantisBT is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with MantisBT.  If not, see <http://www.gnu.org/licenses/>.

/**
 * @package MantisBT
 * @copyright Copyright (C) 2000 - 2002  Kenzaburo Ito - kenito@300baud.org
 * @copyright Copyright (C) 2002 MantisBT Team - mantisbt-dev@lists.sourceforge.net
 * @link http://www.mantisbt.org
 */

# This sample file contains the essential files that you MUST
# configure to your specific settings.  You may override settings
# from config_defaults_inc.php by uncommenting the config option
# and setting its value in this file.

# Rename this file to config_inc.php after configuration.

# In general the value OFF means the feature is disabled and ON means the
# feature is enabled.  Any other cases will have an explanation.

# Look in http://www.mantisbt.org/docs/ or config_defaults_inc.php for more
# detailed comments.

# --- Database Configuration ---
$g_hostname      = '192.168.1.102:3326';
$g_db_username   = 'root';
$g_db_password   = 'root';
$g_database_name = 'mantis215';
$g_db_type       = 'mysqli';

# --- Security ---
$g_crypto_master_salt = 'ldjC+Ceqr8WcVUZgWnCDf1O2Z2jaGSXLdoMmtZ3l7yI=';	#  Random string of at least 16 chars, unique to the installation
$g_default_timezone       = 'Asia/Shanghai';

# --- Anonymous Access / Signup ---
$g_allow_signup				= ON;
$g_allow_anonymous_login	= OFF;
$g_anonymous_account		= '';

# --- Email Configuration ---
$g_phpMailer_method		= PHPMAILER_METHOD_MAIL; # or PHPMAILER_METHOD_SMTP, PHPMAILER_METHOD_SENDMAIL
$g_smtp_host			= 'localhost';			# used with PHPMAILER_METHOD_SMTP
$g_smtp_username		= '';					# used with PHPMAILER_METHOD_SMTP
$g_smtp_password		= '';					# used with PHPMAILER_METHOD_SMTP
$g_webmaster_email      = 'webmaster@example.com';
$g_from_email           = 'noreply@example.com';	# the "From: " field in emails
$g_return_path_email    = 'admin@example.com';	# the return address for bounced mail
# $g_from_name			= 'Mantis Bug Tracker';
# $g_email_receive_own	= OFF;
# $g_email_send_using_cronjob = OFF;

# --- Attachments / File Uploads ---
# $g_allow_file_upload	= ON;
# $g_file_upload_method	= DATABASE; # or DISK
# $g_absolute_path_default_upload_folder = ''; # used with DISK, must contain trailing \ or /.
# $g_max_file_size		= 5000000;	# in bytes
# $g_preview_attachments_inline_max_size = 256 * 1024;
# $g_allowed_files		= '';		# extensions comma separated, e.g. 'php,html,java,exe,pl'
# $g_disallowed_files		= '';		# extensions comma separated

# --- Branding ---
# $g_window_title			= 'MantisBT';
# $g_logo_image			= 'images/mantis_logo.png';
# $g_favicon_image		= 'images/favicon.ico';

# --- Real names ---
# $g_show_realname = OFF;
# $g_show_user_realname_threshold = NOBODY;	# Set to access level (e.g. VIEWER, REPORTER, DEVELOPER, MANAGER, etc)

# --- Others ---
# $g_default_home_page = 'my_view_page.php';	# Set to name of page to go to after login
config_inc.php (3,447 bytes)
Bourne

Bourne

2018-10-05 06:12

reporter   ~0060746

Attachment php.ini



php.ini (69,500 bytes)
Bourne

Bourne

2018-10-05 06:21

reporter   ~0060747

Attached is the screenshot.



report_issue.png (46,497 bytes)
report_issue.png (46,497 bytes)
atrol

atrol

2018-10-05 06:34

developer   ~0060748

Did you create a project?

Bourne

Bourne

2018-10-05 06:43

reporter   ~0060749

thank you very much.
The problem was solved and a low-level mistake was made.

Issue History

Date Modified Username Field Change
2018-10-05 01:27 Bourne New Issue
2018-10-05 01:45 Bourne Note Added: 0060741
2018-10-05 03:16 Bourne Note Added: 0060742
2018-10-05 04:49 atrol Status new => feedback
2018-10-05 04:49 atrol Note Added: 0060743
2018-10-05 05:53 Bourne File Added: config_inc.php
2018-10-05 05:53 Bourne Note Added: 0060745
2018-10-05 05:53 Bourne Status feedback => new
2018-10-05 06:12 Bourne File Added: php.ini
2018-10-05 06:12 Bourne Note Added: 0060746
2018-10-05 06:21 Bourne File Added: report_issue.png
2018-10-05 06:21 Bourne Note Added: 0060747
2018-10-05 06:34 atrol Status new => feedback
2018-10-05 06:34 atrol Note Added: 0060748
2018-10-05 06:43 Bourne Note Added: 0060749
2018-10-05 06:43 Bourne Status feedback => new
2018-10-05 06:50 atrol Assigned To => atrol
2018-10-05 06:50 atrol Status new => resolved
2018-10-05 06:50 atrol Resolution open => no change required
2018-10-15 06:52 atrol Status resolved => closed