View Issue Details

IDProjectCategoryView StatusLast Update
0024847mantisbtbugtrackerpublic2018-10-25 17:24
Reportereeyrsja Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.17.1 
Target VersionFixed in Version 
Summary0024847: APPLICATION ERROR #502 when trying to move issue from one project to another
Description
  • Mantis 2.17.1 configured to store attachments to DISK
  • All projects are configured to use the default file attachment folder as spcifified in config_inc.php

When attempting to move an issue that has attachments from one project to another then APPLICATION ERROR #502 is triggered.

Additional Information

Recommended solution: Apply an additional check to prevent the error triggering if the old and new filenames of the attachments are the same:

Existing file_api.php :

1155:if( !file_exists( $t_disk_file_name_to ) ) {

Proposed change:
1155: if ($t_disk_file_name_from == $t_disk_file_name_to) {
1156: #pass - nothing to do
1157: } elseif( !file_exists( $t_disk_file_name_to ) ) {

TagsNo tags attached.

Relationships

related to 0024466 feedback Move Bug from one Project to Another 

Activities

atrol

atrol

2018-10-13 10:49

developer   ~0060803

All projects are configured to use the default file attachment folder as spcifified in config_inc.php

Are you sure?
I was not able to reproduce.

I would expect that line 1155 is not be executed in this case, as there is the following code starting from line 1134

    if( $t_path_from == $t_path_to ) {
        return;
    }
eeyrsja

eeyrsja

2018-10-15 04:12

reporter   ~0060805

Thanks for the quick reply. Sorry this turns out to be a configuration error:

Project 1 upload file path: D:\MantisFiles\
Project 2 upload file path: D:/MantisFiles/

This causes the if statement on line 1134 to not trigger. I have now reconfigured the upload file path for both projects and the application error is no longer found.

atrol

atrol

2018-10-15 04:25

developer   ~0060806

Thanks for telling the solution.

Issue History

Date Modified Username Field Change
2018-10-12 09:19 eeyrsja New Issue
2018-10-13 10:49 atrol Status new => feedback
2018-10-13 10:49 atrol Note Added: 0060803
2018-10-13 10:50 atrol Relationship added related to 0024466
2018-10-15 04:12 eeyrsja Note Added: 0060805
2018-10-15 04:12 eeyrsja Status feedback => new
2018-10-15 04:25 atrol Assigned To => atrol
2018-10-15 04:25 atrol Status new => resolved
2018-10-15 04:25 atrol Resolution open => no change required
2018-10-15 04:25 atrol Note Added: 0060806
2018-10-25 17:24 atrol Status resolved => closed