View Issue Details

IDProjectCategoryView StatusLast Update
0024930mantisbtbugtrackerpublic2018-11-13 03:00
ReporterAviaAssigned Toatrol 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version1.3.15 
Target VersionFixed in Version 
Summary0024930: No unique check on registration form.
Description

There isn’t check in place that checks if a user already exist with the same username.

Steps To Reproduce
  1. Fill out the registration form and submit with the username "Nick" twice.
Additional Information

This might lead to problems if multiple users uses the same username since there isn’t away to identify a unique user. A proposed solution is to use the email address as apart of the login credential on the login form and check for its uniqueness on the registration
form.

TagsNo tags attached.

Activities

atrol

atrol

2018-11-03 05:29

developer   ~0060908

In case this is not just a test but a real issue, please provide detailed step by step instructions to reproduce the issue.

atrol

atrol

2018-11-13 03:00

developer   ~0060952

Avia,

You did not provide any feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

Issue History

Date Modified Username Field Change
2018-11-02 19:58 Avia New Issue
2018-11-03 05:29 atrol Status new => feedback
2018-11-03 05:29 atrol Note Added: 0060908
2018-11-13 03:00 atrol Assigned To => atrol
2018-11-13 03:00 atrol Status feedback => resolved
2018-11-13 03:00 atrol Resolution open => no change required
2018-11-13 03:00 atrol Note Added: 0060952