View Issue Details

IDProjectCategoryView StatusLast Update
0024993mantisbtinstallationpublic2018-11-30 02:00
Reportermantis_noobAssigned Toatrol 
PriorityhighSeveritymajorReproducibilityN/A
Status closedResolutionno change required 
Product Version2.15.0 
Target VersionFixed in Version 
Summary0024993: Installation on RedHat - "Database not supported by PHP"
Description

Hello Forum!

I run a RedHat-Server with Apache and PHP 7.1 installed and I'd like to install Mantis 2.15.0.

Unfortunately, the install script fails due to the "Database not supported by PHP"-Error (look at screenshot). I've googled the error extensively but none of the solutions applied to me.

When I run 'php -m', the mysqli-Module is listed. Including the 'extension=mysqli.so"-Path into the php.ini doesn't help either.

Any advice would be much appreciated. Thanks guys!

TagsNo tags attached.

Activities

mantis_noob

mantis_noob

2018-11-19 08:44

reporter  

PHP_error.PNG (30,974 bytes)
PHP_error.PNG (30,974 bytes)
atrol

atrol

2018-11-19 09:25

developer   ~0060982

Last edited: 2018-11-19 09:26

View 2 revisions

I'd like to install Mantis 2.15.0.

I recommend to use latest version (2.18.0 at the moment)

Create a test script test.php in the root folder of your Mantis installation and run it in your browser.

<?php
phpinfo();

I am pretty sure, that mysqli will not be listed as installed extension.

mantis_noob,

This is not a bug or feature request for MantisBT (you are asking for help on how to configure your PHP installation). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

mantis_noob

mantis_noob

2018-11-19 09:28

reporter   ~0060983

Thank you for the quick response! I'll open a topic in the Mantis-Forum as requested.

atrol

atrol

2018-11-19 09:31

developer   ~0060984

I'll open a topic in the Mantis-Forum

A RedHat and/or CentOS forum might be a better place to ask.

Issue History

Date Modified Username Field Change
2018-11-19 08:44 mantis_noob New Issue
2018-11-19 08:44 mantis_noob File Added: PHP_error.PNG
2018-11-19 09:25 atrol Assigned To => atrol
2018-11-19 09:25 atrol Status new => resolved
2018-11-19 09:25 atrol Resolution open => no change required
2018-11-19 09:25 atrol Note Added: 0060982
2018-11-19 09:26 atrol Note Edited: 0060982 View Revisions
2018-11-19 09:28 mantis_noob Note Added: 0060983
2018-11-19 09:31 atrol Note Added: 0060984
2018-11-30 02:00 atrol Status resolved => closed