View Issue Details

IDProjectCategoryView StatusLast Update
0025204mantisbtcustom fieldspublic2019-02-10 08:32
ReporterAlokSharma Assigned Toatrol  
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Product Version2.15.0 
Target VersionFixed in Version 
Summary0025204: Custom field of user type ->All users.
Description

Custom field of user type ->All users.

Additional Information

Hi Team,

can anyone help me regarding this one, i want to add a custom field that would populate all the users(reporter/dev/manager)

I tried with many patches and diff file available but nothing seems to work with this mantis version 2.15.0.
As there has been many changes in the latest core files (core/filter_api.php) of 2.15.0.

Can anyone help me with any patches for 2.15.0 version, Its urgently required?

TagsNo tags attached.

Relationships

related to 0025223 feedback Custom Field Exactly like the default "Assigned To" Field with all email notifications about issue. 

Activities

atrol

atrol

2019-01-11 03:06

developer   ~0061205

AlokSharma,

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Before that, read https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.customize.customfields.dynamic

AlokSharma

AlokSharma

2019-01-14 06:08

reporter   ~0061227

Thanks @atrol

I checked and was able to populate users as dynamic enum custom field, but again my basic request was to create an custom filed just as the "Assigned to" in the report bug page, which when used the selected users are notified with an email about the issue,
Which is not happening in the custom enum dynamic field, just users names are populating.

Don't you think its a feature request? to send email notification too, in the Custom field of User type. Please inform if i am missing any thing here.

Thanks & Regards



2019-01-14_163010.PNG (131,900 bytes)
2019-01-14_163010.PNG (131,900 bytes)
dregad

dregad

2019-01-14 10:43

developer   ~0061230

You won't be able to achieve what you want with just custom fields.

Sure it could be considered as a feature request to have user-linked CF that includes selected user(s ?) in e-mail notifications, but this is not what you requested above.

AlokSharma

AlokSharma

2019-01-14 12:11

reporter   ~0061231

Hey @dregad Thanks for replying.

Can you help me with any patches available for v2.15.0 and above, because i tried ever similar patch available in similar issue's like 0003790,0004640,0014565 but some core files are completely changed and now they won't support the previous patches.

I just want the selected users to be notified.

Thanks & Regards

atrol

atrol

2019-01-15 03:17

developer   ~0061232

Last edited: 2019-01-15 03:18

View 2 revisions

While seeing your latest note and 0025223.
@AlokSharma isn't the existing Monitor / Send a Reminder functionality (Add users that are notified) what you want?

AlokSharma

AlokSharma

2019-01-15 04:16

reporter   ~0061234

@atrol
Yes atrol I am looking for something similar to the Monitor Users Functionality, but I want that functionality to be seen in the report bug page with predefined Username values(static/dynamic).

And Currently with the Monitor Issue Functionality-> the user doesn't receive an email on issue creation, he gets informed only when the issue is updated, besides the monitor functionality is not present in the report issue page.

dregad

dregad

2019-01-15 05:31

developer   ~0061235

In response to 0025204:0061231...
I'm sorry but I do not have any spare time to help you with that, not to mention that I have no idea what patches you are referring to.
Furthermore, I would advise against modifying MantisBT code, and recommand that you develop a simple plugin that does what you want instead.

AlokSharma

AlokSharma

2019-01-15 06:10

reporter   ~0061239

Thanks @dregad anyways.

AlokSharma

AlokSharma

2019-01-29 01:33

reporter   ~0061316

Hello @atrol

But is there any way i could possibly bring this -> "Send A reminder" functionality in the bug report Page?

atrol

atrol

2019-01-30 14:14

developer   ~0061331

But is there any way i could possibly bring this -> "Send A reminder" functionality in the bug report Page?

There is no better answer than what @dregad wrote before

and recommand that you develop a simple plugin that does what you want instead.

atrol

atrol

2019-01-30 14:18

developer   ~0061332

Didn't have a deeper look, but sounds like this could be a good point to start https://github.com/mantisbt-plugins/CustomReporter

atrol

atrol

2019-01-30 14:34

developer   ~0061333

Your original request was

Custom field of user type ->All users.

This is covered by my answer in 0025204:0061205

but again my basic request was to create an custom filed just as the "Assigned to" in the report bug page, which when used the selected users are notified with an email about the issue,

This was not in your original request, but if I understand right this request is covered by your issue 0025223, so we do not have to talk about this feature in the current issue.

Your 3rd issue

"Send A reminder" functionality in the bug report Page

can be solved by writing a plugin.

Therefore I set this issue to resolved.

Feel free to create a separate issue for any open feature request.
Keep in mind that dealing with different topics in a single issue is hard to follow up.

Issue History

Date Modified Username Field Change
2019-01-11 02:59 AlokSharma New Issue
2019-01-11 03:06 atrol Assigned To => atrol
2019-01-11 03:06 atrol Status new => resolved
2019-01-11 03:06 atrol Resolution open => no change required
2019-01-11 03:06 atrol Note Added: 0061205
2019-01-14 06:08 AlokSharma File Added: 2019-01-14_163010.PNG
2019-01-14 06:08 AlokSharma Note Added: 0061227
2019-01-14 06:10 AlokSharma Status resolved => feedback
2019-01-14 06:10 AlokSharma Resolution no change required => reopened
2019-01-14 10:43 dregad Note Added: 0061230
2019-01-14 12:11 AlokSharma Note Added: 0061231
2019-01-14 12:11 AlokSharma Status feedback => assigned
2019-01-15 03:17 atrol Assigned To atrol =>
2019-01-15 03:17 atrol Status assigned => feedback
2019-01-15 03:17 atrol Note Added: 0061232
2019-01-15 03:18 atrol Note Edited: 0061232 View Revisions
2019-01-15 04:16 AlokSharma Note Added: 0061234
2019-01-15 04:16 AlokSharma Status feedback => new
2019-01-15 05:31 dregad Note Added: 0061235
2019-01-15 05:33 dregad Relationship added related to 0025223
2019-01-15 06:10 AlokSharma Note Added: 0061239
2019-01-29 01:33 AlokSharma Note Added: 0061316
2019-01-30 14:14 atrol Note Added: 0061331
2019-01-30 14:18 atrol Note Added: 0061332
2019-01-30 14:34 atrol Assigned To => atrol
2019-01-30 14:34 atrol Status new => resolved
2019-01-30 14:34 atrol Resolution reopened => no change required
2019-01-30 14:34 atrol Note Added: 0061333
2019-02-10 08:32 atrol Status resolved => closed