View Issue Details

IDProjectCategoryView StatusLast Update
0025388mantisbtadministrationpublic2019-02-17 13:52
ReportertitovetchAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.19.0 
Target VersionFixed in Version 
Summary0025388: access denied message while changing status to close
Description

i don't know why no one can change status to close even the administrator

TagsNo tags attached.

Activities

titovetch

titovetch

2019-01-27 06:03

reporter  

access denied.JPG (11,133 bytes)
access denied.JPG (11,133 bytes)
atrol

atrol

2019-01-27 09:29

developer   ~0061307

titovetch,

I assume this is not a bug, but caused by your customized status values I see at 0025357:0061305.

If you think it's a bug, be aware that the provided information is not sufficient to reproduce the issue and to provide any help in resolving the issue. A complete and detailed description is required for the support team to get a clear understanding of the problem.

Please provide detailed, step-by-step instructions to reproduce the issue.

  • Exact version of MantisBT, PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
titovetch

titovetch

2019-02-03 09:57

reporter   ~0061389

i resolve issue 0025357 but i see this might be a bug:

1- i have created new customized status [100:fixed]
2- in workflow i set status [fixed] to be able to change status to [close]
3- issue is not happened anymore after amending the new status to be lower than [90:closed]

what happened :
1-filterer select wrong values because its greater than [90:close] 0025357
2- even admin can't change the status to close because its give access denied

Exact version of MantisBT, PHP, Database, Web server, Browser and Operating System
--MySQL 5.7.24 , PHP 7.1.22 , Apache 2.4.37 ,google chomre
Relevant customizations (e.g. changes in config_inc.php, etc)
-- the normal changes to have customized status
Installed plugins or custom functions ?
--no
Was the MantisBT source code modified in any way ?
--no

atrol

atrol

2019-02-07 13:18

developer   ~0061442

This happened because you tried to close an issue that was already closed.
Closed means that current status is greater or equal than setting $g_bug_closed_status_threshold.
Default setting for it is 90:closed, so your 100 :fixed was already closed.

Issue History

Date Modified Username Field Change
2019-01-27 06:03 titovetch New Issue
2019-01-27 06:03 titovetch File Added: access denied.JPG
2019-01-27 09:29 atrol Status new => feedback
2019-01-27 09:29 atrol Note Added: 0061307
2019-02-03 09:57 titovetch Note Added: 0061389
2019-02-03 09:57 titovetch Status feedback => new
2019-02-07 13:18 atrol Assigned To => atrol
2019-02-07 13:18 atrol Status new => resolved
2019-02-07 13:18 atrol Resolution open => no change required
2019-02-07 13:18 atrol Note Added: 0061442
2019-02-17 13:52 atrol Status resolved => closed