View Issue Details

IDProjectCategoryView StatusLast Update
0025513mantisbtbugtrackerpublic2019-03-10 16:16
Reporterdfranco Assigned Toatrol  
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.19.0 
Target VersionFixed in Version 
Summary0025513: User cannot see his own notes and attachment in bug report
Description

Signed in as user xyz

Create a new bug report or add notes/attachments to a bug report works without error.

But, added notes / attachment by the same user are not displayed in the bug report, except in the bug report history.

Steps To Reproduce

Add a notes or an attachment to a bug report and notice that added notes or attachment are not accessible (history ok but that's all).

TagsNo tags attached.

Relationships

related to 0025512 closedatrol Uploaded attachment not visible anymore 

Activities

dfranco

dfranco

2019-02-24 05:21

reporter   ~0061556

I'v made some tests with a new account and the issue does not appear with this new user.

Something broken with my current account maybe ?
How can I fix this ?

atrol

atrol

2019-02-24 05:24

developer   ~0061557

dfranco,

The provided information is not sufficient to reproduce the issue and to provide any help in resolving it. A complete and detailed description is required for the support team to get a clear understanding of the problem.

Please provide detailed, step-by-step instructions to reproduce the issue; the additional information listed below may also be useful:

  • Exact version of PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
dfranco

dfranco

2019-02-24 05:38

reporter   ~0061558

To reproduce the issue

  1. Sign in with my account
  2. Add a note to an already existing bug report
  3. Display the updated bug report
  4. Notice that the note added few seconds ago is not visible, but appear in the history.

System details

PHP 7.0.33, Apache 2.4.25 on Debian 9.8 (Stretch)
Firefox 65.0.1 on OS X

  • No extra plugins installed
  • MantisBT source not hacked
  • custom config attached

MariaDB 10.1.37



mantis_config.txt (720 bytes)
$g_hostname               = 'XXXXXXXXXXXX';
$g_db_type                = 'mysqli';
$g_database_name          = 'XXXXXXXXXXXX';
$g_db_username            = 'XXXXXXXXXXXX';
$g_db_password            = 'XXXXXXXXXXXX';

$g_default_timezone       = 'Europe/Berlin';

$g_crypto_master_salt     = 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX';

$g_allow_anonymous_login  = ON;
$g_anonymous_account 	  = 'anonymous';

$g_max_failed_login_count = 3;

$g_signup_use_captcha = true;

# --- Email Configuration ---
$g_webmaster_email      = 'XXXXXXXXXXXX@XXXXXXXXXXXX';
$g_from_email           = 'XXXXXXXXXXXX@XXXXXXXXXXXX';        
$g_return_path_email    = 'XXXXXXXXXXXX@XXXXXXXXXXXX';  

$g_allowed_files = 'zip,png,gif,jpg,jpeg,txt,csv';
mantis_config.txt (720 bytes)
atrol

atrol

2019-02-24 06:04

developer   ~0061560

To reproduce the issue
Sign in with my account

The steps provided are enough for you to reproduce the issue, but I cannot reproduce it this way.

As a first step, can you provide a link similar to the one you provided in 0025512 where someone can see an example where this issues occurs ?
https://bugs.bacula-web.org/view.php?id=262

Run also admin/check/index.php and fix any errors you might encounter.

dfranco

dfranco

2019-02-24 06:26

reporter   ~0061561

it's hard to reproduce as it the issue happen only with my account (manager).

Everything looks good if you use a "public" link, but once I've signed in with my account, I don't see added notes/attachments.

Notes that creating a new fake account, the issue disappear.

admin/check/index.php does not display any issue.

atrol

atrol

2019-02-24 06:39

developer   ~0061562

happen only with my account (manager)

Only your account or any other manager account?

Check attachment settings on page Manage > Permissions Report.
Maybe someone changed settings for Managers.

dfranco

dfranco

2019-02-24 07:29

reporter   ~0061564

After some tests, the issue append only with my account (which is manager of the project).

From Manage / Manage configuration / Permissions report / Attachments

View list of attachments (everyone)
Download attachments (everyone)
Delete attachments (developer, manager, administrator)
Upload issue attachments (everyone except viewer)

dfranco

dfranco

2019-02-24 08:01

reporter   ~0061565

I've found were the problem was, you can close this issue.

Thanks for your help.

atrol

atrol

2019-02-24 09:44

developer   ~0061566

Thanks for your feedback

I've found were the problem was

To help other users, it would be good if you could add a note about the root cause.

dfranco

dfranco

2019-02-25 04:22

reporter   ~0061569

It was a "dirty" altered MantisBT schema which I've fixed.
Once I've reverted the change, everything worked as expected.

Thanks again for your help.

Issue History

Date Modified Username Field Change
2019-02-24 05:17 dfranco New Issue
2019-02-24 05:21 dfranco Note Added: 0061556
2019-02-24 05:24 atrol Status new => feedback
2019-02-24 05:24 atrol Note Added: 0061557
2019-02-24 05:38 dfranco File Added: mantis_config.txt
2019-02-24 05:38 dfranco Note Added: 0061558
2019-02-24 05:38 dfranco Status feedback => new
2019-02-24 06:00 atrol Relationship added related to 0025512
2019-02-24 06:04 atrol Status new => feedback
2019-02-24 06:04 atrol Note Added: 0061560
2019-02-24 06:26 dfranco Note Added: 0061561
2019-02-24 06:26 dfranco Status feedback => new
2019-02-24 06:39 atrol Status new => feedback
2019-02-24 06:39 atrol Note Added: 0061562
2019-02-24 07:29 dfranco Note Added: 0061564
2019-02-24 07:29 dfranco Status feedback => new
2019-02-24 08:01 dfranco Note Added: 0061565
2019-02-24 09:44 atrol Assigned To => atrol
2019-02-24 09:44 atrol Status new => resolved
2019-02-24 09:44 atrol Resolution open => no change required
2019-02-24 09:44 atrol Note Added: 0061566
2019-02-25 04:22 dfranco Note Added: 0061569
2019-03-10 16:16 atrol Status resolved => closed