View Issue Details

IDProjectCategoryView StatusLast Update
0025516mantisbtdb mysqlpublic2019-03-10 16:16
Reporterrasheeda Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.18.0 
Target VersionFixed in Version 
Summary0025516: Restoring database - by using import
Description

I am trying to mysql database export and import to check for recovery mechanism.

I have taken back in .sql format by 'export' and then using same file by 'import' from php admin page and get following error.

SQL query:

--
-- Database: bugtracker


--
-- Table structure for table mantis_api_token_table

CREATE TABLE IF NOT EXISTS mantis_api_token_table (
id int(10) unsigned NOT NULL AUTO_INCREMENT,
user_id int(10) unsigned NOT NULL DEFAULT '0',
name varchar(128) NOT NULL,
hash varchar(128) NOT NULL,
date_created int(10) unsigned NOT NULL DEFAULT '1',
date_used int(10) unsigned NOT NULL DEFAULT '1',
PRIMARY KEY (id),
UNIQUE KEY idx_user_id_name (user_id,name)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1 ;
MySQL said: Documentation

#1046 - Aucune base n'a été sélectionnée

TagsNo tags attached.

Activities

rasheeda

rasheeda

2019-02-25 03:24

reporter  

el-apps-wamp2x..png (18,714 bytes)
el-apps-wamp2x..png (18,714 bytes)
atrol

atrol

2019-02-25 05:16

developer   ~0061570

rasheeda,

From what I see, you did not create / select a database for the import.

This is not a bug or feature request for MantisBT (you are asking for help on how to export/import a MySQL database using PHPMyAdmin ). I am therefore resolving this issue as "no change required".

Please use a MySQL or PHPMyAdmin forum to get support.

Issue History

Date Modified Username Field Change
2019-02-25 03:24 rasheeda New Issue
2019-02-25 03:24 rasheeda File Added: el-apps-wamp2x..png
2019-02-25 05:16 atrol Assigned To => atrol
2019-02-25 05:16 atrol Status new => resolved
2019-02-25 05:16 atrol Resolution open => no change required
2019-02-25 05:16 atrol Note Added: 0061570
2019-03-10 16:16 atrol Status resolved => closed