View Issue Details

IDProjectCategoryView StatusLast Update
0025596mantisbtemailpublic2019-03-23 14:33
ReporterrasheedaAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.18.0 
Target VersionFixed in Version 
Summary0025596: smtp email delivery failed - for external email ids
Description
  1. The smtp email sender is configured as below:
    #$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
    #$g_smtp_host = 'mail.xxx.com';
    #$g_smtp_username = '';
    #$g_smtp_password = '';
    #$g_smtp_connection_mode = '';
    #$g_from_email = 'rasheeda@xxx.com'; # the "From: " field in emails
    #$g_smtp_port = 25;
    #$g_from_name = 'HelpDesk';

the above setting is able to delivery email within the domain, but external emails to hotmail, gmail is not getting delivered.

  1. Once error is sending email, all subsequent emails are also not sent.

smtp.gamil.com setting is able send all the email internal/external.

Thanks for your support.

TagsNo tags attached.

Activities

dregad

dregad

2019-03-13 07:32

developer   ~0061668

Last edited: 2019-03-13 07:32

View 2 revisions

You can try to set $g_log_level = LOG_EMAIL_VERBOSE to get additional details about MantisBT interactions with the SMTP server.

That being said, considering that

the above setting is able to delivery email within the domain

it most likely not a bug with MantisBT, but an issue with your SMTP server's configuration.

Issue History

Date Modified Username Field Change
2019-03-13 05:30 rasheeda New Issue
2019-03-13 07:32 dregad Assigned To => dregad
2019-03-13 07:32 dregad Status new => resolved
2019-03-13 07:32 dregad Resolution open => no change required
2019-03-13 07:32 dregad Note Added: 0061668
2019-03-13 07:32 dregad Note Edited: 0061668 View Revisions
2019-03-23 14:33 atrol Status resolved => closed