View Issue Details

IDProjectCategoryView StatusLast Update
0025618mantisbtuipublic2019-04-05 17:14
Reporterrogueresearch Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.19.0 
Target VersionFixed in Version 
Summary0025618: "Activities" section often has first column too wide, second column too narrow
Description

When looking at several issues in our install of mantis, in the "Activities" section, we often see that the first column is much wider than necessary, and that the space could be better used my making the second column (with image) wider.

This reproduces for some issues, but not others. It behaves consistently per-issue. Not sure what's different between the issues where it occurs and doesn't.

Easier to see with images, see attached.

TagsNo tags attached.

Activities

rogueresearch

rogueresearch

2019-03-18 10:32

reporter  

GoodColumns.png (73,973 bytes)
GoodColumns.png (73,973 bytes)
BadColumns.png (118,971 bytes)
BadColumns.png (118,971 bytes)
atrol

atrol

2019-03-18 12:12

developer   ~0061687

Your 2nd screen shot shows different colors than the 1st one.
I assume you tweaked original CSS of Mantis in the 2nd installation.
Maybe this is also the reason for the behavior.

rogueresearch

rogueresearch

2019-03-18 12:55

reporter   ~0061690

Thanks for the speedy reply!

I wouldn't even know how to change CSS, as I'm not a web developer. :)

But your observation was apt. It's a difference between browsers!

In Safari:

  • the column widths are buggy
  • the colour is purple, not blue
  • the note text is bold

In Firefox:

  • the column widths are sensible
  • the colour is blue, not purple
  • the note text is not bold

Here's two pictures of the same issue from both browsers.



Firefox.png (64,859 bytes)
Firefox.png (64,859 bytes)
Safari.png (76,864 bytes)
Safari.png (76,864 bytes)
atrol

atrol

2019-03-18 13:27

developer   ~0061691

Clearing browser cache might fix the issue.

rogueresearch

rogueresearch

2019-03-18 14:04

reporter   ~0061692

Confirmed! Glad this thought occurred to you! I really shouldn't assume my browser is bug free. :)

atrol

atrol

2019-03-18 18:11

developer   ~0061702

I really shouldn't assume my browser is bug free

You shouldn't, but this is not that simple and could be done better in Mantis.
Your browser used a cached version of default.css from your previous 1.2 Mantis.
https://stackoverflow.com/questions/460389/browser-caching-of-css-files.

Issue History

Date Modified Username Field Change
2019-03-18 10:32 rogueresearch New Issue
2019-03-18 10:32 rogueresearch File Added: GoodColumns.png
2019-03-18 10:32 rogueresearch File Added: BadColumns.png
2019-03-18 12:12 atrol Status new => feedback
2019-03-18 12:12 atrol Note Added: 0061687
2019-03-18 12:55 rogueresearch File Added: Firefox.png
2019-03-18 12:55 rogueresearch File Added: Safari.png
2019-03-18 12:55 rogueresearch Note Added: 0061690
2019-03-18 12:55 rogueresearch Status feedback => new
2019-03-18 13:27 atrol Status new => feedback
2019-03-18 13:27 atrol Note Added: 0061691
2019-03-18 14:04 rogueresearch Note Added: 0061692
2019-03-18 14:04 rogueresearch Status feedback => new
2019-03-18 18:11 atrol Assigned To => atrol
2019-03-18 18:11 atrol Status new => resolved
2019-03-18 18:11 atrol Resolution open => no change required
2019-03-18 18:11 atrol Note Added: 0061702
2019-04-05 17:14 atrol Status resolved => closed